summaryrefslogtreecommitdiffstats
path: root/phpMyAdmin.spec
diff options
context:
space:
mode:
Diffstat (limited to 'phpMyAdmin.spec')
-rw-r--r--phpMyAdmin.spec330
1 files changed, 189 insertions, 141 deletions
diff --git a/phpMyAdmin.spec b/phpMyAdmin.spec
index 62df4c2..6f2f6ad 100644
--- a/phpMyAdmin.spec
+++ b/phpMyAdmin.spec
@@ -1,7 +1,7 @@
+# remirepo:4
# remirepo spec file for phpMyAdmin
-# remirepo:3
#
-# Copyright (c) 2008-2020 Remi Collet
+# Copyright (c) 2008-2023 Remi Collet
#
# Fedora spec file for phpMyAdmin
#
@@ -11,6 +11,7 @@
# Please, preserve the changelog entries
#
%{!?_pkgdocdir: %global _pkgdocdir %{_datadir}/doc/%{name}-%{version}}
+
# remirepo:1
%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
# nginx 1.6 with nginx-filesystem
@@ -23,37 +24,49 @@
%global with_httpd 0
%endif
-%global upstream_version 5.0.2
+%global upstream_version 5.2.1
#global upstream_prever rc1
Name: phpMyAdmin
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: A web interface for MySQL and MariaDB
+# phpMyAdmin is GPL-2.0-or-later
# MIT (js/jquery/, js/jqplot, js/codemirror/, js/tracekit/)
-# BSD (js/openlayers/)
-# GPLv2+ (the rest)
-License: GPLv2+ and MIT and BSD
+# BSD 2-Clause (js/openlayers/)
+# for PHP library see generated bundled list above
+License: GPL-2.0-or-later AND MIT AND BSD 2-Clause AND BSD 3-Clause AND LGPL-3.0-or-later AND MPL-2.0 AND ISC
URL: https://www.phpmyadmin.net/
Source0: https://files.phpmyadmin.net/%{name}/%{upstream_version}%{?upstream_prever:-%upstream_prever}/%{name}-%{upstream_version}%{?upstream_prever:-%upstream_prever}-all-languages.tar.xz
Source1: https://files.phpmyadmin.net/%{name}/%{upstream_version}%{?upstream_prever:-%upstream_prever}/%{name}-%{upstream_version}%{?upstream_prever:-%upstream_prever}-all-languages.tar.xz.asc
Source2: phpMyAdmin.htaccess
Source3: phpMyAdmin.nginx
Source4: https://files.phpmyadmin.net/phpmyadmin.keyring
-# remirepo:1
-Source10: phpMyAdmin.htaccess22
+# List name / version / license of bundled libraries
+Source5: phpMyAdmin-bundled.php
# Redirect to system certificates
Patch0: phpMyAdmin-certs.patch
BuildArch: noarch
BuildRequires: gnupg2
+# to run phpMyAdmin-bundled.php
+BuildRequires: php(language) >= 7.2.5
+BuildRequires: php-cli
+BuildRequires: php-json
Requires(post): coreutils sed
Requires: webserver
%if %{with_nginx}
-Requires: nginx-filesystem
+# remirepo:4
+# Temporarily not mandatory to allow nginx for nginx repo
+%if 1
+Recommends: nginx-filesystem
+%else
+Requires: nginx-filesystem
+# remirepo:1
+%endif
%endif
%if %{with_httpd}
Requires: httpd-filesystem
@@ -61,106 +74,112 @@ Requires: php(httpd)
Suggests: httpd
%endif
# From composer.json, "require": {
-# "php": "^7.1.3",
+# "php": "^7.2.5 || ^8.0",
# "ext-hash": "*",
# "ext-iconv": "*",
# "ext-json": "*",
# "ext-mysqli": "*",
+# "ext-openssl": "*",
# "ext-pcre": "*",
# "ext-xml": "*",
# "google/recaptcha": "^1.1",
-# "phpmyadmin/motranslator": "^4.0",
+# "nikic/fast-route": "^1.3",
+# "phpmyadmin/motranslator": "^5.0",
# "phpmyadmin/shapefile": "^2.0",
-# "phpmyadmin/sql-parser": "^5.0",
-# "phpmyadmin/twig-i18n-extension": "^2.0",
+# "phpmyadmin/sql-parser": "^5.5",
+# "phpmyadmin/twig-i18n-extension": "^3.0",
# "phpseclib/phpseclib": "^2.0",
-# "symfony/config": "^4.2.8",
-# "symfony/dependency-injection": "^4.2.8",
-# "symfony/expression-language": "^4.2",
-# "symfony/polyfill-ctype": "^1.8",
-# "symfony/polyfill-mbstring": "^1.3",
-# "symfony/yaml": "^4.2.8",
-# "twig/twig": "^2.4",
+# "symfony/config": "^4.4.9",
+# "symfony/dependency-injection": "^4.4.9",
+# "symfony/expression-language": "^4.4.9",
+# "symfony/polyfill-ctype": "^1.17.0",
+# "symfony/polyfill-mbstring": "^1.17.0",
+# "twig/twig": "^2.14.9 || ^3.3.5",
# "williamdes/mariadb-mysql-kbs": "^1.2"
-Requires: php(language) >= 7.1.3
+Requires: php(language) >= 7.2.5
Requires: php-hash
Requires: php-iconv
Requires: php-json
Requires: php-mysqli
+Requires: php-openssl
Requires: php-pcre
Requires: php-xml
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(google/recaptcha) >= 1.1 with php-composer(google/recaptcha) < 2)
-Requires: (php-composer(phpmyadmin/motranslator) >= 4.0 with php-composer(phpmyadmin/motranslator) < 5)
-Requires: (php-composer(phpmyadmin/shapefile) >= 2.0 with php-composer(phpmyadmin/shapefile) < 3)
-Requires: (php-composer(phpmyadmin/sql-parser) >= 5.0 with php-composer(phpmyadmin/sql-parser) < 6)
-Requires: (php-composer(phpmyadmin/twig-i18n-extension) >= 2.0 with php-composer(phpmyadmin/twig-i18n-extension) < 3)
-Requires: (php-composer(phpseclib/phpseclib) >= 2.0.9 with php-composer(phpseclib/phpseclib) < 3)
-Requires: (php-composer(symfony/config) >= 4.2.8 with php-composer(symfony/config) < 5)
-Requires: (php-composer(symfony/dependency-injection) >= 4.2.8 with php-composer(symfony/dependency-injection) < 5)
-Requires: (php-composer(symfony/expression-language) >= 4.2.8 with php-composer(symfony/expression-language) < 5)
-Requires: (php-composer(symfony/polyfill-mbstring) >= 1.8 with php-composer(symfony/polyfill-mbstring) < 2)
-Requires: (php-composer(symfony/yaml) >= 4.2.8 with php-composer(symfony/yaml) < 5)
-Requires: (php-composer(twig/twig) >= 2.4 with php-composer(twig/twig) < 3)
-Requires: (php-composer(williamdes/mariadb-mysql-kbs) >= 1.2 with php-composer(williamdes/mariadb-mysql-kbs) < 2)
-# remirepo:15
-%else
-Requires: php-google-recaptcha >= 1.1
-Requires: php-phpmyadmin-motranslator >= 4.0
-Requires: php-phpmyadmin-shapefile >= 2.0
-Requires: php-phpmyadmin-sql-parser5
-Requires: php-phpmyadmin-twig-i18n-extension
-Requires: php-phpseclib >= 2.0.9
-Requires: php-symfony4-config >= 4.1
-Requires: php-symfony4-dependency-injection >= 4.1
-Requires: php-symfony4-expression-language >= 4.1
-Requires: php-symfony-polyfill >= 1.8.0
-Requires: php-symfony4-yaml >= 4.1
-Requires: php-twig2 >= 2.4
-Requires: php-williamdes-mariadb-mysql-kbs >= 1.2
-%endif
-# Autoloader
-Requires: php-composer(fedora/autoloader)
-# From composer.json, "suggest": {
-# "ext-openssl": "Cookie encryption",
-# "ext-curl": "Updates checking",
-# "ext-opcache": "Better performance",
-# "ext-zlib": "For gz import and export",
-# "ext-bz2": "For bzip2 import and export",
-# "ext-zip": "For zip import and export",
-# "ext-gd2": "For image transformations",
-# "ext-mbstring": "For best performance",
-# "tecnickcom/tcpdf": "For PDF support",
-# "pragmarx/google2fa-qrcode": "For 2FA authentication",
-# "samyoul/u2f-php-server": "For FIDO U2F authentication"
-# "conflict": {
-# "phpseclib/phpseclib": "2.0.8",
-# "tecnickcom/tcpdf": "<6.2",
-# "pragmarx/google2fa-qrcode": "<1.0.1",
-# "samyoul/u2f-php-server": "<1.1"
+
+# License BSD-2-Clause
+Provides: bundled(php-bacon-bacon-qr-code) = 2.0.8
+Provides: bundled(php-beberlei-assert) = v3.3.2
+Provides: bundled(php-code-lts-u2f-php-server) = v1.2.1
+Provides: bundled(php-dasprid-enum) = 1.0.3
+# License BSD-3-Clause
+Provides: bundled(php-google-recaptcha) = 1.2.4
+Provides: bundled(php-nikic-fast-route) = v1.3.0
+Provides: bundled(php-twig-twig) = v3.5.0
+# License GPL-2.0-or-later
+Provides: bundled(php-phpmyadmin-motranslator) = 5.3.0
+Provides: bundled(php-phpmyadmin-shapefile) = 3.0.1
+Provides: bundled(php-phpmyadmin-sql-parser) = 5.7.0
+# License ISC
+Provides: bundled(php-paragonie-sodium-compat) = v1.19.0
+# License LGPL-3.0-only
+Provides: bundled(php-tecnickcom-tcpdf) = 6.6.2
+# License MIT
+Provides: bundled(php-brick-math) = 0.8.17
+Provides: bundled(php-composer-ca-bundle) = 1.3.5
+Provides: bundled(php-fgrosse-phpasn1) = v2.5.0
+Provides: bundled(php-fig-http-message-util) = 1.1.5
+Provides: bundled(php-league-uri) = 6.4.0
+Provides: bundled(php-league-uri-interfaces) = 2.3.0
+Provides: bundled(php-paragonie-constant-time-encoding) = v2.6.3
+Provides: bundled(php-paragonie-random-compat) = v9.99.100
+Provides: bundled(php-phpmyadmin-twig-i18n-extension) = v4.0.1
+Provides: bundled(php-pragmarx-google2fa) = v8.0.1
+Provides: bundled(php-pragmarx-google2fa-qrcode) = v2.1.1
+Provides: bundled(php-psr-cache) = 1.0.1
+Provides: bundled(php-psr-container) = 1.1.1
+Provides: bundled(php-psr-http-client) = 1.0.1
+Provides: bundled(php-psr-http-factory) = 1.0.1
+Provides: bundled(php-psr-http-message) = 1.0.1
+Provides: bundled(php-psr-log) = 1.1.4
+Provides: bundled(php-ralouphie-getallheaders) = 3.0.3
+Provides: bundled(php-ramsey-collection) = 1.1.4
+Provides: bundled(php-ramsey-uuid) = 4.2.3
+Provides: bundled(php-slim-psr7) = 1.4
+Provides: bundled(php-spomky-labs-base64url) = v2.0.4
+Provides: bundled(php-spomky-labs-cbor-php) = v1.1.1
+Provides: bundled(php-symfony-cache) = v5.4.19
+Provides: bundled(php-symfony-cache-contracts) = v2.5.2
+Provides: bundled(php-symfony-config) = v5.4.19
+Provides: bundled(php-symfony-dependency-injection) = v5.4.20
+Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
+Provides: bundled(php-symfony-expression-language) = v5.4.19
+Provides: bundled(php-symfony-filesystem) = v5.4.19
+Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
+Provides: bundled(php-symfony-process) = v5.4.19
+Provides: bundled(php-symfony-service-contracts) = v2.5.2
+Provides: bundled(php-symfony-var-exporter) = v5.4.19
+Provides: bundled(php-thecodingmachine-safe) = v1.3.3
+Provides: bundled(php-web-auth-cose-lib) = v3.3.12
+Provides: bundled(php-web-auth-metadata-service) = v3.3.12
+Provides: bundled(php-web-auth-webauthn-lib) = v3.3.12
+Provides: bundled(php-webmozart-assert) = 1.11.0
+# License MPL-2.0
+Provides: bundled(php-williamdes-mariadb-mysql-kbs) = v1.2.14
+
+Requires: php-dom
+Requires: php-intl
+Requires: php-posix
+# php-tidy required by tcpdf is not used (fixHTMLCode)
Requires: php-ctype
-Requires: php-openssl
Requires: php-curl
Requires: php-zlib
Requires: php-bz2
Requires: php-zip
Requires: php-gd
Requires: php-mbstring
-# remirepo:1
-%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
-Recommends: php-opcache
-Recommends: php-composer(tecnickcom/tcpdf) >= 6.3
-Recommends: php-composer(pragmarx/google2fa-qrcode) >= 1.0.1
-Recommends: php-composer(samyoul/u2f-php-server) >= 1.1
-Recommends: php-tcpdf-dejavu-sans-fonts >= 6.2
-# remirepo:6
-%else
-Requires: php-tcpdf >= 6.3
-Requires: php-pragmarx-google2fa-qrcode >= 1.0.1
-Requires: php-samyoul-u2f-php-server >= 1.1
-Requires: php-tcpdf-dejavu-sans-fonts >= 6.2
-%endif
# From phpcompatinfo reports for 4.8.0
# notice: recode is optional (iconv or mbstring are preferred / used first)
Requires: php-date
@@ -203,6 +222,7 @@ is available in 50 languages
%setup -qn phpMyAdmin-%{upstream_version}%{?upstream_prever:-%upstream_prever}-all-languages
%patch0 -p1
+rm -r vendor/composer/ca-bundle/res/
# Minimal configuration file
sed -e "/'blowfish_secret'/s@''@'MUSTBECHANGEDONINSTALL'@" \
@@ -211,48 +231,21 @@ sed -e "/'blowfish_secret'/s@''@'MUSTBECHANGEDONINSTALL'@" \
config.sample.inc.php >CONFIG
# Setup vendor config file
-sed -e "/'CHANGELOG_FILE'/s@ROOT_PATH@'%{_pkgdocdir}/'@" \
- -e "/'LICENSE_FILE'/s@ROOT_PATH@'%{_pkgdocdir}/'@" \
- -e "/'CONFIG_DIR'/s@ROOT_PATH@'%{_sysconfdir}/%{name}/'@" \
+sed -e "/'changeLogFile'/s@ROOT_PATH@'%{_pkgdocdir}/'@" \
+ -e "/'licenseFile'/s@ROOT_PATH@'%{_pkgdocdir}/'@" \
+ -e "/'configFile'/s@ROOT_PATH@'%{_sysconfdir}/%{name}/'@" \
%if 0%{?_licensedir:1}
- -e '/LICENSE_FILE/s:%_defaultdocdir:%_defaultlicensedir:' \
+ -e '/licenseFile/s:%_defaultdocdir:%_defaultlicensedir:' \
%endif
- -e '/AUTOLOAD_FILE/s@./vendor@%{_datadir}/%{name}/vendor@' \
- -e "/TEMP_DIR/s@ROOT.*tmp/'@'%{_localstatedir}/lib/%{name}/temp'@" \
+ -e "/versionSuffix/s/''/'-%{release}'/" \
+ -e "/tempDir/s@ROOT.*tmp'@'%{_localstatedir}/lib/%{name}/temp'@" \
+ -e "/cacheDir/s@ROOT.*cache'@'%{_localstatedir}/lib/%{name}/cache'@" \
-i libraries/vendor_config.php
# For debug
-grep '^define' libraries/vendor_config.php
-
-# Generate autoloader
-rm -rf vendor/*
-cat << 'EOF' | tee vendor/autoload.php
-<?php
-/* Autoloader for phpMyAdmin and its dependencies */
-
-require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('PhpMyAdmin\\', dirname(__DIR__) . '/libraries/classes');
-\Fedora\Autoloader\Dependencies::required([
- '%{_datadir}/php/PhpMyAdmin/MoTranslator/autoload.php', /* before sqlparser which may allow other version */
- '%{_datadir}/php/PhpMyAdmin/SqlParser5/autoload.php',
- '%{_datadir}/php/PhpMyAdmin/ShapeFile/autoload.php',
- '%{_datadir}/php/phpseclib/autoload.php',
- '%{_datadir}/php/ReCaptcha/autoload.php',
- '%{_datadir}/php/Twig2/autoload.php',
- '%{_datadir}/php/PhpMyAdmin/Twig/Extensions/autoload.php',
- '%{_datadir}/php/Symfony4/Component/Config/autoload.php',
- '%{_datadir}/php/Symfony4/Component/DependencyInjection/autoload.php',
- '%{_datadir}/php/Symfony4/Component/ExpressionLanguage/autoload.php',
- '%{_datadir}/php/Symfony4/Component/Yaml/autoload.php',
- '%{_datadir}/php/Symfony/Polyfill/autoload.php',
- '%{_datadir}/php/Williamdes/MariaDBMySQLKBS/autoload.php',
-]);
-\Fedora\Autoloader\Dependencies::optional([
- '%{_datadir}/php/tcpdf/autoload.php',
- '%{_datadir}/php/Google2FAQRCode/Google2FA/autoload.php',
- '%{_datadir}/php/Samyoul/U2F/U2FServer/autoload.php',
-]);
-EOF
+grep '=>' libraries/vendor_config.php
+
+php %{SOURCE5} vendor/composer/installed.json
%build
@@ -264,34 +257,28 @@ mkdir -p %{buildroot}/%{_datadir}/%{name}
cp -ad ./* %{buildroot}/%{_datadir}/%{name}
install -Dpm 0640 CONFIG %{buildroot}/%{_sysconfdir}/%{name}/config.inc.php
# Apache
-# remirepo:4
-%if 0%{?rhel} == 6
-# old config file with Apache 2.2/2.4 compatibility
-install -Dpm 0644 %{SOURCE10} %{buildroot}/%{_sysconfdir}/httpd/conf.d/phpMyAdmin.conf
-%else
install -Dpm 0644 %{SOURCE2} %{buildroot}/%{_sysconfdir}/httpd/conf.d/phpMyAdmin.conf
-# remirepo:1
-%endif
# Nginx
%if %{with_nginx}
install -Dpm 0644 %{SOURCE3} %{buildroot}/%{_sysconfdir}/nginx/default.d/phpMyAdmin.conf
%endif
+mkdir -p %{buildroot}/%{_localstatedir}/lib/%{name}/{upload,save,config,temp}
+
rm -f %{buildroot}/%{_datadir}/%{name}/config.sample.inc.php
rm -f %{buildroot}/%{_datadir}/%{name}/*txt
rm -f %{buildroot}/%{_datadir}/%{name}/[CDLR]*
rm -f %{buildroot}/%{_datadir}/%{name}/libraries/.htaccess
rm -f %{buildroot}/%{_datadir}/%{name}/setup/lib/.htaccess
rm -f %{buildroot}/%{_datadir}/%{name}/setup/frames/.htaccess
-rm -rf %{buildroot}/%{_datadir}/%{name}/contrib
-rm %{buildroot}/%{_datadir}/%{name}/composer.*
+rm -rf %{buildroot}%{_datadir}/%{name}/contrib
+rm %{buildroot}%{_datadir}/%{name}/composer.*
+rm -rf %{buildroot}%{_datadir}/%{name}/tmp/
+mv %{buildroot}%{_datadir}/%{name}/libraries/cache %{buildroot}/%{_localstatedir}/lib/%{name}/cache
# JS libraries sources
-#rm -r %{buildroot}%{_datadir}/%{name}/js/jquery/src
-#rm -r %{buildroot}%{_datadir}/%{name}/js/openlayers/src
-
-# Bundled certificates
-rm -r %{buildroot}%{_datadir}/%{name}/libraries/certs
+#rm -r %%{buildroot}%%{_datadir}/%{name}/js/jquery/src
+#rm -r %%{buildroot}%%{_datadir}/%{name}/js/openlayers/src
# documentation
rm -rf %{buildroot}%{_datadir}/%{name}/examples/
@@ -299,8 +286,6 @@ rm -rf %{buildroot}%{_datadir}/%{name}/doc/
mkdir -p %{buildroot}%{_datadir}/%{name}/doc/
ln -s %{_pkgdocdir}/html %{buildroot}%{_datadir}/%{name}/doc/html
-mkdir -p %{buildroot}/%{_localstatedir}/lib/%{name}/{upload,save,config,temp}
-
mv -f %{buildroot}%{_datadir}/%{name}/js/vendor/jquery/MIT-LICENSE.txt LICENSE-jquery
mv -f %{buildroot}%{_datadir}/%{name}/js/vendor/codemirror/LICENSE LICENSE-codemirror
@@ -321,7 +306,7 @@ sed -e "/'blowfish_secret'/s/MUSTBECHANGEDONINSTALL/$SECRET/" \
%files
%{!?_licensedir:%global license %%doc}
%license LICENSE*
-%doc ChangeLog README CONTRIBUTING.md DCO config.sample.inc.php
+%doc ChangeLog README CONTRIBUTING.md config.sample.inc.php
%doc doc/html/
%doc examples/
%doc composer.json
@@ -337,9 +322,72 @@ sed -e "/'blowfish_secret'/s/MUSTBECHANGEDONINSTALL/$SECRET/" \
%dir %attr(0750,apache,apache) %{_localstatedir}/lib/%{name}/save
%dir %attr(0750,apache,apache) %{_localstatedir}/lib/%{name}/config
%dir %attr(0750,apache,apache) %{_localstatedir}/lib/%{name}/temp
+%dir %attr(0750,apache,apache) %{_localstatedir}/lib/%{name}/cache
+ %attr(0640,apache,apache) %{_localstatedir}/lib/%{name}/cache/*
%changelog
+* Wed Feb 8 2023 Remi Collet <remi@remirepo.net> - 5.2.1-1
+- update to 5.2.1 (2023-02-08, security and bugfix release)
+
+* Thu May 12 2022 Remi Collet <remi@remirepo.net> - 5.2.0-1
+- update to 5.2.0 (2022-10-12, new features release)
+
+* Mon Jan 24 2022 Remi Collet <remi@remirepo.net> - 5.2.0~rc1-1
+- update to 5.2.0-rc1
+- raise dependency on PHP 7.2.5
+- always use bundled libraries
+
+* Sun Jan 23 2022 Remi Collet <remi@remirepo.net> - 5.1.2-1
+- update to 5.1.2 (2022-01-22, security and bugfix release)
+- raise dependency on phpmyadmin/sql-parser 5.5
+- raise dependency on twig/twig 2.14.9
+- switch from samyoul/u2f-php-server to code-lts/u2f-php-server
+
+* Thu Jan 13 2022 Remi Collet <remi@remirepo.net> - 5.1.1-4
+- fix Licence name
+- add build dependency on json ext
+
+* Fri Dec 10 2021 Remi Collet <remi@remirepo.net> - 5.1.1-3
+- add flag to use all PHP bundled libraries instead of system ones
+
+* Fri Jun 4 2021 Remi Collet <remi@remirepo.net> - 5.1.1-1
+- update to 5.1.1 (2021-06-04, bugfix release)
+
+* Wed May 5 2021 Remi Collet <remi@remirepo.net> - 5.1.0-3
+- add VERSION_SUFFIX in vendor_config.php
+
+* Thu Apr 1 2021 Remi Collet <remi@remirepo.net> - 5.1.0-2
+- fix autoloader for pragmarx/google2fa-qrcode
+
+* Wed Feb 24 2021 Remi Collet <remi@remirepo.net> - 5.1.0-1
+- update to 5.1.0 (2021-02-24, new features release)
+
+* Wed Feb 10 2021 Remi Collet <remi@remirepo.net> - 5.1.0~rc2-1
+- update to 5.1.0-rc2
+
+* Mon Dec 21 2020 Remi Collet <remi@remirepo.net> - 5.1.0~rc1-2
+- set CACHE_DIR
+
+* Mon Dec 21 2020 Remi Collet <remi@remirepo.net> - 5.1.0~rc1-1
+- update to 5.1.0-rc1
+- add dependency on nikic/fast-route
+- raise dependency on phpmyadmin/motranslator 5.0
+- raise dependency on phpmyadmin/twig-i18n-extension 3.0
+- raise dependency on Symfony 4.4.9
+
+* Fri Oct 16 2020 Remi Collet <remi@remirepo.net> - 5.0.4-1
+- update to 5.0.4 (2020-10-15, bug fix release)
+
+* Sat Oct 10 2020 Remi Collet <remi@remirepo.net> - 5.0.3-1
+- update to 5.0.3 (2020-10-10, security release)
+- raise dependency on twig 2.9 and allow v3
+- allow phpmyadmin/twig-i18n-extension v3
+
+* Sat Apr 4 2020 Remi Collet <remi@remirepo.net> 5.0.2-3
+- temporarily make nginx-filesystem optional to
+ allow installation with nginx from nginx repository
+
* Tue Mar 24 2020 Remi Collet <remi@remirepo.net> 5.0.2-2
- cleanup httpd configuration