summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-11 08:58:38 +0100
committerRemi Collet <remi@php.net>2022-02-11 08:58:38 +0100
commit4038683da918a82f81db1880efc9f03155c268ed (patch)
tree28c02c3d73b0196a78f2ca9ae0b23cbcc02286fa
parent45987056f0ecc0b6dfc82a59cb336d9d317abe90 (diff)
update to 5.1.3 (2022-02-10, security and bugfix release)
-rw-r--r--composer.json4
-rw-r--r--phpMyAdmin.spec23
2 files changed, 15 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index c980a03..235c30b 100644
--- a/composer.json
+++ b/composer.json
@@ -86,7 +86,7 @@
"php-webdriver/webdriver": "^1.11",
"phpmyadmin/coding-standard": "^2.1.1",
"phpstan/extension-installer": "^1.1",
- "phpstan/phpstan": "^1.3",
+ "phpstan/phpstan": "^1.4.5",
"phpstan/phpstan-phpunit": "^1.0",
"phpunit/phpunit": "^7.5 || ^8.0 || ^9.0",
"pragmarx/google2fa-qrcode": "^1.0.1",
@@ -94,7 +94,7 @@
"symfony/finder": "^4.4",
"symfony/twig-bridge": "^4.4",
"tecnickcom/tcpdf": "^6.4.4",
- "vimeo/psalm": "^4.17"
+ "vimeo/psalm": "^4.19"
},
"extra": {
"branch-alias": {
diff --git a/phpMyAdmin.spec b/phpMyAdmin.spec
index c37dcff..17bc623 100644
--- a/phpMyAdmin.spec
+++ b/phpMyAdmin.spec
@@ -31,7 +31,7 @@
%global with_httpd 0
%endif
-%global upstream_version 5.1.2
+%global upstream_version 5.1.3
#global upstream_prever rc2
Name: phpMyAdmin
@@ -189,7 +189,7 @@ Requires: php-code-lts-u2f-php-server >= 1.2
Requires: php-tcpdf-dejavu-sans-fonts >= 6.2
%endif
%else
-Provides: bundled(php-bacon-bacon-qr-code) = 2.0.4
+Provides: bundled(php-bacon-bacon-qr-code) = 2.0.6
Provides: bundled(php-code-lts-u2f-php-server) = v1.2.0
Provides: bundled(php-dasprid-enum) = 1.0.3
Provides: bundled(php-google-recaptcha) = 1.2.4
@@ -199,18 +199,18 @@ Provides: bundled(php-phpmyadmin-motranslator) = 5.2.0
Provides: bundled(php-phpmyadmin-shapefile) = 2.1
Provides: bundled(php-phpmyadmin-sql-parser) = 5.5.0
Provides: bundled(php-phpmyadmin-twig-i18n-extension) = v3.0.0
-Provides: bundled(php-phpseclib-phpseclib) = 2.0.35
+Provides: bundled(php-phpseclib-phpseclib) = 2.0.36
Provides: bundled(php-pragmarx-google2fa) = 8.0.0
Provides: bundled(php-pragmarx-google2fa-qrcode) = v1.0.3
Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-cache) = v4.4.36
+Provides: bundled(php-symfony-cache) = v4.4.37
Provides: bundled(php-symfony-cache-contracts) = v1.1.11
-Provides: bundled(php-symfony-config) = v4.4.36
-Provides: bundled(php-symfony-dependency-injection) = v4.4.36
-Provides: bundled(php-symfony-expression-language) = v4.4.34
-Provides: bundled(php-symfony-filesystem) = v4.4.27
+Provides: bundled(php-symfony-config) = v4.4.37
+Provides: bundled(php-symfony-dependency-injection) = v4.4.37
+Provides: bundled(php-symfony-expression-language) = v4.4.37
+Provides: bundled(php-symfony-filesystem) = v4.4.37
Provides: bundled(php-symfony-polyfill-ctype) = v1.24.0
Provides: bundled(php-symfony-polyfill-mbstring) = v1.24.0
Provides: bundled(php-symfony-polyfill-php72) = v1.24.0
@@ -218,9 +218,9 @@ Provides: bundled(php-symfony-polyfill-php73) = v1.24.0
Provides: bundled(php-symfony-polyfill-php80) = v1.24.0
Provides: bundled(php-symfony-polyfill-php81) = v1.24.0
Provides: bundled(php-symfony-service-contracts) = v1.1.11
-Provides: bundled(php-symfony-var-exporter) = v4.4.34
+Provides: bundled(php-symfony-var-exporter) = v4.4.37
Provides: bundled(php-tecnickcom-tcpdf) = 6.4.4
-Provides: bundled(php-twig-twig) = v2.14.10
+Provides: bundled(php-twig-twig) = v2.14.11
Provides: bundled(php-williamdes-mariadb-mysql-kbs) = v1.2.13
Requires: php-dom
Requires: php-intl
@@ -420,6 +420,9 @@ sed -e "/'blowfish_secret'/s/MUSTBECHANGEDONINSTALL/$SECRET/" \
%changelog
+* Fri Feb 11 2022 Remi Collet <remi@remirepo.net> - 5.1.3-1
+- update to 5.1.3 (2022-02-10, security and bugfix release)
+
* Sun Jan 23 2022 Remi Collet <remi@remirepo.net> - 5.1.2-1
- update to 5.1.2 (2022-01-22, security and bugfix release)
- raise dependency on phpmyadmin/sql-parser 5.5