summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-08 07:47:44 +0100
committerRemi Collet <remi@php.net>2023-02-08 07:47:44 +0100
commit6cda13e5b2009b165c1cb5668340b3290a00abb9 (patch)
tree0ade98965c34137e4bed95a92aa771083377b04f
parent6c198953bcd17afe44d303220ec959d88ffc2891 (diff)
update to 5.2.1 (2023-02-08, security and bugfix release)HEADmaster
-rw-r--r--phpMyAdmin-bundled.php15
-rw-r--r--phpMyAdmin.spec100
2 files changed, 69 insertions, 46 deletions
diff --git a/phpMyAdmin-bundled.php b/phpMyAdmin-bundled.php
index 5f2cb89..ee018ef 100644
--- a/phpMyAdmin-bundled.php
+++ b/phpMyAdmin-bundled.php
@@ -18,9 +18,16 @@ if (!is_array($pkgs)) {
$lic = [];
if (isset($pkgs['packages'])) {
- foreach($pkgs['packages'] as $pkg) {
- printf("Provides: bundled(php-%s) = %s\n", str_replace(['/', '_'], ['-', '-'], $pkg['name']), $pkg['version']);
- $lic = array_merge($lic, $pkg['license']);
+ $res = [];
+ foreach($pkgs["packages"] as $pkg) {
+ $lic = implode(" and ", $pkg["license"]);
+ if (!isset($res[$lic])) $res[$lic] = [];
+ $res[$lic][] = sprintf("Provides: bundled(php-%s) = %s", str_replace(["/", "_"], ["-", "-"], $pkg["name"]), $pkg["version"]);
+ }
+ ksort($res);
+ foreach($res as $lic => $lib) {
+ sort($lib);
+ printf("# License %s\n%s\n", $lic, implode("\n", $lib));
}
} else if (isset($pkgs['dependencies'])) {
foreach($pkgs['dependencies'] as $pkg) {
@@ -35,5 +42,3 @@ if (isset($pkgs['packages'])) {
echo "unkown content\n";
exit(4);
}
-sort($lic);
-printf("\nLicense: %s\n", implode(' and ', array_unique($lic)));
diff --git a/phpMyAdmin.spec b/phpMyAdmin.spec
index 7caf20a..6f2f6ad 100644
--- a/phpMyAdmin.spec
+++ b/phpMyAdmin.spec
@@ -1,7 +1,7 @@
+# remirepo:4
# remirepo spec file for phpMyAdmin
-# remirepo:3
#
-# Copyright (c) 2008-2022 Remi Collet
+# Copyright (c) 2008-2023 Remi Collet
#
# Fedora spec file for phpMyAdmin
#
@@ -24,7 +24,7 @@
%global with_httpd 0
%endif
-%global upstream_version 5.2.0
+%global upstream_version 5.2.1
#global upstream_prever rc1
Name: phpMyAdmin
@@ -32,18 +32,11 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}
Summary: A web interface for MySQL and MariaDB
+# phpMyAdmin is GPL-2.0-or-later
# MIT (js/jquery/, js/jqplot, js/codemirror/, js/tracekit/)
-# BSD (js/openlayers/)
-# GPLv2+ (the rest)
-# BSD: bacon/bacon-qr-code, dasprid/enum, google/recaptcha, nikic/fast-route,
-# code-lts/u2f-php-server, twig/twig
-# MIT: paragonie/constant_time_encoding, phpmyadmin/twig-i18n-extension,
-# phpseclib/phpseclib, pragmarx/google2fa, pragmarx/google2fa-qrcode,
-# psr/*, symfony/*
-# GPLv2+: phpmyadmin/motranslator, phpmyadmin/shapefile, phpmyadmin/sql-parser
-# LGPLv3: tecnickcom/tcpdf
-# MPLv2.0: williamdes/mariadb-mysql-kbs
-License: GPLv2+ and MIT and BSD and LGPLv3 and MPLv2.0
+# BSD 2-Clause (js/openlayers/)
+# for PHP library see generated bundled list above
+License: GPL-2.0-or-later AND MIT AND BSD 2-Clause AND BSD 3-Clause AND LGPL-3.0-or-later AND MPL-2.0 AND ISC
URL: https://www.phpmyadmin.net/
Source0: https://files.phpmyadmin.net/%{name}/%{upstream_version}%{?upstream_prever:-%upstream_prever}/%{name}-%{upstream_version}%{?upstream_prever:-%upstream_prever}-all-languages.tar.xz
Source1: https://files.phpmyadmin.net/%{name}/%{upstream_version}%{?upstream_prever:-%upstream_prever}/%{name}-%{upstream_version}%{?upstream_prever:-%upstream_prever}-all-languages.tar.xz.asc
@@ -112,47 +105,69 @@ Requires: php-openssl
Requires: php-pcre
Requires: php-xml
-Provides: bundled(php-bacon-bacon-qr-code) = 2.0.7
-Provides: bundled(php-code-lts-u2f-php-server) = v1.2.0
-Provides: bundled(php-composer-ca-bundle) = 1.3.1
+# License BSD-2-Clause
+Provides: bundled(php-bacon-bacon-qr-code) = 2.0.8
+Provides: bundled(php-beberlei-assert) = v3.3.2
+Provides: bundled(php-code-lts-u2f-php-server) = v1.2.1
Provides: bundled(php-dasprid-enum) = 1.0.3
-Provides: bundled(php-fig-http-message-util) = 1.1.5
+# License BSD-3-Clause
Provides: bundled(php-google-recaptcha) = 1.2.4
Provides: bundled(php-nikic-fast-route) = v1.3.0
-Provides: bundled(php-paragonie-constant-time-encoding) = v2.5.0
-Provides: bundled(php-paragonie-random-compat) = v9.99.100
-Provides: bundled(php-paragonie-sodium-compat) = v1.17.1
+Provides: bundled(php-twig-twig) = v3.5.0
+# License GPL-2.0-or-later
Provides: bundled(php-phpmyadmin-motranslator) = 5.3.0
Provides: bundled(php-phpmyadmin-shapefile) = 3.0.1
-Provides: bundled(php-phpmyadmin-sql-parser) = 5.5.0
+Provides: bundled(php-phpmyadmin-sql-parser) = 5.7.0
+# License ISC
+Provides: bundled(php-paragonie-sodium-compat) = v1.19.0
+# License LGPL-3.0-only
+Provides: bundled(php-tecnickcom-tcpdf) = 6.6.2
+# License MIT
+Provides: bundled(php-brick-math) = 0.8.17
+Provides: bundled(php-composer-ca-bundle) = 1.3.5
+Provides: bundled(php-fgrosse-phpasn1) = v2.5.0
+Provides: bundled(php-fig-http-message-util) = 1.1.5
+Provides: bundled(php-league-uri) = 6.4.0
+Provides: bundled(php-league-uri-interfaces) = 2.3.0
+Provides: bundled(php-paragonie-constant-time-encoding) = v2.6.3
+Provides: bundled(php-paragonie-random-compat) = v9.99.100
Provides: bundled(php-phpmyadmin-twig-i18n-extension) = v4.0.1
-Provides: bundled(php-pragmarx-google2fa) = 8.0.0
+Provides: bundled(php-pragmarx-google2fa) = v8.0.1
Provides: bundled(php-pragmarx-google2fa-qrcode) = v2.1.1
Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.1
+Provides: bundled(php-psr-http-client) = 1.0.1
Provides: bundled(php-psr-http-factory) = 1.0.1
Provides: bundled(php-psr-http-message) = 1.0.1
Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-ralouphie-getallheaders) = 3.0.3
+Provides: bundled(php-ramsey-collection) = 1.1.4
+Provides: bundled(php-ramsey-uuid) = 4.2.3
Provides: bundled(php-slim-psr7) = 1.4
-Provides: bundled(php-symfony-cache) = v5.4.8
-Provides: bundled(php-symfony-cache-contracts) = v2.5.1
-Provides: bundled(php-symfony-config) = v5.4.8
-Provides: bundled(php-symfony-dependency-injection) = v5.4.8
-Provides: bundled(php-symfony-deprecation-contracts) = v2.5.1
-Provides: bundled(php-symfony-expression-language) = v5.4.8
-Provides: bundled(php-symfony-filesystem) = v5.4.7
-Provides: bundled(php-symfony-polyfill-ctype) = v1.25.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.25.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.25.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.25.0
-Provides: bundled(php-symfony-polyfill-php81) = v1.25.0
-Provides: bundled(php-symfony-service-contracts) = v2.5.1
-Provides: bundled(php-symfony-var-exporter) = v5.4.8
-Provides: bundled(php-tecnickcom-tcpdf) = 6.4.4
-Provides: bundled(php-twig-twig) = v3.3.10
-Provides: bundled(php-webmozart-assert) = 1.10.0
-Provides: bundled(php-williamdes-mariadb-mysql-kbs) = v1.2.13
+Provides: bundled(php-spomky-labs-base64url) = v2.0.4
+Provides: bundled(php-spomky-labs-cbor-php) = v1.1.1
+Provides: bundled(php-symfony-cache) = v5.4.19
+Provides: bundled(php-symfony-cache-contracts) = v2.5.2
+Provides: bundled(php-symfony-config) = v5.4.19
+Provides: bundled(php-symfony-dependency-injection) = v5.4.20
+Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
+Provides: bundled(php-symfony-expression-language) = v5.4.19
+Provides: bundled(php-symfony-filesystem) = v5.4.19
+Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
+Provides: bundled(php-symfony-process) = v5.4.19
+Provides: bundled(php-symfony-service-contracts) = v2.5.2
+Provides: bundled(php-symfony-var-exporter) = v5.4.19
+Provides: bundled(php-thecodingmachine-safe) = v1.3.3
+Provides: bundled(php-web-auth-cose-lib) = v3.3.12
+Provides: bundled(php-web-auth-metadata-service) = v3.3.12
+Provides: bundled(php-web-auth-webauthn-lib) = v3.3.12
+Provides: bundled(php-webmozart-assert) = 1.11.0
+# License MPL-2.0
+Provides: bundled(php-williamdes-mariadb-mysql-kbs) = v1.2.14
Requires: php-dom
Requires: php-intl
@@ -312,6 +327,9 @@ sed -e "/'blowfish_secret'/s/MUSTBECHANGEDONINSTALL/$SECRET/" \
%changelog
+* Wed Feb 8 2023 Remi Collet <remi@remirepo.net> - 5.2.1-1
+- update to 5.2.1 (2023-02-08, security and bugfix release)
+
* Thu May 12 2022 Remi Collet <remi@remirepo.net> - 5.2.0-1
- update to 5.2.0 (2022-10-12, new features release)