summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json28
-rw-r--r--php-phpdocumentor-reflection-docblock5.spec77
2 files changed, 72 insertions, 33 deletions
diff --git a/composer.json b/composer.json
index 7038f48..cf8f49d 100644
--- a/composer.json
+++ b/composer.json
@@ -10,18 +10,26 @@
},
{
"name": "Jaap van Otterdijk",
- "email": "account@ijaap.nl"
+ "email": "opensource@ijaap.nl"
}
],
"require": {
- "php": "^7.2 || ^8.0",
- "phpdocumentor/type-resolver": "^1.3",
+ "php": "^7.4 || ^8.0",
+ "phpdocumentor/type-resolver": "^1.7",
"webmozart/assert": "^1.9.1",
"phpdocumentor/reflection-common": "^2.2",
- "ext-filter": "*"
+ "ext-filter": "*",
+ "phpstan/phpdoc-parser": "^1.7",
+ "doctrine/deprecations": "^1.1"
},
"require-dev": {
- "mockery/mockery": "~1.3.2"
+ "mockery/mockery": "~1.3.5",
+ "phpunit/phpunit": "^9.5",
+ "phpstan/phpstan": "^1.8",
+ "phpstan/phpstan-mockery": "^1.1",
+ "phpstan/extension-installer": "^1.1",
+ "phpstan/phpstan-webmozart-assert": "^1.2",
+ "vimeo/psalm": "^5.13"
},
"autoload": {
"psr-4": {
@@ -30,7 +38,15 @@
},
"autoload-dev": {
"psr-4": {
- "phpDocumentor\\Reflection\\": "tests/unit"
+ "phpDocumentor\\Reflection\\": ["tests/unit", "tests/integration"]
+ }
+ },
+ "config": {
+ "platform": {
+ "php":"7.4.0"
+ },
+ "allow-plugins": {
+ "phpstan/extension-installer": true
}
},
"extra": {
diff --git a/php-phpdocumentor-reflection-docblock5.spec b/php-phpdocumentor-reflection-docblock5.spec
index 8b4b495..b10be02 100644
--- a/php-phpdocumentor-reflection-docblock5.spec
+++ b/php-phpdocumentor-reflection-docblock5.spec
@@ -1,6 +1,6 @@
# Fedora/remirepo spec file for php-phpdocumentor-reflection-docblock5
#
-# Copyright (c) 2017-2020 Remi Collet, Shawn Iwinski
+# Copyright (c) 2017-2024 Remi Collet, Shawn Iwinski
# 2014-2015 Remi Collet
#
# License: CC-BY-SA
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 069a785b2141f5bcf49f3e353548dc1cce6df556
+%global gh_commit 298d2febfe79d03fe714eb871d5538da55205b1a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpDocumentor
%global gh_project ReflectionDocBlock
@@ -16,7 +16,7 @@
%bcond_without tests
Name: php-phpdocumentor-reflection-docblock%{major}
-Version: 5.2.2
+Version: 5.4.0
Release: 1%{?dist}
Summary: DocBlock parser
@@ -31,34 +31,39 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 7.4
BuildRequires: php-filter
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(phpdocumentor/type-resolver) >= 1.3 with php-composer(phpdocumentor/type-resolver) < 2)
-BuildRequires: (php-composer(webmozart/assert) >= 1.9.1 with php-composer(webmozart/assert) < 2)
-BuildRequires: (php-composer(phpdocumentor/reflection-common) >= 2.2 with php-composer(phpdocumentor/reflection-common) < 3)
-# remirepo:5
+BuildRequires: (php-composer(phpdocumentor/type-resolver) >= 1.7 with php-composer(phpdocumentor/type-resolver) < 2)
+BuildRequires: (php-composer(webmozart/assert) >= 1.9.1 with php-composer(webmozart/assert) < 2)
+BuildRequires: (php-composer(phpdocumentor/reflection-common) >= 2.2 with php-composer(phpdocumentor/reflection-common) < 3)
+BuildRequires: (php-composer(phpstan/phpdoc-parser) >= 1.7 with php-composer(phpstan/phpdoc-parser) < 2)
+BuildRequires: (php-composer(doctrine/deprecations) >= 1.1 with php-composer(doctrine/deprecations) < 2)
+# remirepo:7
%else
-BuildRequires: php-phpdocumentor-type-resolver1 >= 1.3
+BuildRequires: php-phpdocumentor-type-resolver1 >= 1.7
BuildRequires: php-webmozart-assert >= 1.9.1
BuildRequires: php-phpdocumentor-reflection-common2 >= 2.2
+BuildRequires: php-phpstan-phpdoc-parser >= 1.7
+BuildRequires: php-doctrine-deprecations >= 1.1
%endif
# From composer.json, require-dev
-# "mockery/mockery": "~1.3.2"
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 9
-BuildRequires: phpunit9
+# "mockery/mockery": "~1.3.5",
+# "phpunit/phpunit": "^9.5",
+# "phpstan/phpstan": "^1.8",
+# "phpstan/phpstan-mockery": "^1.1",
+# "phpstan/extension-installer": "^1.1",
+# "phpstan/phpstan-webmozart-assert": "^1.2",
+# "vimeo/psalm": "^5.13"
+BuildRequires: phpunit9 >= 9.5
%global phpunit %{_bindir}/phpunit9
-%else
-BuildRequires: phpunit8
-%global phpunit %{_bindir}/phpunit8
-%endif
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(mockery/mockery) >= 1.3.2 with php-composer(mockery/mockery) < 2)
+BuildRequires: (php-composer(mockery/mockery) >= 1.3.5 with php-composer(mockery/mockery) < 2)
# remirepo:3
%else
-BuildRequires: php-mockery >= 1.3.2
+BuildRequires: php-mockery >= 1.3.5
%endif
# From phpcompatinfo report for 5.0.0
BuildRequires: php-reflection
@@ -67,23 +72,29 @@ BuildRequires: php-spl
%endif
# From composer.json, require
-# "php": "^7.2 || ^8.0",
-# "phpdocumentor/type-resolver": "^1.3",
+# "php": "^7.4 || ^8.0",
+# "phpdocumentor/type-resolver": "^1.7",
# "webmozart/assert": "^1.9.1",
# "phpdocumentor/reflection-common": "^2.2",
-# "ext-filter": "*"
-Requires: php(language) >= 7.2
+# "ext-filter": "*",
+# "phpstan/phpdoc-parser": "^1.7",
+# "doctrine/deprecations": "^1.1"
+Requires: php(language) >= 7.4
Requires: php-filter
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(phpdocumentor/type-resolver) >= 1.3 with php-composer(phpdocumentor/type-resolver) < 2)
+Requires: (php-composer(phpdocumentor/type-resolver) >= 1.7 with php-composer(phpdocumentor/type-resolver) < 2)
Requires: (php-composer(webmozart/assert) >= 1.9.1 with php-composer(webmozart/assert) < 2)
Requires: (php-composer(phpdocumentor/reflection-common) >= 2.2 with php-composer(phpdocumentor/reflection-common) < 3)
-# remirepo:5
+Requires: (php-composer(phpstan/phpdoc-parser) >= 1.7 with php-composer(phpstan/phpdoc-parser) < 2)
+Requires: (php-composer(doctrine/deprecations) >= 1.1 with php-composer(doctrine/deprecations) < 2)
+# remirepo:7
%else
-Requires: php-phpdocumentor-type-resolver1 >= 1.3
+Requires: php-phpdocumentor-type-resolver1 >= 1.7
Requires: php-webmozart-assert >= 1.9.1
Requires: php-phpdocumentor-reflection-common2 >= 2.2
+Requires: php-phpstan-phpdoc-parser >= 1.7
+Requires: php-doctrine-deprecations >= 1.1
%endif
# From phpcompatinfo report for 4.3.2
Requires: php-reflection
@@ -128,6 +139,8 @@ cat <<AUTOLOAD | tee -a src/DocBlock/autoload.php
'%{_datadir}/php/phpDocumentor/Reflection2/autoload-common.php',
'%{_datadir}/php/phpDocumentor/Reflection2/autoload-type-resolver.php',
'%{_datadir}/php/Webmozart/Assert/autoload.php',
+ '%{_datadir}/php/PHPStan/PhpDocParser/autoload.php',
+ '%{_datadir}/php/Doctrine/Deprecations/autoload.php',
]);
AUTOLOAD
@@ -144,7 +157,7 @@ sed -e '/autoload.php/d' -i examples/*.php examples/*/*.php
phpab \
--template fedora \
--output bootstrap.php \
- tests/unit/
+ tests/unit tests/integration
cat <<BOOTSTRAP | tee -a bootstrap.php
@@ -155,7 +168,7 @@ cat <<BOOTSTRAP | tee -a bootstrap.php
BOOTSTRAP
RETURN_CODE=0
-for PHP_EXEC in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for PHP_EXEC in "php %{phpunit}" php73 php74 php80 php81; do
if which $PHP_EXEC; then
set $PHP_EXEC
$1 -d auto_prepend_file=$PWD/bootstrap.php \
@@ -181,6 +194,16 @@ exit $RETURN_CODE
%changelog
+* Thu Apr 25 2024 Remi Collet <remi@remirepo.net> - 5.4.0-1
+- update to 5.4.0
+- raise dependency on PHP 7.4
+- raise dependency on phpdocumentor/type-resolver 1.7
+- add dependency on phpstan/phpdoc-parser
+- add dependency on doctrine/deprecations
+
+* Wed Oct 20 2021 Remi Collet <remi@remirepo.net> - 5.3.0-1
+- update to 5.3.0
+
* Fri Sep 18 2020 Remi Collet <remi@remirepo.net> - 5.2.2-1
- update to 5.2.2