summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-20 10:16:14 +0200
committerRemi Collet <remi@php.net>2021-10-20 10:16:14 +0200
commit732ec7de674aeb242d54ce2197b3a47b052f6b2f (patch)
treed1c529dae00945212a770a1034b17b205d5a8abd
parentb87c7659e42aaba8e4f866fa842f3f20ea6abdec (diff)
update to 5.3.0HEADmaster
-rw-r--r--composer.json5
-rw-r--r--php-phpdocumentor-reflection-docblock5.spec19
2 files changed, 12 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 7038f48..d907630 100644
--- a/composer.json
+++ b/composer.json
@@ -21,7 +21,8 @@
"ext-filter": "*"
},
"require-dev": {
- "mockery/mockery": "~1.3.2"
+ "mockery/mockery": "~1.3.2",
+ "psalm/phar": "^4.8"
},
"autoload": {
"psr-4": {
@@ -30,7 +31,7 @@
},
"autoload-dev": {
"psr-4": {
- "phpDocumentor\\Reflection\\": "tests/unit"
+ "phpDocumentor\\Reflection\\": ["tests/unit", "tests/integration"]
}
},
"extra": {
diff --git a/php-phpdocumentor-reflection-docblock5.spec b/php-phpdocumentor-reflection-docblock5.spec
index 8b4b495..9820c30 100644
--- a/php-phpdocumentor-reflection-docblock5.spec
+++ b/php-phpdocumentor-reflection-docblock5.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 069a785b2141f5bcf49f3e353548dc1cce6df556
+%global gh_commit 622548b623e81ca6d78b721c5e029f4ce664f170
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpDocumentor
%global gh_project ReflectionDocBlock
@@ -16,7 +16,7 @@
%bcond_without tests
Name: php-phpdocumentor-reflection-docblock%{major}
-Version: 5.2.2
+Version: 5.3.0
Release: 1%{?dist}
Summary: DocBlock parser
@@ -45,14 +45,10 @@ BuildRequires: php-webmozart-assert >= 1.9.1
BuildRequires: php-phpdocumentor-reflection-common2 >= 2.2
%endif
# From composer.json, require-dev
-# "mockery/mockery": "~1.3.2"
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 9
+# "mockery/mockery": "~1.3.2",
+# "psalm/phar": "^4.8"
BuildRequires: phpunit9
%global phpunit %{_bindir}/phpunit9
-%else
-BuildRequires: phpunit8
-%global phpunit %{_bindir}/phpunit8
-%endif
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(mockery/mockery) >= 1.3.2 with php-composer(mockery/mockery) < 2)
@@ -144,7 +140,7 @@ sed -e '/autoload.php/d' -i examples/*.php examples/*/*.php
phpab \
--template fedora \
--output bootstrap.php \
- tests/unit/
+ tests/unit tests/integration
cat <<BOOTSTRAP | tee -a bootstrap.php
@@ -155,7 +151,7 @@ cat <<BOOTSTRAP | tee -a bootstrap.php
BOOTSTRAP
RETURN_CODE=0
-for PHP_EXEC in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for PHP_EXEC in "php %{phpunit}" php73 php74 php80 php81; do
if which $PHP_EXEC; then
set $PHP_EXEC
$1 -d auto_prepend_file=$PWD/bootstrap.php \
@@ -181,6 +177,9 @@ exit $RETURN_CODE
%changelog
+* Wed Oct 20 2021 Remi Collet <remi@remirepo.net> - 5.3.0-1
+- update to 5.3.0
+
* Fri Sep 18 2020 Remi Collet <remi@remirepo.net> - 5.2.2-1
- update to 5.2.2