summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-23 13:52:54 +0100
committerRemi Collet <remi@remirepo.net>2021-03-23 13:52:54 +0100
commit2a314ba1abc1a3d8ee45f60a7ea81db043d2f9f1 (patch)
tree057e29dd7c090b1aab5c1b3364becf0fae896bd2
parentb414f2eb191ca6048c3b9969436685b21d2f850d (diff)
update to 2.2.0
raise dependency on PHP 7.2
-rw-r--r--.gitignore2
-rw-r--r--composer.json4
-rw-r--r--php-phpdocumentor-reflection-common2.spec14
3 files changed, 13 insertions, 7 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index 90afe72..4d128b4 100644
--- a/composer.json
+++ b/composer.json
@@ -11,7 +11,7 @@
}
],
"require": {
- "php": ">=7.1"
+ "php": "^7.2 || ^8.0"
},
"autoload" : {
"psr-4" : {
@@ -22,7 +22,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.x-dev"
+ "dev-2.x": "2.x-dev"
}
}
}
diff --git a/php-phpdocumentor-reflection-common2.spec b/php-phpdocumentor-reflection-common2.spec
index bf0ccad..227d819 100644
--- a/php-phpdocumentor-reflection-common2.spec
+++ b/php-phpdocumentor-reflection-common2.spec
@@ -10,16 +10,16 @@
%global github_owner phpDocumentor
%global github_name ReflectionCommon
-%global github_version 2.1.0
-%global github_commit 6568f4687e5b41b054365f9ae03fcb1ed5f2069b
+%global github_version 2.2.0
+%global github_commit 1d01c49d4ed62f25aa84a747ad35d5a16924662b
%global composer_vendor phpdocumentor
%global composer_project reflection-common
%global major 2
-# "php": ">=7.1"
-%global php_min_ver 7.1
+# "php": "^7.2 || ^8.0"
+%global php_min_ver 7.2
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -91,7 +91,7 @@ touch vendor/autoload.php
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php71 php72 php73 php74 php80; do
+for PHP_EXEC in php php72 php73 php74 php80; do
if which $PHP_EXEC; then
$PHP_EXEC -d auto_prepend_file=$BOOTSTRAP \
%{_bindir}/phpunit6 --verbose || RETURN_CODE=1
@@ -120,6 +120,10 @@ exit $RETURN_CODE
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+- raise dependency on PHP 7.2
+
* Mon Apr 27 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0