summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-04-27 12:55:39 +0200
committerRemi Collet <remi@remirepo.net>2020-04-27 12:55:39 +0200
commitb414f2eb191ca6048c3b9969436685b21d2f850d (patch)
treede38b79e98e3d86ad8204c93b7ae98823db97eb7
parent6b472a269087f0ee80a42ddac0ff2500da29dcc3 (diff)
update to 2.1.0
-rw-r--r--composer.json1
-rw-r--r--php-phpdocumentor-reflection-common2.spec13
2 files changed, 9 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 6daeb50..90afe72 100644
--- a/composer.json
+++ b/composer.json
@@ -19,7 +19,6 @@
}
},
"require-dev": {
- "phpunit/phpunit": "~6"
},
"extra": {
"branch-alias": {
diff --git a/php-phpdocumentor-reflection-common2.spec b/php-phpdocumentor-reflection-common2.spec
index 8fc80b1..bf0ccad 100644
--- a/php-phpdocumentor-reflection-common2.spec
+++ b/php-phpdocumentor-reflection-common2.spec
@@ -10,8 +10,8 @@
%global github_owner phpDocumentor
%global github_name ReflectionCommon
-%global github_version 2.0.0
-%global github_commit 63a995caa1ca9e5590304cd845c15ad6d482a62a
+%global github_version 2.1.0
+%global github_commit 6568f4687e5b41b054365f9ae03fcb1ed5f2069b
%global composer_vendor phpdocumentor
%global composer_project reflection-common
@@ -28,7 +28,7 @@
Name: php-%{composer_vendor}-%{composer_project}%{major}
Version: %{github_version}
-Release: 2%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Common reflection classes used by phpdocumentor
Group: Development/Libraries
@@ -86,10 +86,12 @@ cp -rp src %{buildroot}%{phpdir}/phpDocumentor/Reflection%{major}
%check
%if %{with_tests}
BOOTSTRAP=%{buildroot}%{phpdir}/phpDocumentor/Reflection%{major}/autoload-common.php
+mkdir vendor
+touch vendor/autoload.php
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php71 php72 php73 php74; do
+for PHP_EXEC in php php71 php72 php73 php74 php80; do
if which $PHP_EXEC; then
$PHP_EXEC -d auto_prepend_file=$BOOTSTRAP \
%{_bindir}/phpunit6 --verbose || RETURN_CODE=1
@@ -118,6 +120,9 @@ exit $RETURN_CODE
%changelog
+* Mon Apr 27 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
+- update to 2.1.0
+
* Fri Sep 13 2019 Remi Collet <remi@remirepo.net> - 2.0.0-2
- fix autoloader path in description