summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-15 14:21:26 +0200
committerRemi Collet <remi@remirepo.net>2019-10-15 14:21:26 +0200
commitf9d71a15a180592ef19ca38c4e1679443ee9823f (patch)
tree49f9a12d09793167af1eed35f24ed49fc0ac4854
parent028cf358b400b31869b1691e229200611bbb2748 (diff)
update to 7.4.0RC4
-rw-r--r--e1362b3cf0021c1c8492594da08b7a017b3585ba.patch53
-rw-r--r--f633c347574c0d814050b4bf2493e0cac6a5988c.patch36
-rw-r--r--failed.txt14
-rw-r--r--php.ini12
-rw-r--r--php74.spec13
5 files changed, 26 insertions, 102 deletions
diff --git a/e1362b3cf0021c1c8492594da08b7a017b3585ba.patch b/e1362b3cf0021c1c8492594da08b7a017b3585ba.patch
deleted file mode 100644
index 3fd99a8..0000000
--- a/e1362b3cf0021c1c8492594da08b7a017b3585ba.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From e1362b3cf0021c1c8492594da08b7a017b3585ba Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 7 Oct 2019 16:31:09 +0200
-Subject: [PATCH] add librt for opcache
-
----
- ext/opcache/config.m4 | 14 ++++++++++++--
- 1 file changed, 12 insertions(+), 2 deletions(-)
-
-diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
-index a388dd787b67..6c40cafc1c39 100644
---- a/ext/opcache/config.m4
-+++ b/ext/opcache/config.m4
-@@ -13,6 +13,9 @@ PHP_ARG_ENABLE([huge-code-pages],
-
- if test "$PHP_OPCACHE" != "no"; then
-
-+ dnl Always build as shared extension
-+ ext_shared=yes
-+
- if test "$PHP_HUGE_CODE_PAGES" = "yes"; then
- AC_DEFINE(HAVE_HUGE_CODE_PAGES, 1, [Define to enable copying PHP CODE pages into HUGE PAGES (experimental)])
- fi
-@@ -141,6 +144,7 @@ int main() {
- msg=yes],[msg=no],[msg=no])
- AC_MSG_RESULT([$msg])
-
-+ PHP_CHECK_FUNC_LIB(shm_open, rt)
- AC_MSG_CHECKING(for mmap() using shm_open() shared memory support)
- AC_RUN_IFELSE([AC_LANG_SOURCE([[
- #include <sys/types.h>
-@@ -207,8 +211,13 @@ int main() {
- }
- ]])],[dnl
- AC_DEFINE(HAVE_SHM_MMAP_POSIX, 1, [Define if you have POSIX mmap() SHM support])
-- msg=yes],[msg=no],[msg=no])
-- AC_MSG_RESULT([$msg])
-+ AC_MSG_RESULT([yes])
-+ PHP_CHECK_LIBRARY(rt, shm_unlink, [PHP_ADD_LIBRARY(rt,1,OPCACHE_SHARED_LIBADD)])
-+ ],[
-+ AC_MSG_RESULT([no])
-+ ],[
-+ AC_MSG_RESULT([no])
-+ ])
-
- PHP_NEW_EXTENSION(opcache,
- ZendAccelerator.c \
-@@ -250,4 +259,5 @@ int main() {
-
- PHP_ADD_BUILD_DIR([$ext_builddir/Optimizer], 1)
- PHP_ADD_EXTENSION_DEP(opcache, pcre)
-+ PHP_SUBST(OPCACHE_SHARED_LIBADD)
- fi
diff --git a/f633c347574c0d814050b4bf2493e0cac6a5988c.patch b/f633c347574c0d814050b4bf2493e0cac6a5988c.patch
deleted file mode 100644
index 55fa13c..0000000
--- a/f633c347574c0d814050b4bf2493e0cac6a5988c.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From f633c347574c0d814050b4bf2493e0cac6a5988c Mon Sep 17 00:00:00 2001
-From: Dmitry Stogov <dmitry@zend.com>
-Date: Thu, 19 Sep 2019 23:44:53 +0300
-Subject: [PATCH] Don't buid static libaraies when only DSO required
-
----
- build/Makefile.global | 2 +-
- build/php.m4 | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/build/Makefile.global b/build/Makefile.global
-index 82e0d69f35e3..3aec9fc9d597 100644
---- a/build/Makefile.global
-+++ b/build/Makefile.global
-@@ -16,7 +16,7 @@ build-modules: $(PHP_MODULES) $(PHP_ZEND_EX)
- build-binaries: $(PHP_BINARIES)
-
- libphp$(PHP_MAJOR_VERSION).la: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
-- $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
-+ $(LIBTOOL) --mode=link --tag=disable-static $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
- -@$(LIBTOOL) --silent --mode=install cp $@ $(phptempdir)/$@ >/dev/null 2>&1
-
- libs/libphp$(PHP_MAJOR_VERSION).bundle: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
-diff --git a/build/php.m4 b/build/php.m4
-index 3624a33a8eec..3d6a1133777b 100644
---- a/build/php.m4
-+++ b/build/php.m4
-@@ -849,7 +849,7 @@ AC_DEFUN([PHP_SHARED_MODULE],[
- \$(LIBTOOL) --mode=install cp $3/$1.$suffix \$(phplibdir)
-
- $3/$1.$suffix: \$($2) \$(translit($1,a-z_-,A-Z__)_SHARED_DEPENDENCIES)
-- \$(LIBTOOL) --mode=link ifelse($4,,[\$(CC)],[\$(CXX)]) \$(COMMON_FLAGS) \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(LDFLAGS) $additional_flags -o [\$]@ -export-dynamic -avoid-version -prefer-pic -module -rpath \$(phplibdir) \$(EXTRA_LDFLAGS) \$($2) \$(translit($1,a-z_-,A-Z__)_SHARED_LIBADD)
-+ \$(LIBTOOL) --mode=link --tag=disable-static ifelse($4,,[\$(CC)],[\$(CXX)]) \$(COMMON_FLAGS) \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(LDFLAGS) $additional_flags -o [\$]@ -export-dynamic -avoid-version -prefer-pic -module -rpath \$(phplibdir) \$(EXTRA_LDFLAGS) \$($2) \$(translit($1,a-z_-,A-Z__)_SHARED_LIBADD)
-
- EOF
- ])
diff --git a/failed.txt b/failed.txt
index 62aec84..867e3e5 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,19 +1,21 @@
-===== 7.4.0RC3 (2019-10-03)
+===== 7.4.0RC4 (2019-10-17)
$ grep -ar 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/el7x/build.log:Tests failed : 0
-/var/lib/mock/el8x74/build.log:Tests failed : 16
+/var/lib/mock/el8x74/build.log:Tests failed : 28
/var/lib/mock/fc29i/build.log:Tests failed : 0
/var/lib/mock/fc29x/build.log:Tests failed : 0
/var/lib/mock/fc30i/build.log:Tests failed : 1
/var/lib/mock/fc30x/build.log:Tests failed : 0
-/var/lib/mock/fc31i/build.log:Tests failed : 0
-/var/lib/mock/fc31x/build.log:Tests failed : 0
+/var/lib/mock/fc31x/build.log:Tests failed : 2
-fc30x
- 6 SPL: DirectoryIterator and clone [ext/spl/tests/dit_004.phpt]
+fc30i
+ 6 Bug #61977 Test exit code for various errors [sapi/cli/tests/bug43177.phpt]
+fc31x
+ 6 Bug #70198 Checking liveness does not work as expected [ext/standard/tests/streams/bug70198.phpt]
+ 6 Test get_headers() function : test with context [ext/standard/tests/url/get_headers_error_003.phpt]
1 proc_open give erratic test results :(
diff --git a/php.ini b/php.ini
index e7db839..6f476b2 100644
--- a/php.ini
+++ b/php.ini
@@ -284,6 +284,13 @@ implicit_flush = Off
; callback-function.
unserialize_callback_func =
+; The unserialize_max_depth specifies the default depth limit for unserialized
+; structures. Setting the depth limit too high may result in stack overflows
+; during unserialization. The unserialize_max_depth ini setting can be
+; overridden by the max_depth option on individual unserialize() calls.
+; A value of 0 disables the depth limit.
+;unserialize_max_depth = 4096
+
; When floats & doubles are serialized, store serialize_precision significant
; digits after the floating point. The default value ensures that when floats
; are decoded with unserialize, the data will remain the same.
@@ -1568,6 +1575,11 @@ zend.assertions = -1
; Default: 100000
;mbstring.regex_stack_limit=100000
+; This directive specifies maximum retry count for mbstring regular expressions. It is similar
+; to the pcre.backtrack_limit for PCRE.
+; Default: 1000000
+;mbstring.regex_retry_limit=1000000
+
[gd]
; Tell the jpeg decode to ignore warnings and try to create
; a gd image. The warning will then be displayed as notices
diff --git a/php74.spec b/php74.spec
index 6280cbd..5e5e6db 100644
--- a/php74.spec
+++ b/php74.spec
@@ -97,13 +97,13 @@
%global with_zip 0
%global upver 7.4.0
-%global rcver RC3
-%global lower RC3
+%global rcver RC4
+%global lower RC4
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 8%{?dist}
+Release: 9%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -160,8 +160,6 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: https://github.com/php/php-src/commit/f633c347574c0d814050b4bf2493e0cac6a5988c.patch
-Patch101: https://github.com/php/php-src/commit/e1362b3cf0021c1c8492594da08b7a017b3585ba.patch
# Security fixes (200+)
@@ -1156,8 +1154,6 @@ in pure PHP.
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -R
-%patch101 -p1 -b .up
# security patches
@@ -2155,6 +2151,9 @@ fi
%changelog
+* Tue Oct 15 2019 Remi Collet <remi@remirepo.net> - 7.4.0~RC4-9
+- update to 7.4.0RC4
+
* Thu Oct 10 2019 Remi Collet <remi@remirepo.net> - 7.4.0~RC3-8
- fix librt issue on F31 using upstream patch