summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-10 12:05:13 +0200
committerRemi Collet <remi@remirepo.net>2019-10-10 12:05:13 +0200
commit028cf358b400b31869b1691e229200611bbb2748 (patch)
tree8e70426f9964e44f6dfbd17d5fe29a195fc82121
parent140b6cd9fbb7f7f574e90fac3134b1ee158b39ef (diff)
fix librt issue on F31 using upstream patch
-rw-r--r--e1362b3cf0021c1c8492594da08b7a017b3585ba.patch53
-rw-r--r--php74.spec7
2 files changed, 59 insertions, 1 deletions
diff --git a/e1362b3cf0021c1c8492594da08b7a017b3585ba.patch b/e1362b3cf0021c1c8492594da08b7a017b3585ba.patch
new file mode 100644
index 0000000..3fd99a8
--- /dev/null
+++ b/e1362b3cf0021c1c8492594da08b7a017b3585ba.patch
@@ -0,0 +1,53 @@
+From e1362b3cf0021c1c8492594da08b7a017b3585ba Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 7 Oct 2019 16:31:09 +0200
+Subject: [PATCH] add librt for opcache
+
+---
+ ext/opcache/config.m4 | 14 ++++++++++++--
+ 1 file changed, 12 insertions(+), 2 deletions(-)
+
+diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
+index a388dd787b67..6c40cafc1c39 100644
+--- a/ext/opcache/config.m4
++++ b/ext/opcache/config.m4
+@@ -13,6 +13,9 @@ PHP_ARG_ENABLE([huge-code-pages],
+
+ if test "$PHP_OPCACHE" != "no"; then
+
++ dnl Always build as shared extension
++ ext_shared=yes
++
+ if test "$PHP_HUGE_CODE_PAGES" = "yes"; then
+ AC_DEFINE(HAVE_HUGE_CODE_PAGES, 1, [Define to enable copying PHP CODE pages into HUGE PAGES (experimental)])
+ fi
+@@ -141,6 +144,7 @@ int main() {
+ msg=yes],[msg=no],[msg=no])
+ AC_MSG_RESULT([$msg])
+
++ PHP_CHECK_FUNC_LIB(shm_open, rt)
+ AC_MSG_CHECKING(for mmap() using shm_open() shared memory support)
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #include <sys/types.h>
+@@ -207,8 +211,13 @@ int main() {
+ }
+ ]])],[dnl
+ AC_DEFINE(HAVE_SHM_MMAP_POSIX, 1, [Define if you have POSIX mmap() SHM support])
+- msg=yes],[msg=no],[msg=no])
+- AC_MSG_RESULT([$msg])
++ AC_MSG_RESULT([yes])
++ PHP_CHECK_LIBRARY(rt, shm_unlink, [PHP_ADD_LIBRARY(rt,1,OPCACHE_SHARED_LIBADD)])
++ ],[
++ AC_MSG_RESULT([no])
++ ],[
++ AC_MSG_RESULT([no])
++ ])
+
+ PHP_NEW_EXTENSION(opcache,
+ ZendAccelerator.c \
+@@ -250,4 +259,5 @@ int main() {
+
+ PHP_ADD_BUILD_DIR([$ext_builddir/Optimizer], 1)
+ PHP_ADD_EXTENSION_DEP(opcache, pcre)
++ PHP_SUBST(OPCACHE_SHARED_LIBADD)
+ fi
diff --git a/php74.spec b/php74.spec
index 77fa986..6280cbd 100644
--- a/php74.spec
+++ b/php74.spec
@@ -103,7 +103,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 7%{?dist}
+Release: 8%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -161,6 +161,7 @@ Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
Patch100: https://github.com/php/php-src/commit/f633c347574c0d814050b4bf2493e0cac6a5988c.patch
+Patch101: https://github.com/php/php-src/commit/e1362b3cf0021c1c8492594da08b7a017b3585ba.patch
# Security fixes (200+)
@@ -1156,6 +1157,7 @@ in pure PHP.
# upstream patches
%patch100 -p1 -R
+%patch101 -p1 -b .up
# security patches
@@ -2153,6 +2155,9 @@ fi
%changelog
+* Thu Oct 10 2019 Remi Collet <remi@remirepo.net> - 7.4.0~RC3-8
+- fix librt issue on F31 using upstream patch
+
* Mon Oct 7 2019 Remi Collet <remi@remirepo.net> - 7.4.0~RC3-7
- ensure all shared extensions can be loaded