summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-21 14:50:17 +0200
committerRemi Collet <remi@remirepo.net>2019-10-21 14:50:17 +0200
commit7378d34a2b44dd7ffaeaff147d0278a2cee7d369 (patch)
tree71899f80f17fd0e092b98e1c9417d3357cc78aa5
parentf9d71a15a180592ef19ca38c4e1679443ee9823f (diff)
- fix preload, add upstream patch for https://bugs.php.net/78512
- change dependency on nginx-filesystem to weak
-rw-r--r--05c5e5dfde91955263469daa2dd5afcbb5199d17.patch26
-rw-r--r--failed.txt13
-rw-r--r--php74.spec11
3 files changed, 40 insertions, 10 deletions
diff --git a/05c5e5dfde91955263469daa2dd5afcbb5199d17.patch b/05c5e5dfde91955263469daa2dd5afcbb5199d17.patch
new file mode 100644
index 0000000..81cdc23
--- /dev/null
+++ b/05c5e5dfde91955263469daa2dd5afcbb5199d17.patch
@@ -0,0 +1,26 @@
+From 05c5e5dfde91955263469daa2dd5afcbb5199d17 Mon Sep 17 00:00:00 2001
+From: Dmitry Stogov <dmitry@zend.com>
+Date: Mon, 21 Oct 2019 14:52:26 +0300
+Subject: [PATCH] Fixed bug #78512 (Cannot make preload work)
+
+---
+ NEWS | 3 +++
+ ext/opcache/ZendAccelerator.c | 5 +++++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/ext/opcache/ZendAccelerator.c b/ext/opcache/ZendAccelerator.c
+index 056c7739a0b6..636058dd0875 100644
+--- a/ext/opcache/ZendAccelerator.c
++++ b/ext/opcache/ZendAccelerator.c
+@@ -4565,6 +4565,11 @@ static int accel_finish_startup(void)
+ zend_accel_error(ACCEL_LOG_FATAL, "Preloading failed to waitpid(%d)", pid);
+ return FAILURE;
+ }
++
++ if (ZCSG(preload_script)) {
++ preload_load();
++ }
++
+ zend_shared_alloc_unlock();
+ if (WIFEXITED(status) && WEXITSTATUS(status) == 0) {
+ return SUCCESS;
diff --git a/failed.txt b/failed.txt
index 867e3e5..a6efb60 100644
--- a/failed.txt
+++ b/failed.txt
@@ -3,19 +3,16 @@
$ grep -ar 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/el7x/build.log:Tests failed : 0
-/var/lib/mock/el8x74/build.log:Tests failed : 28
+/var/lib/mock/el8x74/build.log:Tests failed : 18
/var/lib/mock/fc29i/build.log:Tests failed : 0
/var/lib/mock/fc29x/build.log:Tests failed : 0
-/var/lib/mock/fc30i/build.log:Tests failed : 1
+/var/lib/mock/fc30i/build.log:Tests failed : 0
/var/lib/mock/fc30x/build.log:Tests failed : 0
-/var/lib/mock/fc31x/build.log:Tests failed : 2
+/var/lib/mock/fc31x/build.log:Tests failed : 0
-fc30i
- 6 Bug #61977 Test exit code for various errors [sapi/cli/tests/bug43177.phpt]
-fc31x
- 6 Bug #70198 Checking liveness does not work as expected [ext/standard/tests/streams/bug70198.phpt]
- 6 Test get_headers() function : test with context [ext/standard/tests/url/get_headers_error_003.phpt]
+el7x:
+ 6 SPL: DirectoryIterator and clone [ext/spl/tests/dit_004.phpt]
1 proc_open give erratic test results :(
diff --git a/php74.spec b/php74.spec
index 5e5e6db..da00c5f 100644
--- a/php74.spec
+++ b/php74.spec
@@ -103,7 +103,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 9%{?dist}
+Release: 10%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -168,6 +168,7 @@ Patch91: php-7.2.0-oci8conf.patch
Patch300: php-7.0.10-datetests.patch
# WIP
+Patch100: https://github.com/php/php-src/commit/05c5e5dfde91955263469daa2dd5afcbb5199d17.patch
BuildRequires: gnupg2
BuildRequires: bzip2-devel
@@ -320,7 +321,8 @@ Provides: php(httpd)
%endif
%if %{with_nginx}
# for /etc/nginx ownership
-Requires: nginx-filesystem
+# Temporarily not mandatory to allow nginx for nginx repo
+Recommends: nginx-filesystem
%endif
%if 0%{?rhel}
Obsoletes: php53-fpm, php53u-fpm, php54-fpm, php54w-fpm, php55u-fpm, php55w-fpm, php56u-fpm, php56w-fpm
@@ -1163,6 +1165,7 @@ in pure PHP.
%endif
# WIP patch
+%patch100 -p1
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -2151,6 +2154,10 @@ fi
%changelog
+* Mon Oct 21 2019 Remi Collet <remi@remirepo.net> - 7.4.0~RC4-10
+- fix preload, add upstream patch for https://bugs.php.net/78512
+- change dependency on nginx-filesystem to weak
+
* Tue Oct 15 2019 Remi Collet <remi@remirepo.net> - 7.4.0~RC4-9
- update to 7.4.0RC4