summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJarrod Makin <jmakin@godaddy.com>2019-01-07 14:10:22 +0000
committerRemi Collet <remi@remirepo.net>2019-01-07 15:46:30 +0100
commitb0f1fa504c35bd1c7a94cdd2c15c62a6667e91a7 (patch)
treecf7545d31bba7d2d7dd4ec41c90545cf06a2126b
parent91186080032f03d6803f95a59b6ba0f58b96ada8 (diff)
Enable build to complete if 'with_zts' is set to 0
-rw-r--r--php73.spec4
1 files changed, 4 insertions, 0 deletions
diff --git a/php73.spec b/php73.spec
index 5b1e270..326cae9 100644
--- a/php73.spec
+++ b/php73.spec
@@ -1849,7 +1849,9 @@ for mod in pgsql odbc ldap snmp xmlrpc imap json \
# some extensions have their own config file
if [ -f ${ini} ]; then
cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini}
+ %if %{with_zts}
cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/${ini}
+ %endif
else
cat > $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini} <<EOF
; Enable ${mod} extension module
@@ -1909,9 +1911,11 @@ cat files.curl files.phar files.fileinfo \
# The default Zend OPcache blacklist file
install -m 644 %{SOURCE51} $RPM_BUILD_ROOT%{_sysconfdir}/php.d/opcache-default.blacklist
+%if %{with_zts}
install -m 644 %{SOURCE51} $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/opcache-default.blacklist
sed -e '/blacklist_filename/s/php.d/php-zts.d/' \
-i $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/10-opcache.ini
+%endif
# Install the macros file:
sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \