summaryrefslogtreecommitdiffstats
path: root/php73.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php73.spec')
-rw-r--r--php73.spec4
1 files changed, 4 insertions, 0 deletions
diff --git a/php73.spec b/php73.spec
index 5b1e270..326cae9 100644
--- a/php73.spec
+++ b/php73.spec
@@ -1849,7 +1849,9 @@ for mod in pgsql odbc ldap snmp xmlrpc imap json \
# some extensions have their own config file
if [ -f ${ini} ]; then
cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini}
+ %if %{with_zts}
cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/${ini}
+ %endif
else
cat > $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini} <<EOF
; Enable ${mod} extension module
@@ -1909,9 +1911,11 @@ cat files.curl files.phar files.fileinfo \
# The default Zend OPcache blacklist file
install -m 644 %{SOURCE51} $RPM_BUILD_ROOT%{_sysconfdir}/php.d/opcache-default.blacklist
+%if %{with_zts}
install -m 644 %{SOURCE51} $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/opcache-default.blacklist
sed -e '/blacklist_filename/s/php.d/php-zts.d/' \
-i $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/10-opcache.ini
+%endif
# Install the macros file:
sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \