summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-30 17:56:34 +0200
committerRemi Collet <remi@remirepo.net>2019-07-30 17:56:34 +0200
commit8839affa96b4ded7033a079ccb2b5f3e7dc807f1 (patch)
tree143eadc6525a410f1479ef63dddf3e8312241a2c
parent621cb98a0cece6f52e2d017fc4f225645edb1f0c (diff)
Update to 7.3.8 - http://www.php.net/releases/7_3_8.php
-rw-r--r--failed.txt13
-rw-r--r--php-bug77287.patch38
-rw-r--r--php-bug78297.patch62
-rw-r--r--php-upstream.patch26
-rw-r--r--php73.spec11
5 files changed, 12 insertions, 138 deletions
diff --git a/failed.txt b/failed.txt
index e1954cd..ce2f385 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,19 +1,21 @@
-===== 7.3.8RC1 (2019-07-18)
+===== 7.3.8 (2019-08-01)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/el6i/build.log:Tests failed : 0
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
-/var/lib/mock/el8x73/build.log:Tests failed : 13
-/var/lib/mock/fc28i/build.log:Tests failed : 0
-/var/lib/mock/fc28x/build.log:Tests failed : 0
+/var/lib/mock/el8x73/build.log:Tests failed : 14
+/var/lib/mock/fc28i/build.log:Tests failed : 1
+/var/lib/mock/fc28x/build.log:Tests failed : 1
/var/lib/mock/fc29i/build.log:Tests failed : 0
/var/lib/mock/fc29x/build.log:Tests failed : 0
/var/lib/mock/fc30i/build.log:Tests failed : 0
/var/lib/mock/fc30x/build.log:Tests failed : 0
+el8x, fc28i, fc28x:
+ 6 Bug #78338 (Array cross-border reading in PCRE) [ext/pcre/tests/bug78338.phpt]
el8x:
5 buildroot issue with openssl under investigation
@@ -23,5 +25,4 @@ el8x:
3 known issue
4 bugs related to tzdata
5 need investigation
-6 https://bugzilla.redhat.com/1632640
-
+6 https://bugzilla.redhat.com/1734468
diff --git a/php-bug77287.patch b/php-bug77287.patch
deleted file mode 100644
index 4df20d6..0000000
--- a/php-bug77287.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 76760901fabf8ff53c8dfb4ddf7ca703c5a12b79 Mon Sep 17 00:00:00 2001
-From: Nikita Popov <nikita.ppv@gmail.com>
-Date: Tue, 22 Jan 2019 12:15:06 +0100
-Subject: [PATCH] Fixed bug #77287
-
-There may be an EXT_NOP opcode before the parameter list, we should
-skip over it.
----
- NEWS | 2 ++
- ext/opcache/Optimizer/compact_literals.c | 2 +-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/NEWS b/NEWS
-index 6265b1736c6d..656e4ab70eaa 100644
---- a/NEWS
-+++ b/NEWS
-@@ -61,6 +61,8 @@ PHP NEWS
- (Nikita)
- . Fixed bug #77361 (configure fails on 64-bit AIX when opcache enabled).
- (Kevin Adler)
-+ . Fixed bug #77287 (Opcache literal compaction is incompatible with EXT
-+ opcodes). (Nikita)
-
- - PCRE:
- . Fixed bug #77338 (get_browser with empty string). (Nikita)
-diff --git a/ext/opcache/Optimizer/compact_literals.c b/ext/opcache/Optimizer/compact_literals.c
-index 10bdf540118e..fdab0068a4d5 100644
---- a/ext/opcache/Optimizer/compact_literals.c
-+++ b/ext/opcache/Optimizer/compact_literals.c
-@@ -810,7 +810,7 @@ void zend_optimizer_compact_literals(zend_op_array *op_array, zend_optimizer_ctx
- Z_CACHE_SLOT_P(val) = op_array->cache_size;
- op_array->cache_size += sizeof(zval);
- }
-- } else if (opline->opcode != ZEND_RECV) {
-+ } else if (opline->opcode != ZEND_RECV && opline->opcode != ZEND_EXT_NOP) {
- break;
- }
- opline++;
diff --git a/php-bug78297.patch b/php-bug78297.patch
deleted file mode 100644
index 396a161..0000000
--- a/php-bug78297.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From f3e71b3b730eabc2b12871b3a19dad815219bcb9 Mon Sep 17 00:00:00 2001
-From: Nikita Popov <nikita.ppv@gmail.com>
-Date: Tue, 16 Jul 2019 11:08:27 +0200
-Subject: [PATCH] Fixed bug #78297
-
-(cherry picked from commit 8a19fe29de77d7477d59db472dd6aadabd5ac249)
----
- NEWS | 5 +++++
- sapi/phpdbg/phpdbg_list.c | 1 +
- sapi/phpdbg/tests/bug78297.phpt | 16 ++++++++++++++++
- 3 files changed, 22 insertions(+)
- create mode 100644 sapi/phpdbg/tests/bug78297.phpt
-
-diff --git a/NEWS b/NEWS
-index ae6a3c5405d8..76e8f830a0bb 100644
---- a/NEWS
-+++ b/NEWS
-@@ -1,5 +1,10 @@
- PHP NEWS
- |||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
-+?? ??? ????, PHP 7.3.8
-+
-+- Phpdbg:
-+ . Fixed bug #78297 (Include unexistent file memory leak). (Nikita)
-+
- 18 Jul 2019, PHP 7.3.8RC1
-
- - Core:
-diff --git a/sapi/phpdbg/phpdbg_list.c b/sapi/phpdbg/phpdbg_list.c
-index aab641cb5606..a9b0f4b815cf 100644
---- a/sapi/phpdbg/phpdbg_list.c
-+++ b/sapi/phpdbg/phpdbg_list.c
-@@ -248,6 +248,7 @@ zend_op_array *phpdbg_compile_file(zend_file_handle *file, int type) {
- } else {
- zend_message_dispatcher(ZMSG_FAILED_INCLUDE_FOPEN, file->filename);
- }
-+ return NULL;
- }
-
- data.buf = estrndup(bufptr, len);
-diff --git a/sapi/phpdbg/tests/bug78297.phpt b/sapi/phpdbg/tests/bug78297.phpt
-new file mode 100644
-index 000000000000..47b13ad60544
---- /dev/null
-+++ b/sapi/phpdbg/tests/bug78297.phpt
-@@ -0,0 +1,16 @@
-+--TEST--
-+Bug #78297: Include unexistent file memory leak
-+--PHPDBG--
-+r
-+q
-+--FILE--
-+<?php
-+include "does_not_exist.php";
-+--EXPECTF--
-+[Successful compilation of %s]
-+prompt>
-+Warning: include(%s): failed to open stream: No such file or directory in %s on line %d
-+
-+Warning: include(): Failed opening 'does_not_exist.php' for inclusion (include_path=%s) in %s on line %d
-+[Script ended normally]
-+prompt>
diff --git a/php-upstream.patch b/php-upstream.patch
deleted file mode 100644
index ecd8d8f..0000000
--- a/php-upstream.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From e6c2b288652cf9c8d0b92d2842d73b3eb2431860 Mon Sep 17 00:00:00 2001
-From: George Peter Banyard <girgias@php.net>
-Date: Thu, 11 Jul 2019 16:06:41 +0200
-Subject: [PATCH] Convert short tag to standard tag in Zend test file
-
-Closes GH-4389.
----
- Zend/tests/bug78271.phpt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Zend/tests/bug78271.phpt b/Zend/tests/bug78271.phpt
-index fbbe016..70eba17 100644
---- a/Zend/tests/bug78271.phpt
-+++ b/Zend/tests/bug78271.phpt
-@@ -1,7 +1,7 @@
- --TEST--
- Bug #78271: Invalid result of if-else
- --FILE--
--<?
-+<?php
- function test($a, $b){
- if ($a==10) {
- $w="x";
---
-2.1.4
-
diff --git a/php73.spec b/php73.spec
index 0a65079..bf84d8a 100644
--- a/php73.spec
+++ b/php73.spec
@@ -117,8 +117,8 @@
%endif
%global upver 7.3.8
-%global rcver RC1
-%global lower RC1
+#global rcver RC1
+#global lower RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -181,8 +181,6 @@ Patch48: php-7.3.3-pdooci.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-bug78297.patch
-Patch101: php-upstream.patch
# Security fixes (200+)
@@ -1152,8 +1150,6 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .78297
-%patch101 -p1 -b .up
# security patches
@@ -2238,6 +2234,9 @@ fi
%changelog
+* Tue Jul 30 2019 Remi Collet <remi@remirepo.net> - 7.3.8-1
+- Update to 7.3.8 - http://www.php.net/releases/7_3_8.php
+
* Tue Jul 16 2019 Remi Collet <remi@remirepo.net> - 7.3.8~RC1-1
- update to 7.3.8RC1
- add upstream patch for #78297