summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-16 16:34:12 +0200
committerRemi Collet <remi@remirepo.net>2019-07-16 16:34:12 +0200
commit621cb98a0cece6f52e2d017fc4f225645edb1f0c (patch)
treee7376eca03b96a8289cabf0f44223b389e2a6a4e
parent51cbcdbe43f65c027e78e0bf5c861d290a838693 (diff)
- update to 7.3.8RC1
- add upstream patch for #78297 - main package now recommends commonly used extensions (json, mbstring, opcache, pdo, xml)
-rw-r--r--failed.txt4
-rw-r--r--php-bug78297.patch62
-rw-r--r--php-upstream.patch26
-rw-r--r--php73.spec26
4 files changed, 110 insertions, 8 deletions
diff --git a/failed.txt b/failed.txt
index 43a1206..e1954cd 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.3.7 (2019-07-04)
+===== 7.3.8RC1 (2019-07-18)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
@@ -6,8 +6,6 @@ $ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/el8x73/build.log:Tests failed : 13
-/var/lib/mock/fc27i/build.log:Tests failed : 0
-/var/lib/mock/fc27x/build.log:Tests failed : 0
/var/lib/mock/fc28i/build.log:Tests failed : 0
/var/lib/mock/fc28x/build.log:Tests failed : 0
/var/lib/mock/fc29i/build.log:Tests failed : 0
diff --git a/php-bug78297.patch b/php-bug78297.patch
new file mode 100644
index 0000000..396a161
--- /dev/null
+++ b/php-bug78297.patch
@@ -0,0 +1,62 @@
+From f3e71b3b730eabc2b12871b3a19dad815219bcb9 Mon Sep 17 00:00:00 2001
+From: Nikita Popov <nikita.ppv@gmail.com>
+Date: Tue, 16 Jul 2019 11:08:27 +0200
+Subject: [PATCH] Fixed bug #78297
+
+(cherry picked from commit 8a19fe29de77d7477d59db472dd6aadabd5ac249)
+---
+ NEWS | 5 +++++
+ sapi/phpdbg/phpdbg_list.c | 1 +
+ sapi/phpdbg/tests/bug78297.phpt | 16 ++++++++++++++++
+ 3 files changed, 22 insertions(+)
+ create mode 100644 sapi/phpdbg/tests/bug78297.phpt
+
+diff --git a/NEWS b/NEWS
+index ae6a3c5405d8..76e8f830a0bb 100644
+--- a/NEWS
++++ b/NEWS
+@@ -1,5 +1,10 @@
+ PHP NEWS
+ |||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
++?? ??? ????, PHP 7.3.8
++
++- Phpdbg:
++ . Fixed bug #78297 (Include unexistent file memory leak). (Nikita)
++
+ 18 Jul 2019, PHP 7.3.8RC1
+
+ - Core:
+diff --git a/sapi/phpdbg/phpdbg_list.c b/sapi/phpdbg/phpdbg_list.c
+index aab641cb5606..a9b0f4b815cf 100644
+--- a/sapi/phpdbg/phpdbg_list.c
++++ b/sapi/phpdbg/phpdbg_list.c
+@@ -248,6 +248,7 @@ zend_op_array *phpdbg_compile_file(zend_file_handle *file, int type) {
+ } else {
+ zend_message_dispatcher(ZMSG_FAILED_INCLUDE_FOPEN, file->filename);
+ }
++ return NULL;
+ }
+
+ data.buf = estrndup(bufptr, len);
+diff --git a/sapi/phpdbg/tests/bug78297.phpt b/sapi/phpdbg/tests/bug78297.phpt
+new file mode 100644
+index 000000000000..47b13ad60544
+--- /dev/null
++++ b/sapi/phpdbg/tests/bug78297.phpt
+@@ -0,0 +1,16 @@
++--TEST--
++Bug #78297: Include unexistent file memory leak
++--PHPDBG--
++r
++q
++--FILE--
++<?php
++include "does_not_exist.php";
++--EXPECTF--
++[Successful compilation of %s]
++prompt>
++Warning: include(%s): failed to open stream: No such file or directory in %s on line %d
++
++Warning: include(): Failed opening 'does_not_exist.php' for inclusion (include_path=%s) in %s on line %d
++[Script ended normally]
++prompt>
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..ecd8d8f
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,26 @@
+From e6c2b288652cf9c8d0b92d2842d73b3eb2431860 Mon Sep 17 00:00:00 2001
+From: George Peter Banyard <girgias@php.net>
+Date: Thu, 11 Jul 2019 16:06:41 +0200
+Subject: [PATCH] Convert short tag to standard tag in Zend test file
+
+Closes GH-4389.
+---
+ Zend/tests/bug78271.phpt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Zend/tests/bug78271.phpt b/Zend/tests/bug78271.phpt
+index fbbe016..70eba17 100644
+--- a/Zend/tests/bug78271.phpt
++++ b/Zend/tests/bug78271.phpt
+@@ -1,7 +1,7 @@
+ --TEST--
+ Bug #78271: Invalid result of if-else
+ --FILE--
+-<?
++<?php
+ function test($a, $b){
+ if ($a==10) {
+ $w="x";
+--
+2.1.4
+
diff --git a/php73.spec b/php73.spec
index c957321..0a65079 100644
--- a/php73.spec
+++ b/php73.spec
@@ -116,14 +116,14 @@
%global db_devel libdb-devel
%endif
-%global upver 7.3.7
-#global rcver RC3
-#global lower RC3
+%global upver 7.3.8
+%global rcver RC1
+%global lower RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 3%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -181,6 +181,8 @@ Patch48: php-7.3.3-pdooci.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-bug78297.patch
+Patch101: php-upstream.patch
# Security fixes (200+)
@@ -256,7 +258,13 @@ Requires(pre): httpd
Provides: php(httpd)
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# httpd have threaded MPM by default
-Recommends: php-fpm%{?_isa} = %{version}-%{release}
+Recommends: php-fpm%{?_isa} = %{version}-%{release}
+# as "php" is now mostly a meta-package, commonly used extensions
+Recommends: php-json%{?_isa} = %{version}-%{release}
+Recommends: php-mbstring%{?_isa} = %{version}-%{release}
+Recommends: php-opcache%{?_isa} = %{version}-%{release}
+Recommends: php-pdo%{?_isa} = %{version}-%{release}
+Recommends: php-xml%{?_isa} = %{version}-%{release}
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -1144,6 +1152,8 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .78297
+%patch101 -p1 -b .up
# security patches
@@ -2228,6 +2238,12 @@ fi
%changelog
+* Tue Jul 16 2019 Remi Collet <remi@remirepo.net> - 7.3.8~RC1-1
+- update to 7.3.8RC1
+- add upstream patch for #78297
+- main package now recommends commonly used extensions
+ (json, mbstring, opcache, pdo, xml)
+
* Wed Jul 3 2019 Remi Collet <remi@remirepo.net> - 7.3.7-3
- rebuild 7.3.7 (new tag)