summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-14 15:05:29 +0200
committerRemi Collet <remi@remirepo.net>2019-05-14 15:05:29 +0200
commit6553c0c2a63e1038945c80aef2c09a92804cc398 (patch)
treeb40df25898af5bd1212b1eac2fdde328f029db5c
parent86de6e2d3d3d91507f05b0ca38cc19dee2506bd4 (diff)
v7.3.6RC1
-rw-r--r--.gitignore2
-rw-r--r--Makefile9
-rw-r--r--failed.txt6
-rw-r--r--php73.spec11
-rw-r--r--tembed.c15
5 files changed, 31 insertions, 12 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..aca98dd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,5 @@ package-*.xml
*.tar.xz.asc
*.src.rpm
*/*rpm
+tembed
+TODO*
diff --git a/Makefile b/Makefile
index 7aca750..78ac8ed 100644
--- a/Makefile
+++ b/Makefile
@@ -2,13 +2,10 @@ SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
INCL1 := $(shell php-config --includes)
INCL2 := -I $(shell php-config --include-dir)/sapi/embed
-LIBS := -lphp5 $(shell php-config --libs)
+LIBE := -lphp7
+LIBS := -lphp7 $(shell php-config --libs)
include ../../common/Makefile
tembed: tembed.c
- gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
-
-debug:
- time rpmbuild $(RPMDEFINES) --with debug -bb $(NAME).spec
-
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBE) -o tembed
diff --git a/failed.txt b/failed.txt
index 1247bf8..3075b28 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,8 +1,8 @@
-===== 7.3.5 (2019-05-02)
+===== 7.3.6RC1 (2019-05-16)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
-/var/lib/mock/el6i/build.log:Tests failed : 0
+/var/lib/mock/el6i/build.log:Tests failed : 1
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/el8x73/build.log:Tests failed : 13
@@ -16,6 +16,8 @@ $ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/fc30x/build.log:Tests failed : 0
+el6i:
+ 1 Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
el8x:
5 buildroot issue with openssl under investigation
diff --git a/php73.spec b/php73.spec
index 98eebf5..7d2f457 100644
--- a/php73.spec
+++ b/php73.spec
@@ -114,9 +114,9 @@
%global db_devel libdb-devel
%endif
-%global upver 7.3.5
-#global rcver RC1
-#global lower RC1
+%global upver 7.3.6
+%global rcver RC1
+%global lower RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -952,7 +952,7 @@ Obsoletes: php73u-pdo-dblib, php73w-pdo_dblib
%description pdo-dblib
The php-pdo-dblib package contains a dynamic shared object
that implements the PHP Data Objects (PDO) interface to enable access from
-PHP to Microsoft SQL Server and Sybase databases through the FreeTDS libary.
+PHP to Microsoft SQL Server and Sybase databases through the FreeTDS library.
%package embedded
Summary: PHP library for embedding in applications
@@ -2213,6 +2213,9 @@ fi
%changelog
+* Tue May 14 2019 Remi Collet <remi@remirepo.net> - 7.3.6~RC1-1
+- update to 7.3.6RC1
+
* Wed May 1 2019 Remi Collet <remi@remirepo.net> - 7.3.5-1
- Update to 7.3.5 - http://www.php.net/releases/7_3_5.php
diff --git a/tembed.c b/tembed.c
new file mode 100644
index 0000000..60595ea
--- /dev/null
+++ b/tembed.c
@@ -0,0 +1,15 @@
+#include <stdio.h>
+#include <php_embed.h>
+
+int main (int argc, char*argv[]) {
+ PHP_EMBED_START_BLOCK(argc, argv)
+ zval ver;
+ zend_eval_string("phpversion();", &ver, "Get version" TSRMLS_CC);
+ convert_to_string(&ver);
+ php_printf("Build PHP Version: %s\n", PHP_VERSION);
+ php_printf("Running PHP Version: %s\n", Z_STRVAL(ver));
+ zval_dtor(&ver);
+ PHP_EMBED_END_BLOCK()
+
+ return 0;
+}