summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-26 14:11:06 +0200
committerRemi Collet <remi@remirepo.net>2020-05-26 14:11:06 +0200
commit1956cba3746a4ca4d40c83167f3535b8d4cf0d3f (patch)
treea9fd0d3b1811f9473a22ce68e9c9e12d9e338dd8
parent33d6f3fe7a2119202cabc55f9ef966fdf5284189 (diff)
update to 7.3.19RC1
-rw-r--r--Makefile5
-rw-r--r--failed.txt11
-rw-r--r--php73.spec7
-rw-r--r--tembed.c4
4 files changed, 15 insertions, 12 deletions
diff --git a/Makefile b/Makefile
index 78ac8ed..01bd11c 100644
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,10 @@
SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
-INCL1 := $(shell php-config --includes)
-INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+INCL := $(shell php-config --includes)
LIBE := -lphp7
LIBS := -lphp7 $(shell php-config --libs)
include ../../common/Makefile
tembed: tembed.c
- gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBE) -o tembed
+ gcc -Wall $(INCL) tembed.c $(LIBS) -o tembed
diff --git a/failed.txt b/failed.txt
index ab2a2cc..a27514f 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,18 +1,19 @@
-===== 7.3.18 (2020-05-14)
+===== 7.3.19RC1 (2020-05-28)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
-/var/lib/mock/el6i/build.log:Tests failed : 0
+/var/lib/mock/el6i/build.log:Tests failed : 2
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/el8x73/build.log:Tests failed : 14
-/var/lib/mock/fc30i/build.log:Tests failed : 1
+/var/lib/mock/fc30i/build.log:Tests failed : 0
/var/lib/mock/fc30x/build.log:Tests failed : 0
/var/lib/mock/fc31x/build.log:Tests failed : 0
-fc30i
- 1 Bug #69900 Commandline input/output weird behaviour with STDIO [ext/standard/tests/streams/proc_open_bug69900.phpt]
+el6i
+ 1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
+ 1 Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
el8x:
5 buildroot issue with openssl under investigation
diff --git a/php73.spec b/php73.spec
index be032f6..d1a6752 100644
--- a/php73.spec
+++ b/php73.spec
@@ -120,8 +120,8 @@
%global db_devel libdb-devel
%endif
-%global upver 7.3.18
-#global rcver RC1
+%global upver 7.3.19
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -2249,6 +2249,9 @@ fi
%changelog
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 7.3.19~RC1-1
+- update to 7.3.19RC1
+
* Tue May 12 2020 Remi Collet <remi@remirepo.net> - 7.3.18-1
- Update to 7.3.18 - http://www.php.net/releases/7_3_18.php
diff --git a/tembed.c b/tembed.c
index 60595ea..dcb8052 100644
--- a/tembed.c
+++ b/tembed.c
@@ -1,12 +1,12 @@
#include <stdio.h>
-#include <php_embed.h>
+#include <sapi/embed/php_embed.h>
int main (int argc, char*argv[]) {
PHP_EMBED_START_BLOCK(argc, argv)
zval ver;
zend_eval_string("phpversion();", &ver, "Get version" TSRMLS_CC);
convert_to_string(&ver);
- php_printf("Build PHP Version: %s\n", PHP_VERSION);
+ php_printf("Build PHP Version: %s\n", PHP_VERSION);
php_printf("Running PHP Version: %s\n", Z_STRVAL(ver));
zval_dtor(&ver);
PHP_EMBED_END_BLOCK()