summaryrefslogtreecommitdiffstats
path: root/php71.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-26 08:47:50 +0200
committerRemi Collet <remi@remirepo.net>2017-04-26 08:47:50 +0200
commit4965e4a488ea721d9420539151b06d8a161421e7 (patch)
tree1f433b5dcdcaf1a0dd4c890f4bac227415c2dbc0 /php71.spec
parent28b7eb25cd6ab1e7e2e4099f1433561f55d2b908 (diff)
7.1.5RC1
Diffstat (limited to 'php71.spec')
-rw-r--r--php71.spec34
1 files changed, 19 insertions, 15 deletions
diff --git a/php71.spec b/php71.spec
index a6871ae..b9eb9eb 100644
--- a/php71.spec
+++ b/php71.spec
@@ -14,7 +14,7 @@
%global pdover 20150127
# Extension version
%global fileinfover 1.0.5
-%global oci8ver 2.1.3
+%global oci8ver 2.1.4
%global zipver 1.13.0
%global jsonver 1.5.0
@@ -120,13 +120,13 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
-%global rpmrel 1
+%global upver 7.1.5
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 7.1.4
-Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
+Version: %{upver}%{?rcver:~%{rcver}}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -136,7 +136,7 @@ License: PHP and Zend and BSD and MIT and ASL 1.0
Group: Development/Languages
URL: http://www.php.net/
-Source0: http://www.php.net/distributions/php-%{version}%{?rcver}.tar.xz
+Source0: http://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz
Source1: php.conf
Source2: php.ini
Source3: macros.php
@@ -994,12 +994,12 @@ support for JavaScript Object Notation (JSON) to PHP.
%prep
-echo CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} libzip=%{with_libzip}
+: CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} libzip=%{with_libzip}
# ensure than current httpd use prefork MPM.
httpd -V | grep -q 'threaded:.*yes' && exit 1
-%setup -q -n php-%{version}%{?rcver}
+%setup -q -n php-%{upver}%{?rcver}
%patch5 -p1 -b .includedir
%patch6 -p1 -b .embed
@@ -1081,8 +1081,8 @@ sed -e 's/64321/64322/' -i ext/openssl/tests/*.phpt
# Safety check for API version change.
pver=$(sed -n '/#define PHP_VERSION /{s/.* "//;s/".*$//;p}' main/php_version.h)
-if test "x${pver}" != "x%{version}%{?rcver}"; then
- : Error: Upstream PHP version is now ${pver}, expecting %{version}%{?rcver}.
+if test "x${pver}" != "x%{upver}%{?rcver}"; then
+ : Error: Upstream PHP version is now ${pver}, expecting %{upver}%{?rcver}.
: Update the version/rcver macros and rebuild.
exit 1
fi
@@ -1743,11 +1743,11 @@ EOF
%endif
fi
cat > files.${mod} <<EOF
-%attr(755,root,root) %{_libdir}/php/modules/${mod}.so
-%config(noreplace) %attr(644,root,root) %{_sysconfdir}/php.d/${ini}
+%{_libdir}/php/modules/${mod}.so
+%config(noreplace) %{_sysconfdir}/php.d/${ini}
%if %{with_zts}
-%attr(755,root,root) %{_libdir}/php-zts/modules/${mod}.so
-%config(noreplace) %attr(644,root,root) %{_sysconfdir}/php-zts.d/${ini}
+%{_libdir}/php-zts/modules/${mod}.so
+%config(noreplace) %{_sysconfdir}/php-zts.d/${ini}
%endif
EOF
done
@@ -1795,7 +1795,7 @@ sed -e '/blacklist_filename/s/php.d/php-zts.d/' \
sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
-e "s/@PHP_ZENDVER@/%{zendver}%{isasuffix}/" \
-e "s/@PHP_PDOVER@/%{pdover}%{isasuffix}/" \
- -e "s/@PHP_VERSION@/%{version}/" \
+ -e "s/@PHP_VERSION@/%{upver}/" \
%if ! %{with_zts}
-e "/zts/d" \
%endif
@@ -2057,6 +2057,10 @@ fi
%changelog
+* Tue Apr 25 2017 Remi Collet <remi@fedoraproject.org> - 7.1.5~RC1-1
+- Update to 7.1.5RC1
+- oci8 version is now 2.1.4
+
* Tue Apr 11 2017 Remi Collet <remi@fedoraproject.org> - 7.1.4-1
- Update to 7.1.4 - http://www.php.net/releases/7_1_4.php