summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-26 08:47:50 +0200
committerRemi Collet <remi@remirepo.net>2017-04-26 08:47:50 +0200
commit4965e4a488ea721d9420539151b06d8a161421e7 (patch)
tree1f433b5dcdcaf1a0dd4c890f4bac227415c2dbc0
parent28b7eb25cd6ab1e7e2e4099f1433561f55d2b908 (diff)
7.1.5RC1
-rw-r--r--failed.txt16
-rw-r--r--php-7.0.10-datetests.patch53
-rw-r--r--php71.spec34
3 files changed, 78 insertions, 25 deletions
diff --git a/failed.txt b/failed.txt
index 3def01b..d42f70b 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,24 +1,20 @@
-===== 7.1.4 (2017-04-13)
+===== 7.1.5RC1 (2017-04-27)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/el6i/build.log:Tests failed : 1
-/var/lib/mock/el6x/build.log:Tests failed : 1
-/var/lib/mock/el7x/build.log:Tests failed : 1
+/var/lib/mock/el6i/build.log:Tests failed : 0
+/var/lib/mock/el6x/build.log:Tests failed : 0
+/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/fc23i/build.log:Tests failed : 0
/var/lib/mock/fc23x/build.log:Tests failed : 0
-/var/lib/mock/fc24i/build.log:Tests failed : 1
-/var/lib/mock/fc24x/build.log:Tests failed : 1
+/var/lib/mock/fc24i/build.log:Tests failed : 0
+/var/lib/mock/fc24x/build.log:Tests failed : 0
/var/lib/mock/fc25i/build.log:Tests failed : 0
/var/lib/mock/fc25x/build.log:Tests failed : 0
/var/lib/mock/fc26i/build.log:Tests failed : 1
/var/lib/mock/fc26x/build.log:Tests failed : 1
-el6i, el6x, el7x
- Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
-fc24i, fc24x
- (4) Bug #33415 [2] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-2.phpt]
fc26i, fc26x
(3) sni_server [ext/openssl/tests/sni_server.phpt]
diff --git a/php-7.0.10-datetests.patch b/php-7.0.10-datetests.patch
index 7df99a5..fc42326 100644
--- a/php-7.0.10-datetests.patch
+++ b/php-7.0.10-datetests.patch
@@ -42,3 +42,56 @@ diff -up ./ext/date/tests/strtotime3-64bit.phpt.datetests ./ext/date/tests/strto
string(31) "Fri, 16 Jun 2006 02:22:33 +0100"
bool(false)
string(31) "Tue, 02 Mar 2004 00:00:00 +0000"
+diff -up ./ext/date/tests/bug33414-2.phpt.old ./ext/date/tests/bug33414-2.phpt
+--- ./ext/date/tests/bug33414-2.phpt.old 2017-04-25 15:47:21.675700587 +0200
++++ ./ext/date/tests/bug33414-2.phpt 2017-04-25 15:57:14.034681111 +0200
+@@ -74,10 +74,10 @@ $strtotime_tstamp = strtotime("next Frid
+ print "result=".date("l Y-m-d H:i:s T I", $strtotime_tstamp)."\n";
+ print "wanted=Friday 00:00:00\n\n";
+ ?>
+---EXPECT--
++--EXPECTF--
+ TZ=Pacific/Rarotonga - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 -1030 0
+-result=Tuesday 1970-01-06 00:00:00 -1030 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Tuesday 1970-01-06 00:00:00 %s
+ wanted=Tuesday 00:00:00
+
+ TZ=Atlantic/South_Georgia - wrong day.
+@@ -91,13 +91,13 @@ result=Monday 2005-04-04 00:00:00 EDT 1
+ wanted=Monday 00:00:00
+
+ TZ=Pacific/Enderbury - wrong day, off by 2 days.
+-tStamp=Thursday 1970-01-01 17:17:17 -12 0
+-result=Monday 1970-01-05 00:00:00 -12 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Monday 1970-01-05 00:00:00 %s
+ wanted=Monday 00:00:00
+
+ TZ=Pacific/Kiritimati - wrong day, off by 2 days.
+-tStamp=Thursday 1970-01-01 17:17:17 -1040 0
+-result=Monday 1970-01-05 00:00:00 -1040 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Monday 1970-01-05 00:00:00 %s
+ wanted=Monday 00:00:00
+
+ TZ=America/Managua - wrong day.
+@@ -106,13 +106,13 @@ result=Tuesday 2005-04-12 00:00:00 CDT 1
+ wanted=Tuesday 00:00:00
+
+ TZ=Pacific/Pitcairn - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 -0830 0
+-result=Wednesday 1970-01-07 00:00:00 -0830 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Wednesday 1970-01-07 00:00:00 %s
+ wanted=Wednesday 00:00:00
+
+ TZ=Pacific/Fakaofo - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 -11 0
+-result=Saturday 1970-01-03 00:00:00 -11 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Saturday 1970-01-03 00:00:00 %s
+ wanted=Saturday 00:00:00
+
+ TZ=Pacific/Johnston - wrong day.
diff --git a/php71.spec b/php71.spec
index a6871ae..b9eb9eb 100644
--- a/php71.spec
+++ b/php71.spec
@@ -14,7 +14,7 @@
%global pdover 20150127
# Extension version
%global fileinfover 1.0.5
-%global oci8ver 2.1.3
+%global oci8ver 2.1.4
%global zipver 1.13.0
%global jsonver 1.5.0
@@ -120,13 +120,13 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
-%global rpmrel 1
+%global upver 7.1.5
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 7.1.4
-Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
+Version: %{upver}%{?rcver:~%{rcver}}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -136,7 +136,7 @@ License: PHP and Zend and BSD and MIT and ASL 1.0
Group: Development/Languages
URL: http://www.php.net/
-Source0: http://www.php.net/distributions/php-%{version}%{?rcver}.tar.xz
+Source0: http://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz
Source1: php.conf
Source2: php.ini
Source3: macros.php
@@ -994,12 +994,12 @@ support for JavaScript Object Notation (JSON) to PHP.
%prep
-echo CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} libzip=%{with_libzip}
+: CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} libzip=%{with_libzip}
# ensure than current httpd use prefork MPM.
httpd -V | grep -q 'threaded:.*yes' && exit 1
-%setup -q -n php-%{version}%{?rcver}
+%setup -q -n php-%{upver}%{?rcver}
%patch5 -p1 -b .includedir
%patch6 -p1 -b .embed
@@ -1081,8 +1081,8 @@ sed -e 's/64321/64322/' -i ext/openssl/tests/*.phpt
# Safety check for API version change.
pver=$(sed -n '/#define PHP_VERSION /{s/.* "//;s/".*$//;p}' main/php_version.h)
-if test "x${pver}" != "x%{version}%{?rcver}"; then
- : Error: Upstream PHP version is now ${pver}, expecting %{version}%{?rcver}.
+if test "x${pver}" != "x%{upver}%{?rcver}"; then
+ : Error: Upstream PHP version is now ${pver}, expecting %{upver}%{?rcver}.
: Update the version/rcver macros and rebuild.
exit 1
fi
@@ -1743,11 +1743,11 @@ EOF
%endif
fi
cat > files.${mod} <<EOF
-%attr(755,root,root) %{_libdir}/php/modules/${mod}.so
-%config(noreplace) %attr(644,root,root) %{_sysconfdir}/php.d/${ini}
+%{_libdir}/php/modules/${mod}.so
+%config(noreplace) %{_sysconfdir}/php.d/${ini}
%if %{with_zts}
-%attr(755,root,root) %{_libdir}/php-zts/modules/${mod}.so
-%config(noreplace) %attr(644,root,root) %{_sysconfdir}/php-zts.d/${ini}
+%{_libdir}/php-zts/modules/${mod}.so
+%config(noreplace) %{_sysconfdir}/php-zts.d/${ini}
%endif
EOF
done
@@ -1795,7 +1795,7 @@ sed -e '/blacklist_filename/s/php.d/php-zts.d/' \
sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
-e "s/@PHP_ZENDVER@/%{zendver}%{isasuffix}/" \
-e "s/@PHP_PDOVER@/%{pdover}%{isasuffix}/" \
- -e "s/@PHP_VERSION@/%{version}/" \
+ -e "s/@PHP_VERSION@/%{upver}/" \
%if ! %{with_zts}
-e "/zts/d" \
%endif
@@ -2057,6 +2057,10 @@ fi
%changelog
+* Tue Apr 25 2017 Remi Collet <remi@fedoraproject.org> - 7.1.5~RC1-1
+- Update to 7.1.5RC1
+- oci8 version is now 2.1.4
+
* Tue Apr 11 2017 Remi Collet <remi@fedoraproject.org> - 7.1.4-1
- Update to 7.1.4 - http://www.php.net/releases/7_1_4.php