summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-11 20:09:42 +0200
committerRemi Collet <remi@remirepo.net>2017-04-11 20:09:42 +0200
commit28b7eb25cd6ab1e7e2e4099f1433561f55d2b908 (patch)
tree78945ce94e415c77b1ec16f18d05fdc89b090241
parentbe881ccff82ed7c931e6cdbeb2287ef75e90f024 (diff)
v7.1.4
-rw-r--r--failed.txt20
-rw-r--r--php-7.1.0-systzdata-v14.patch3
-rw-r--r--php-upstream.patch131
-rw-r--r--php71.spec13
4 files changed, 19 insertions, 148 deletions
diff --git a/failed.txt b/failed.txt
index cc3a01e..3def01b 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,26 +1,24 @@
-===== 7.1.4RC1 (2017-03-30)
+===== 7.1.4 (2017-04-13)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el6i/build.log:Tests failed : 1
/var/lib/mock/el6x/build.log:Tests failed : 1
/var/lib/mock/el7x/build.log:Tests failed : 1
-/var/lib/mock/fc23i/build.log:Tests failed : 1
+/var/lib/mock/fc23i/build.log:Tests failed : 0
/var/lib/mock/fc23x/build.log:Tests failed : 0
/var/lib/mock/fc24i/build.log:Tests failed : 1
-/var/lib/mock/fc24x/build.log:Tests failed : 2
-/var/lib/mock/fc25i/build.log:Tests failed : 1
-/var/lib/mock/fc25x/build.log:Tests failed : 1
+/var/lib/mock/fc24x/build.log:Tests failed : 1
+/var/lib/mock/fc25i/build.log:Tests failed : 0
+/var/lib/mock/fc25x/build.log:Tests failed : 0
/var/lib/mock/fc26i/build.log:Tests failed : 1
/var/lib/mock/fc26x/build.log:Tests failed : 1
-fc23i
- (1) Test get_headers() function : test with context [ext/standard/tests/url/get_headers_error_003.phpt]
-fc24x
- (1) Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
-el6i, el6x, fc24i, fc24x, fc25i, fc25x
- (4) Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
+el6i, el6x, el7x
+ Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
+fc24i, fc24x
+ (4) Bug #33415 [2] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-2.phpt]
fc26i, fc26x
(3) sni_server [ext/openssl/tests/sni_server.phpt]
diff --git a/php-7.1.0-systzdata-v14.patch b/php-7.1.0-systzdata-v14.patch
index d4c8340..bd73a4b 100644
--- a/php-7.1.0-systzdata-v14.patch
+++ b/php-7.1.0-systzdata-v14.patch
@@ -1,3 +1,6 @@
+# License: MIT
+# http://opensource.org/licenses/MIT
+
Add support for use of the system timezone database, rather
than embedding a copy. Discussed upstream but was not desired.
diff --git a/php-upstream.patch b/php-upstream.patch
deleted file mode 100644
index a36a4f9..0000000
--- a/php-upstream.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-From d11211fb5379324e99dc67cdd7a0ec5031874ae7 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 29 Mar 2017 07:01:14 +0200
-Subject: [PATCH] relax test failing in fast computer
-
----
- ext/date/tests/bug73837.phpt | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/ext/date/tests/bug73837.phpt b/ext/date/tests/bug73837.phpt
-index 220deb6..af47cfd 100644
---- a/ext/date/tests/bug73837.phpt
-+++ b/ext/date/tests/bug73837.phpt
-@@ -11,7 +11,9 @@ for ( $i = 0; $i < 1000; $i++ )
- $collect[$key] = true;
- }
-
--echo ( count( $collect ) > 990 ) ? "microseconds differ\n" : "microseconds do not differ enough\n";
-+var_dump($n = count( $collect ));
-+echo ( $n > 900 ) ? "microseconds differ\n" : "microseconds do not differ enough\n";
- ?>
----EXPECT--
-+--EXPECTF--
-+int(%d)
- microseconds differ
---
-2.1.4
-
-From 012dc336a6ae01208c394994b648c221337bf81d Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 29 Mar 2017 07:25:01 +0200
-Subject: [PATCH] Fix buid with system libsqlite, see bug #74217
-
-SQLITE_DETERMINISTIC only exists in recent version
-e.g. missing on 3.7 which is the default on RHEL/CentOS-7
-and probably others (wheezy have 3.7, jessie 3.8...)
----
- ext/pdo_sqlite/pdo_sqlite.c | 2 ++
- ext/pdo_sqlite/tests/pdo_sqlite_createfunction_with_flags.phpt | 5 ++++-
- ext/sqlite3/sqlite3.c | 2 ++
- ext/sqlite3/tests/sqlite3_37_createfunction_flags.phpt | 5 ++++-
- 4 files changed, 12 insertions(+), 2 deletions(-)
-
-diff --git a/ext/pdo_sqlite/pdo_sqlite.c b/ext/pdo_sqlite/pdo_sqlite.c
-index 621123b..d0eb182 100644
---- a/ext/pdo_sqlite/pdo_sqlite.c
-+++ b/ext/pdo_sqlite/pdo_sqlite.c
-@@ -69,7 +69,9 @@ ZEND_GET_MODULE(pdo_sqlite)
- /* {{{ PHP_MINIT_FUNCTION */
- PHP_MINIT_FUNCTION(pdo_sqlite)
- {
-+#ifdef SQLITE_DETERMINISTIC
- REGISTER_PDO_CLASS_CONST_LONG("SQLITE_DETERMINISTIC", (zend_long)SQLITE_DETERMINISTIC);
-+#endif
-
- return php_pdo_register_driver(&pdo_sqlite_driver);
- }
-diff --git a/ext/pdo_sqlite/tests/pdo_sqlite_createfunction_with_flags.phpt b/ext/pdo_sqlite/tests/pdo_sqlite_createfunction_with_flags.phpt
-index 4f0b675..d826d93 100644
---- a/ext/pdo_sqlite/tests/pdo_sqlite_createfunction_with_flags.phpt
-+++ b/ext/pdo_sqlite/tests/pdo_sqlite_createfunction_with_flags.phpt
-@@ -1,7 +1,10 @@
- --TEST--
- PDO_sqlite: Testing sqliteCreateFunction() with flags
- --SKIPIF--
--<?php if (!extension_loaded('pdo_sqlite')) print 'skip not loaded'; ?>
-+<?php
-+if (!extension_loaded('pdo_sqlite')) print 'skip not loaded';
-+if (!defined('PDO::SQLITE_DETERMINISTIC')) die('skip system sqlite is to old');
-+?>
- --FILE--
- <?php
-
-diff --git a/ext/sqlite3/sqlite3.c b/ext/sqlite3/sqlite3.c
-index 5a796e1..f1ed93b 100644
---- a/ext/sqlite3/sqlite3.c
-+++ b/ext/sqlite3/sqlite3.c
-@@ -2283,7 +2283,9 @@ PHP_MINIT_FUNCTION(sqlite3)
- REGISTER_LONG_CONSTANT("SQLITE3_OPEN_READWRITE", SQLITE_OPEN_READWRITE, CONST_CS | CONST_PERSISTENT);
- REGISTER_LONG_CONSTANT("SQLITE3_OPEN_CREATE", SQLITE_OPEN_CREATE, CONST_CS | CONST_PERSISTENT);
-
-+#ifdef SQLITE_DETERMINISTIC
- REGISTER_LONG_CONSTANT("SQLITE3_DETERMINISTIC", SQLITE_DETERMINISTIC, CONST_CS | CONST_PERSISTENT);
-+#endif
-
- return SUCCESS;
- }
-diff --git a/ext/sqlite3/tests/sqlite3_37_createfunction_flags.phpt b/ext/sqlite3/tests/sqlite3_37_createfunction_flags.phpt
-index 31fd42b..f9f0b5f 100644
---- a/ext/sqlite3/tests/sqlite3_37_createfunction_flags.phpt
-+++ b/ext/sqlite3/tests/sqlite3_37_createfunction_flags.phpt
-@@ -1,7 +1,10 @@
- --TEST--
- SQLite3::createFunction - Test with flags
- --SKIPIF--
--<?php require_once(__DIR__ . '/skipif.inc'); ?>
-+<?php
-+require_once(__DIR__ . '/skipif.inc');
-+if (!defined('SQLITE3_DETERMINISTIC')) die('skip system sqlite is to old');
-+?>
- --FILE--
- <?php
-
---
-2.1.4
-
-From cec720857a21873864badc53c10d660b673e38cc Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 29 Mar 2017 07:38:40 +0200
-Subject: [PATCH] relax more this test
-
----
- ext/date/tests/bug73837.phpt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ext/date/tests/bug73837.phpt b/ext/date/tests/bug73837.phpt
-index af47cfd..6fd12f8 100644
---- a/ext/date/tests/bug73837.phpt
-+++ b/ext/date/tests/bug73837.phpt
-@@ -12,7 +12,7 @@ for ( $i = 0; $i < 1000; $i++ )
- }
-
- var_dump($n = count( $collect ));
--echo ( $n > 900 ) ? "microseconds differ\n" : "microseconds do not differ enough\n";
-+echo ( $n > 800 ) ? "microseconds differ\n" : "microseconds do not differ enough ($n)\n";
- ?>
- --EXPECTF--
- int(%d)
---
-2.1.4
-
diff --git a/php71.spec b/php71.spec
index 823455c..a6871ae 100644
--- a/php71.spec
+++ b/php71.spec
@@ -120,7 +120,7 @@
%global db_devel libdb-devel
%endif
-%global rcver RC1
+#global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
@@ -179,7 +179,6 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-upstream.patch
# Security fixes (200+)
@@ -1024,7 +1023,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .up
# security patches
@@ -2059,19 +2057,22 @@ fi
%changelog
+* Tue Apr 11 2017 Remi Collet <remi@fedoraproject.org> - 7.1.4-1
+- Update to 7.1.4 - http://www.php.net/releases/7_1_4.php
+
* Tue Mar 28 2017 Remi Collet <remi@fedoraproject.org> - 7.1.4-0.1.RC1
- Update to 7.1.4RC1
* Tue Mar 14 2017 Remi Collet <remi@fedoraproject.org> - 7.1.3-1
- Update to 7.1.3 - http://www.php.net/releases/7_1_3.php
-* Fri Mar 10 2017 Remi Collet <remi@fedoraproject.org> 7.1.3-0.2.RC1
+* Fri Mar 10 2017 Remi Collet <remi@fedoraproject.org> - 7.1.3-0.2.RC1
- fix interbase build on F26
-* Tue Feb 28 2017 Remi Collet <remi@fedoraproject.org> 7.1.3-0.1.RC1
+* Tue Feb 28 2017 Remi Collet <remi@fedoraproject.org> - 7.1.3-0.1.RC1
- Update to 7.1.3RC1
-* Wed Feb 15 2017 Remi Collet <remi@fedoraproject.org> 7.1.2-1
+* Wed Feb 15 2017 Remi Collet <remi@fedoraproject.org> - 7.1.2-1
- Update to 7.1.2 - http://www.php.net/releases/7_1_2.php
* Thu Feb 2 2017 Remi Collet <remi@fedoraproject.org> - 7.1.2-0.2.RC1