summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-06 19:52:54 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-06 19:52:54 +0100
commit85c278830416f12859834ff9bff78922a51e3ef5 (patch)
tree620a9ce31a650fb378601881de900f9443334ebf
parent4464b77e627fe305887d8c47afadcfe80dcb1bd2 (diff)
PHP 5.6.17
-rw-r--r--failed.txt28
-rw-r--r--php-5.6.17-libdb.patch (renamed from php-5.6.3-libdb.patch)20
-rw-r--r--php56.spec12
3 files changed, 36 insertions, 24 deletions
diff --git a/failed.txt b/failed.txt
index ed0bdb3..3aa6dde 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 5.6.16 (2015-11-26)
+===== 5.6.17 (2016-01-07)
$ grep -r 'Tests failed' /var/lib/mock/56*/build.log
@@ -6,7 +6,7 @@ $ grep -r 'Tests failed' /var/lib/mock/56*/build.log
/var/lib/mock/el5x/build.log:Tests failed : 8 ( 0.0%) ( 0.0%)
/var/lib/mock/el6i/build.log:Tests failed : 6 ( 0.0%) ( 0.0%)
/var/lib/mock/el6x/build.log:Tests failed : 5 ( 0.0%) ( 0.0%)
-/var/lib/mock/el7x/build.log:Tests failed : 5 ( 0.0%) ( 0.0%)
+/var/lib/mock/el7x/build.log:Tests failed : 6 ( 0.0%) ( 0.0%)
/var/lib/mock/fc20i/build.log:Tests failed : 6 ( 0.0%) ( 0.0%)
/var/lib/mock/fc20x/build.log:Tests failed : 5 ( 0.0%) ( 0.0%)
/var/lib/mock/fc21i/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
@@ -18,18 +18,22 @@ $ grep -r 'Tests failed' /var/lib/mock/56*/build.log
el5i, el5x
- openssl_x509_parse() basic test for OpenSSL 0.9 [ext/openssl/tests/openssl_x509_parse_basic_v9.phpt]
- sni_server [ext/openssl/tests/sni_server.phpt]
- Specific protocol method specification [ext/openssl/tests/stream_crypto_flags_004.phpt]
+ openssl_x509_parse() basic test for OpenSSL 0.9 [ext/openssl/tests/openssl_x509_parse_basic_v9.phpt]
+ sni_server [ext/openssl/tests/sni_server.phpt]
+ Specific protocol method specification [ext/openssl/tests/stream_crypto_flags_004.phpt]
el5i, el6i, fc20i, fc21i, fc22i, fc23i
- Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
-el6x, el7x, fc20i, fc20x, fc21i, fc22i, fc23i
- Bug #53437 DateInterval unserialize bad data, 32 bit [ext/date/tests/bug53437_var3.phpt]
+ Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
+fc20i, fc21i, fc22i, fc23i
+ Bug #53437 DateInterval unserialize bad data, 32 bit [ext/date/tests/bug53437_var3.phpt]
+el6x, el7x, fc20x
+ strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
+el7x
+ Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
el6x, el7x, fc20i, fc20x
- Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
- Test date_sunrise() function : usage variation - Passing high positive and negative float values to time argument. [ext/date/tests/date_sunrise_variation9.phpt]
- Test date_sunset() function : usage variation - Passing high positive and negative float values to time argument. [ext/date/tests/date_sunset_variation9.phpt]
- Test getdate() function : usage variation - Passing high positive and negative float values to timestamp. [ext/date/tests/getdate_variation7.phpt]
+ Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
+ Test date_sunrise() function : usage variation - Passing high positive and negative float values to time argument. [ext/date/tests/date_sunrise_variation9.phpt]
+ Test date_sunset() function : usage variation - Passing high positive and negative float values to time argument. [ext/date/tests/date_sunset_variation9.phpt]
+ Test getdate() function : usage variation - Passing high positive and negative float values to timestamp. [ext/date/tests/getdate_variation7.phpt]
diff --git a/php-5.6.3-libdb.patch b/php-5.6.17-libdb.patch
index dc0e40b..a7bbd2e 100644
--- a/php-5.6.3-libdb.patch
+++ b/php-5.6.17-libdb.patch
@@ -1,6 +1,7 @@
---- php-5.4.7/ext/dba/config.m4.orig 2012-09-20 12:23:00.548322754 +0200
-+++ php-5.4.7/ext/dba/config.m4 2012-09-20 12:28:07.656380829 +0200
-@@ -312,57 +312,13 @@
+diff -up php-5.6.17RC1/ext/dba/config.m4.libdb php-5.6.17RC1/ext/dba/config.m4
+--- php-5.6.17RC1/ext/dba/config.m4.libdb 2015-12-10 10:42:34.643252975 +0100
++++ php-5.6.17RC1/ext/dba/config.m4 2015-12-10 10:44:27.924729361 +0100
+@@ -312,61 +312,13 @@ if test "$PHP_DB4" != "no"; then
dbdp4="/usr/local/BerkeleyDB.4."
dbdp5="/usr/local/BerkeleyDB.5."
for i in $PHP_DB4 ${dbdp5}1 ${dbdp5}0 ${dbdp4}8 ${dbdp4}7 ${dbdp4}6 ${dbdp4}5 ${dbdp4}4 ${dbdp4}3 ${dbdp4}2 ${dbdp4}1 ${dbdp}0 /usr/local /usr; do
@@ -12,6 +13,10 @@
- THIS_PREFIX=$i
- THIS_INCLUDE=$i/db4/db.h
- break
+- elif test -f "$i/include/db5.3/db.h"; then
+- THIS_PREFIX=$i
+- THIS_INCLUDE=$i/include/db5.3/db.h
+- break
- elif test -f "$i/include/db5.1/db.h"; then
- THIS_PREFIX=$i
- THIS_INCLUDE=$i/include/db5.1/db.h
@@ -55,13 +60,14 @@
break
fi
done
-- PHP_DBA_DB_CHECK(4, db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
+- PHP_DBA_DB_CHECK(4, db-5.3 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
+ PHP_DBA_DB_CHECK(4, db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
fi
PHP_DBA_STD_RESULT(db4,Berkeley DB4)
---- php-5.4.7/ext/dba/dba.c.old 2012-09-19 14:55:23.868456900 +0200
-+++ php-5.4.7/ext/dba/dba.c 2012-09-19 15:02:42.796009320 +0200
+diff -up php-5.6.17RC1/ext/dba/dba.c.libdb php-5.6.17RC1/ext/dba/dba.c
+--- php-5.6.17RC1/ext/dba/dba.c.libdb 2015-12-10 01:36:02.000000000 +0100
++++ php-5.6.17RC1/ext/dba/dba.c 2015-12-10 10:42:34.644252979 +0100
@@ -52,6 +52,10 @@
#include "php_qdbm.h"
#include "php_tcadb.h"
@@ -73,7 +79,7 @@
/* {{{ arginfo */
ZEND_BEGIN_ARG_INFO_EX(arginfo_dba_popen, 0, 0, 2)
ZEND_ARG_INFO(0, path)
-@@ -535,6 +539,10 @@
+@@ -535,6 +539,10 @@ PHP_MINFO_FUNCTION(dba)
php_info_print_table_start();
php_info_print_table_row(2, "DBA support", "enabled");
diff --git a/php56.spec b/php56.spec
index 27fc67a..1b12c5b 100644
--- a/php56.spec
+++ b/php56.spec
@@ -144,7 +144,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 5.6.16
+Version: 5.6.17
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.1.%{?snapdate}%{?rcver}%{?dist}
%else
@@ -188,7 +188,7 @@ Source99: php-fpm.init
Patch5: php-5.6.3-includedir.patch
Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
-Patch8: php-5.6.3-libdb.patch
+Patch8: php-5.6.17-libdb.patch
Patch9: php-5.5.30-curl.patch
# Fixes for extension modules
@@ -1740,7 +1740,7 @@ echo -e "\nWARNING : These %{name}-* RPMs are not official Fedora / Red Hat buil
echo -e "overrides the official ones. Don't file bugs on Fedora Project nor Red Hat.\n"
echo -e "Use dedicated forum at http://forum.remirepo.net/\n"
-%if %{?fedora}%{!?fedora:99} < 21
+%if %{?fedora}%{!?fedora:99} < 22
echo -e "WARNING : Fedora %{fedora} is now EOL :"
echo -e "You should consider upgrading to a supported release.\n"
%endif
@@ -1988,8 +1988,10 @@ fi
%changelog
-* Mon Dec 14 2015 Remi Collet <remi@fedoraproject.org> 5.6.16-1.1
-- curl: add CURL_SSLVERSION_TLSv1_x constant
+* Wed Jan 6 2016 Remi Collet <remi@fedoraproject.org> 5.6.17-1
+- Update to 5.6.17
+ http://www.php.net/releases/5_6_17.php
+- curl: add CURL_SSLVERSION_TLSv1_x constants
* Thu Nov 26 2015 Remi Collet <remi@fedoraproject.org> 5.6.16-1
- Update to 5.6.16