summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-14 14:38:48 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-14 14:38:48 +0100
commit4464b77e627fe305887d8c47afadcfe80dcb1bd2 (patch)
tree3857f535e1e47c03fd4f257911e147babd751c0d
parent1764ce2ab2fb928cdcd7db4297e6b9b53dd671ce (diff)
php/curl: add CURL_SSLVERSION_TLSv1_x constant
-rw-r--r--php-5.5.30-curl.patch14
-rw-r--r--php56.spec11
2 files changed, 23 insertions, 2 deletions
diff --git a/php-5.5.30-curl.patch b/php-5.5.30-curl.patch
new file mode 100644
index 0000000..0c72d56
--- /dev/null
+++ b/php-5.5.30-curl.patch
@@ -0,0 +1,14 @@
+diff -up php-5.5.30/ext/curl/interface.c.old php-5.5.30/ext/curl/interface.c
+--- php-5.5.30/ext/curl/interface.c.old 2015-12-14 13:58:27.911676702 +0100
++++ php-5.5.30/ext/curl/interface.c 2015-12-14 14:08:04.581124497 +0100
+@@ -1213,7 +1213,9 @@ PHP_MINIT_FUNCTION(curl)
+ REGISTER_CURL_CONSTANT(CURLSSLOPT_ALLOW_BEAST);
+ #endif
+
+-#if LIBCURL_VERSION_NUM >= 0x072200 /* Available since 7.34.0 */
++#if LIBCURL_VERSION_NUM >= 0x071300 /* Available since 7.19.0 (in upstream curl 7.34)
++ backported in RHEL-7 curl-7.29.0-16.el7 rhbz#1012136
++ backported in RHEL-6 curl-7.19.7-43.el6 rhbz#1036789 */
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_0);
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_1);
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_2);
diff --git a/php56.spec b/php56.spec
index f0bdfca..27fc67a 100644
--- a/php56.spec
+++ b/php56.spec
@@ -161,8 +161,8 @@ URL: http://www.php.net/
Source0: http://snaps.php.net/php5.6-%{snapdate}.tar.xz
%else
# Need to download official tarball and strip non-free stuff
-# wget http://www.php.net/distributions/php-%{version}%{?rcver}.tar.xz
-# ./strip.sh %{version}
+# wget http://www.php.net/distributions/php-%%{version}%%{?rcver}.tar.xz
+# ./strip.sh %%{version}
Source0: php-%{version}%{?rcver}-strip.tar.xz
%endif
Source1: php.conf
@@ -189,6 +189,7 @@ Patch5: php-5.6.3-includedir.patch
Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-5.6.3-libdb.patch
+Patch9: php-5.5.30-curl.patch
# Fixes for extension modules
# https://bugs.php.net/63171 no odbc call during timeout
@@ -956,6 +957,9 @@ rm -rf ext/json
%patch6 -p1 -b .embed
%patch7 -p1 -b .recode
%patch8 -p1 -b .libdb
+%if 0%{?rhel}
+%patch9 -p1 -b .curltls
+%endif
%patch21 -p1 -b .odbctimer
@@ -1984,6 +1988,9 @@ fi
%changelog
+* Mon Dec 14 2015 Remi Collet <remi@fedoraproject.org> 5.6.16-1.1
+- curl: add CURL_SSLVERSION_TLSv1_x constant
+
* Thu Nov 26 2015 Remi Collet <remi@fedoraproject.org> 5.6.16-1
- Update to 5.6.16
http://www.php.net/releases/5_6_16.php