summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-26 08:50:12 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-26 08:50:12 +0200
commitc2174d03bdd5817734d61ba689ada3ed81720eb6 (patch)
treeac2aba3210e32bc2704c669d01989b3b5dc309c8 /Makefile
parent69ff8b30a27ea59bf7f8f9ec138acc71e556e1a4 (diff)
add minimum test for libphp5 (embedded)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 91b0fd5..d095534 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,10 @@
SRCDIR := $(shell pwd)
-NAME := $(shell basename $(SRCDIR))
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
include ../../common/Makefile
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed