summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-02-18 17:02:37 +0100
committerRemi Collet <fedora@famillecollet.com>2015-02-18 17:02:37 +0100
commitd8474e818cd8760d6c71182bc665fc9181d8c912 (patch)
tree051b205ff3b27c1368296a283f6bff9562b0855a
parent4a7b1725c974fb785c986f6e000c944f881b17ba (diff)
php 5.4, cleanup
-rw-r--r--php54.spec12
1 files changed, 8 insertions, 4 deletions
diff --git a/php54.spec b/php54.spec
index 659d207..68d262c 100644
--- a/php54.spec
+++ b/php54.spec
@@ -1247,16 +1247,20 @@ popd
%check
%if %runselftest
cd build-apache
+
# Run tests, using the CLI SAPI
export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
export SKIP_ONLINE_TESTS=1
unset TZ LANG LC_ALL
if ! make test; then
set +x
- for f in `find .. -name \*.diff -type f -print`; do
- echo "TEST FAILURE: $f --"
- cat "$f"
- echo "-- $f result ends."
+ for f in $(find .. -name \*.diff -type f -print); do
+ if ! grep -q XFAIL "${f/.diff/.phpt}"
+ then
+ echo "TEST FAILURE: $f --"
+ cat "$f"
+ echo -e "\n-- $f result ends."
+ fi
done
set -x
#exit 1