summaryrefslogtreecommitdiffstats
path: root/php54.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php54.spec')
-rw-r--r--php54.spec12
1 files changed, 8 insertions, 4 deletions
diff --git a/php54.spec b/php54.spec
index 659d207..68d262c 100644
--- a/php54.spec
+++ b/php54.spec
@@ -1247,16 +1247,20 @@ popd
%check
%if %runselftest
cd build-apache
+
# Run tests, using the CLI SAPI
export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
export SKIP_ONLINE_TESTS=1
unset TZ LANG LC_ALL
if ! make test; then
set +x
- for f in `find .. -name \*.diff -type f -print`; do
- echo "TEST FAILURE: $f --"
- cat "$f"
- echo "-- $f result ends."
+ for f in $(find .. -name \*.diff -type f -print); do
+ if ! grep -q XFAIL "${f/.diff/.phpt}"
+ then
+ echo "TEST FAILURE: $f --"
+ cat "$f"
+ echo -e "\n-- $f result ends."
+ fi
done
set -x
#exit 1