summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-29 08:13:05 +0200
committerRemi Collet <remi@remirepo.net>2020-05-29 08:13:05 +0200
commit9c697218a2432dfe2cb128daf64c22b84ae45645 (patch)
treeb818b3654389335aa13033097dc7f4d275478229
parent0bcd76a5e28c46c0ee470b9509b9ac2c482ab617 (diff)
update to 0.8.1 with libzstd 1.4.5
drop patch merged upstream
-rw-r--r--31.patch24
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION6
-rw-r--r--php-zstd.spec17
4 files changed, 14 insertions, 37 deletions
diff --git a/31.patch b/31.patch
deleted file mode 100644
index f4cc45d..0000000
--- a/31.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 50ae3ccf376ec8540a8220aba85e59a7979ac72c Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 15 Apr 2020 16:05:14 +0200
-Subject: [PATCH] fix test to pass with PHP 8
-
----
- tests/streams_7.phpt | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/streams_7.phpt b/tests/streams_7.phpt
-index 6d72cff..aa76d64 100644
---- a/tests/streams_7.phpt
-+++ b/tests/streams_7.phpt
-@@ -15,8 +15,8 @@ readfile("compress.zstd://https://github.com/kjdev/php-ext-zstd/raw/master/tests
- --EXPECTF--
- Warning: readfile(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in %s
-
--Warning: readfile(https://github.com/kjdev/php-ext-zstd/raw/master/tests/streaming.zst): failed to open stream: no suitable wrapper could be found in %s
-+Warning: readfile(https://github.com/kjdev/php-ext-zstd/raw/master/tests/streaming.zst): %sailed to open stream: no suitable wrapper could be found in %s
-
--Warning: readfile(compress.zstd://https://github.com/kjdev/php-ext-zstd/raw/master/tests/streaming.zst): failed to open stream: operation failed in %s
-+Warning: readfile(compress.zstd://https://github.com/kjdev/php-ext-zstd/raw/master/tests/streaming.zst): %sailed to open stream: operation failed in %s
-
- ===Done===
diff --git a/PHPINFO b/PHPINFO
index 78e5c38..c816050 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
zstd
Zstd support => enabled
-Extension Version => 0.8.0
-Interface Version => 1.4.4
+Extension Version => 0.8.1
+Interface Version => 1.4.5
diff --git a/REFLECTION b/REFLECTION
index 212c7fd..b99d1fa 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,11 +1,11 @@
-Extension [ <persistent> extension #101 zstd version 0.8.0 ] {
+Extension [ <persistent> extension #104 zstd version 0.8.1 ] {
- Constants [5] {
Constant [ int ZSTD_COMPRESS_LEVEL_MIN ] { 1 }
Constant [ int ZSTD_COMPRESS_LEVEL_MAX ] { 22 }
Constant [ int ZSTD_COMPRESS_LEVEL_DEFAULT ] { 3 }
- Constant [ int LIBZSTD_VERSION_NUMBER ] { 10404 }
- Constant [ string LIBZSTD_VERSION_STRING ] { 1.4.4 }
+ Constant [ int LIBZSTD_VERSION_NUMBER ] { 10405 }
+ Constant [ string LIBZSTD_VERSION_STRING ] { 1.4.5 }
}
- Functions {
diff --git a/php-zstd.spec b/php-zstd.spec
index 850b884..624a70d 100644
--- a/php-zstd.spec
+++ b/php-zstd.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-zstd
#
-# Copyright (c) 2018-2019 Remi Collet
+# Copyright (c) 2018-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -17,12 +17,12 @@
%global pkg_name %{name}
%endif
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 6
+%if 0%{?fedora} >= 32
%global with_libzstd 1
%else
%global with_libzstd 0
%endif
-%global zstdver 1.4.4
+%global zstdver 1.4.5
%global pecl_name zstd
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -31,8 +31,8 @@
Summary: Zstandard extension
Name: %{?sub_prefix}php-%{pecl_name}
-Version: 0.8.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.8.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%if %{?with_libzstd}
License: MIT
%else
@@ -42,8 +42,6 @@ License: MIT and BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/kjdev/php-ext-zstd/pull/31.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -109,7 +107,6 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1
cp zstd/LICENSE LICENSE-libzstd
%if %{?with_libzstd}
@@ -253,6 +250,10 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Fri May 29 2020 Remi Collet <remi@remirepo.net> - 0.8.1-1
+- update to 0.8.1 with libzstd 1.4.5
+- drop patch merged upstream
+
* Wed Apr 15 2020 Remi Collet <remi@remirepo.net> - 0.8.0-2
- fix test suite with PHP 8 using patch from
https://github.com/kjdev/php-ext-zstd/pull/31