summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-04-15 16:10:40 +0200
committerRemi Collet <remi@remirepo.net>2020-04-15 16:10:40 +0200
commit0bcd76a5e28c46c0ee470b9509b9ac2c482ab617 (patch)
tree47b86abbf80a2337a13aa902ea00c7f78751bd28
parent17904b13235d2c1818ea98c6151a8d64a76809b0 (diff)
fix test suite with PHP 8 using patch from
https://github.com/kjdev/php-ext-zstd/pull/31
-rw-r--r--31.patch24
-rw-r--r--php-zstd.spec9
2 files changed, 32 insertions, 1 deletions
diff --git a/31.patch b/31.patch
new file mode 100644
index 0000000..f4cc45d
--- /dev/null
+++ b/31.patch
@@ -0,0 +1,24 @@
+From 50ae3ccf376ec8540a8220aba85e59a7979ac72c Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 15 Apr 2020 16:05:14 +0200
+Subject: [PATCH] fix test to pass with PHP 8
+
+---
+ tests/streams_7.phpt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/streams_7.phpt b/tests/streams_7.phpt
+index 6d72cff..aa76d64 100644
+--- a/tests/streams_7.phpt
++++ b/tests/streams_7.phpt
+@@ -15,8 +15,8 @@ readfile("compress.zstd://https://github.com/kjdev/php-ext-zstd/raw/master/tests
+ --EXPECTF--
+ Warning: readfile(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in %s
+
+-Warning: readfile(https://github.com/kjdev/php-ext-zstd/raw/master/tests/streaming.zst): failed to open stream: no suitable wrapper could be found in %s
++Warning: readfile(https://github.com/kjdev/php-ext-zstd/raw/master/tests/streaming.zst): %sailed to open stream: no suitable wrapper could be found in %s
+
+-Warning: readfile(compress.zstd://https://github.com/kjdev/php-ext-zstd/raw/master/tests/streaming.zst): failed to open stream: operation failed in %s
++Warning: readfile(compress.zstd://https://github.com/kjdev/php-ext-zstd/raw/master/tests/streaming.zst): %sailed to open stream: operation failed in %s
+
+ ===Done===
diff --git a/php-zstd.spec b/php-zstd.spec
index 61b26e2..850b884 100644
--- a/php-zstd.spec
+++ b/php-zstd.spec
@@ -32,7 +32,7 @@
Summary: Zstandard extension
Name: %{?sub_prefix}php-%{pecl_name}
Version: 0.8.0
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%if %{?with_libzstd}
License: MIT
%else
@@ -42,6 +42,8 @@ License: MIT and BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/kjdev/php-ext-zstd/pull/31.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -107,6 +109,7 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1
cp zstd/LICENSE LICENSE-libzstd
%if %{?with_libzstd}
@@ -250,6 +253,10 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Wed Apr 15 2020 Remi Collet <remi@remirepo.net> - 0.8.0-2
+- fix test suite with PHP 8 using patch from
+ https://github.com/kjdev/php-ext-zstd/pull/31
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 0.8.0-1
- update to 0.8.0 with system libzstd 1.4.4