summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-07 11:10:48 +0200
committerRemi Collet <remi@remirepo.net>2017-09-07 11:10:48 +0200
commit377ee27b86a76579553ba93d60da812ef0b42ebc (patch)
treeb07ad9ec533306a16e0bab70d89ca898b20641a7
parentd98911290030db4e378ece70b37d2f3858c53bce (diff)
-rw-r--r--121.patch49
-rw-r--r--REFLECTION8
-rw-r--r--php-tarantool.spec19
3 files changed, 14 insertions, 62 deletions
diff --git a/121.patch b/121.patch
deleted file mode 100644
index 11a7b08..0000000
--- a/121.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 953c723a59fb437fccea9aeaf4c7f69c112f6308 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Sat, 24 Jun 2017 10:59:29 +0200
-Subject: [PATCH 1/2] fix for 7.2
-
----
- .travis.yml | 2 ++
- src/php_tarantool.h | 5 ++++-
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/src/php_tarantool.h b/src/php_tarantool.h
-index 1679eb7..7556671 100644
---- a/src/php_tarantool.h
-+++ b/src/php_tarantool.h
-@@ -17,7 +17,10 @@
- # include "config.h"
- #endif
-
--#if PHP_VERSION_ID >= 70000
-+#if PHP_VERSION_ID >= 70200
-+# include <Zend/zend_smart_string.h>
-+# define smart_string_alloc4(d, n, what, newlen) smart_string_alloc(d, n, what)
-+#elif PHP_VERSION_ID >= 70000
- # include <ext/standard/php_smart_string.h>
- #else
- # include <ext/standard/php_smart_str.h>
-
-From b8b1a2efdcf3ced046a5af19ea18f326bc9d7f49 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Sat, 24 Jun 2017 11:11:52 +0200
-Subject: [PATCH 2/2] improve previous
-
----
- src/php_tarantool.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/php_tarantool.h b/src/php_tarantool.h
-index 7556671..bab2a49 100644
---- a/src/php_tarantool.h
-+++ b/src/php_tarantool.h
-@@ -19,7 +19,7 @@
-
- #if PHP_VERSION_ID >= 70200
- # include <Zend/zend_smart_string.h>
--# define smart_string_alloc4(d, n, what, newlen) smart_string_alloc(d, n, what)
-+# define smart_string_alloc4(d, n, what, newlen) newlen = smart_string_alloc(d, n, what)
- #elif PHP_VERSION_ID >= 70000
- # include <ext/standard/php_smart_string.h>
- #else
diff --git a/REFLECTION b/REFLECTION
index cb3583d..8b3e82c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #127 tarantool version 0.2.0 ] {
+Extension [ <persistent> extension #142 tarantool version 0.2.0 ] {
- INI {
Entry [ tarantool.persistent <ALL> ]
@@ -11,16 +11,16 @@ Extension [ <persistent> extension #127 tarantool version 0.2.0 ] {
Current = '0'
}
Entry [ tarantool.timeout <ALL> ]
- Current = '10.0'
+ Current = '3600.0'
}
Entry [ tarantool.request_timeout <ALL> ]
- Current = '10.0'
+ Current = '3600.0'
}
Entry [ tarantool.retry_count <ALL> ]
Current = '1'
}
Entry [ tarantool.retry_sleep <ALL> ]
- Current = '0.1'
+ Current = '10'
}
}
diff --git a/php-tarantool.spec b/php-tarantool.spec
index 72a0531..edbd0e3 100644
--- a/php-tarantool.spec
+++ b/php-tarantool.spec
@@ -19,7 +19,7 @@
%global github_owner tarantool
%global github_name tarantool-php
-%global github_commit 3bf856687bc2e72a093f4c01c1f80d2bc39de928
+%global github_commit 96906b30b29222eadb6796b79d889c982abb630a
%global github_short %(c=%{github_commit}; echo ${c:0:7})
#global github_date 20160906
@@ -31,11 +31,11 @@
%global with_tests 0
Name: %{?sub_prefix}php-%{ext_name}
-Version: 0.2.0
+Version: 0.3.0
%if 0%{?github_date}
Release: 0.2.%{?github_date}git%{?github_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
Summary: PHP driver for Tarantool/Box
@@ -45,8 +45,6 @@ License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{pkg_name}-%{version}-%{github_short}.tar.gz
-Patch0: 121.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 7
%if %{with_tests}
# For tests
@@ -104,7 +102,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{github_name}-%{github_commit} NTS
cd NTS
-%patch0 -p1 -b .pr121
+sed -e '/PHP_TARANTOOL_VERSION/s/0.2.0/%{version}/' -i php_tarantool.h
extver=$(sed -n '/#define PHP_TARANTOOL_VERSION/{s/.* "//;s/".*$//;p}' php_tarantool.h)
if test "x${extver}" != "x%{version}%{?pre}%{?github_date:-dev}"; then
@@ -126,10 +124,10 @@ extension=%{ext_name}.so
;tarantool.persistent = 0
;tarantool.use_namespace = 0
;tarantool.connection_alias = 0
-;tarantool.timeout = '10.0'
-;tarantool.request_timeout = '10.0'
+;tarantool.timeout = '3600.0'
+;tarantool.request_timeout = '3600.0'
;tarantool.retry_count = '1'
-;tarantool.retry_sleep = '0.1'
+;tarantool.retry_sleep = '10'
INI
@@ -195,6 +193,9 @@ install -D -m 0644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%changelog
+* Thu Sep 7 2017 Remi Collet <remi@remirepo.net> - 0.3.0-1
+- update to 0.3.0
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 0.2.0-4
- rebuild for PHP 7.2.0beta1 new API