summaryrefslogtreecommitdiffstats
path: root/php-tarantool.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-tarantool.spec')
-rw-r--r--php-tarantool.spec19
1 files changed, 10 insertions, 9 deletions
diff --git a/php-tarantool.spec b/php-tarantool.spec
index 72a0531..edbd0e3 100644
--- a/php-tarantool.spec
+++ b/php-tarantool.spec
@@ -19,7 +19,7 @@
%global github_owner tarantool
%global github_name tarantool-php
-%global github_commit 3bf856687bc2e72a093f4c01c1f80d2bc39de928
+%global github_commit 96906b30b29222eadb6796b79d889c982abb630a
%global github_short %(c=%{github_commit}; echo ${c:0:7})
#global github_date 20160906
@@ -31,11 +31,11 @@
%global with_tests 0
Name: %{?sub_prefix}php-%{ext_name}
-Version: 0.2.0
+Version: 0.3.0
%if 0%{?github_date}
Release: 0.2.%{?github_date}git%{?github_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
Summary: PHP driver for Tarantool/Box
@@ -45,8 +45,6 @@ License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{pkg_name}-%{version}-%{github_short}.tar.gz
-Patch0: 121.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 7
%if %{with_tests}
# For tests
@@ -104,7 +102,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{github_name}-%{github_commit} NTS
cd NTS
-%patch0 -p1 -b .pr121
+sed -e '/PHP_TARANTOOL_VERSION/s/0.2.0/%{version}/' -i php_tarantool.h
extver=$(sed -n '/#define PHP_TARANTOOL_VERSION/{s/.* "//;s/".*$//;p}' php_tarantool.h)
if test "x${extver}" != "x%{version}%{?pre}%{?github_date:-dev}"; then
@@ -126,10 +124,10 @@ extension=%{ext_name}.so
;tarantool.persistent = 0
;tarantool.use_namespace = 0
;tarantool.connection_alias = 0
-;tarantool.timeout = '10.0'
-;tarantool.request_timeout = '10.0'
+;tarantool.timeout = '3600.0'
+;tarantool.request_timeout = '3600.0'
;tarantool.retry_count = '1'
-;tarantool.retry_sleep = '0.1'
+;tarantool.retry_sleep = '10'
INI
@@ -195,6 +193,9 @@ install -D -m 0644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%changelog
+* Thu Sep 7 2017 Remi Collet <remi@remirepo.net> - 0.3.0-1
+- update to 0.3.0
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 0.2.0-4
- rebuild for PHP 7.2.0beta1 new API