summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-16 09:51:26 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-16 09:51:26 +0200
commit7f7dd891d3b0042021d26d9327e010436a98e70e (patch)
tree02bf79f3ab624ed8f62ee41993d0b5e64bad2337
parenta74b27bcb0b99bd9ac3d60643db77e0e1e9af95b (diff)
php-smbclient: 0.8.0-rc1
-rw-r--r--REFLECTION66
-rw-r--r--php-smbclient.spec32
2 files changed, 55 insertions, 43 deletions
diff --git a/REFLECTION b/REFLECTION
index 8ad0e21..329c8cc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
+Extension [ <persistent> extension #152 smbclient version 0.8.0-rc1 ] {
- Constants [30] {
Constant [ integer SMBCLIENT_XATTR_CREATE ] { 1 }
@@ -34,22 +34,22 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
}
- Functions {
- Function [ <internal:libsmbclient> function smbclient_version ] {
+ Function [ <internal:smbclient> function smbclient_version ] {
- Parameters [0] {
}
}
- Function [ <internal:libsmbclient> function smbclient_library_version ] {
+ Function [ <internal:smbclient> function smbclient_library_version ] {
- Parameters [0] {
}
}
- Function [ <internal:libsmbclient> function smbclient_state_new ] {
+ Function [ <internal:smbclient> function smbclient_state_new ] {
- Parameters [0] {
}
}
- Function [ <internal:libsmbclient> function smbclient_state_init ] {
+ Function [ <internal:smbclient> function smbclient_state_init ] {
- Parameters [4] {
Parameter #0 [ <required> $state ]
@@ -58,26 +58,26 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #3 [ <optional> $password ]
}
}
- Function [ <internal:libsmbclient> function smbclient_state_errno ] {
+ Function [ <internal:smbclient> function smbclient_state_errno ] {
- Parameters [1] {
Parameter #0 [ <required> $state ]
}
}
- Function [ <internal:libsmbclient> function smbclient_state_free ] {
+ Function [ <internal:smbclient> function smbclient_state_free ] {
- Parameters [1] {
Parameter #0 [ <required> $state ]
}
}
- Function [ <internal:libsmbclient> function smbclient_option_get ] {
+ Function [ <internal:smbclient> function smbclient_option_get ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $option ]
}
}
- Function [ <internal:libsmbclient> function smbclient_option_set ] {
+ Function [ <internal:smbclient> function smbclient_option_set ] {
- Parameters [3] {
Parameter #0 [ <required> $state ]
@@ -85,42 +85,42 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #2 [ <required> $value ]
}
}
- Function [ <internal:libsmbclient> function smbclient_opendir ] {
+ Function [ <internal:smbclient> function smbclient_opendir ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $path ]
}
}
- Function [ <internal:libsmbclient> function smbclient_readdir ] {
+ Function [ <internal:smbclient> function smbclient_readdir ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $dir ]
}
}
- Function [ <internal:libsmbclient> function smbclient_closedir ] {
+ Function [ <internal:smbclient> function smbclient_closedir ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $dir ]
}
}
- Function [ <internal:libsmbclient> function smbclient_stat ] {
+ Function [ <internal:smbclient> function smbclient_stat ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $path ]
}
}
- Function [ <internal:libsmbclient> function smbclient_fstat ] {
+ Function [ <internal:smbclient> function smbclient_fstat ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $file ]
}
}
- Function [ <internal:libsmbclient> function smbclient_open ] {
+ Function [ <internal:smbclient> function smbclient_open ] {
- Parameters [4] {
Parameter #0 [ <required> $state ]
@@ -129,7 +129,7 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #3 [ <optional> $mode ]
}
}
- Function [ <internal:libsmbclient> function smbclient_creat ] {
+ Function [ <internal:smbclient> function smbclient_creat ] {
- Parameters [3] {
Parameter #0 [ <required> $state ]
@@ -137,21 +137,21 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #2 [ <optional> $mode ]
}
}
- Function [ <internal:libsmbclient> function smbclient_read ] {
+ Function [ <internal:smbclient> function smbclient_read ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $file ]
}
}
- Function [ <internal:libsmbclient> function smbclient_close ] {
+ Function [ <internal:smbclient> function smbclient_close ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $file ]
}
}
- Function [ <internal:libsmbclient> function smbclient_mkdir ] {
+ Function [ <internal:smbclient> function smbclient_mkdir ] {
- Parameters [3] {
Parameter #0 [ <required> $state ]
@@ -159,14 +159,14 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #2 [ <optional> $mode ]
}
}
- Function [ <internal:libsmbclient> function smbclient_rmdir ] {
+ Function [ <internal:smbclient> function smbclient_rmdir ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $path ]
}
}
- Function [ <internal:libsmbclient> function smbclient_rename ] {
+ Function [ <internal:smbclient> function smbclient_rename ] {
- Parameters [4] {
Parameter #0 [ <required> $oldstate ]
@@ -175,7 +175,7 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #3 [ <required> $oldpath ]
}
}
- Function [ <internal:libsmbclient> function smbclient_write ] {
+ Function [ <internal:smbclient> function smbclient_write ] {
- Parameters [4] {
Parameter #0 [ <required> $state ]
@@ -184,14 +184,14 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #3 [ <optional> $count ]
}
}
- Function [ <internal:libsmbclient> function smbclient_unlink ] {
+ Function [ <internal:smbclient> function smbclient_unlink ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $path ]
}
}
- Function [ <internal:libsmbclient> function smbclient_lseek ] {
+ Function [ <internal:smbclient> function smbclient_lseek ] {
- Parameters [4] {
Parameter #0 [ <required> $state ]
@@ -200,7 +200,7 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #3 [ <required> $whence ]
}
}
- Function [ <internal:libsmbclient> function smbclient_ftruncate ] {
+ Function [ <internal:smbclient> function smbclient_ftruncate ] {
- Parameters [3] {
Parameter #0 [ <required> $state ]
@@ -208,7 +208,7 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #2 [ <required> $offset ]
}
}
- Function [ <internal:libsmbclient> function smbclient_chmod ] {
+ Function [ <internal:smbclient> function smbclient_chmod ] {
- Parameters [3] {
Parameter #0 [ <required> $state ]
@@ -216,7 +216,7 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #2 [ <optional> $mode ]
}
}
- Function [ <internal:libsmbclient> function smbclient_utimes ] {
+ Function [ <internal:smbclient> function smbclient_utimes ] {
- Parameters [4] {
Parameter #0 [ <required> $state ]
@@ -225,14 +225,14 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #3 [ <required> $atime ]
}
}
- Function [ <internal:libsmbclient> function smbclient_listxattr ] {
+ Function [ <internal:smbclient> function smbclient_listxattr ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $path ]
}
}
- Function [ <internal:libsmbclient> function smbclient_getxattr ] {
+ Function [ <internal:smbclient> function smbclient_getxattr ] {
- Parameters [3] {
Parameter #0 [ <required> $state ]
@@ -240,7 +240,7 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #2 [ <required> $name ]
}
}
- Function [ <internal:libsmbclient> function smbclient_setxattr ] {
+ Function [ <internal:smbclient> function smbclient_setxattr ] {
- Parameters [5] {
Parameter #0 [ <required> $state ]
@@ -250,7 +250,7 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #4 [ <optional> $flags ]
}
}
- Function [ <internal:libsmbclient> function smbclient_removexattr ] {
+ Function [ <internal:smbclient> function smbclient_removexattr ] {
- Parameters [3] {
Parameter #0 [ <required> $state ]
@@ -258,14 +258,14 @@ Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
Parameter #2 [ <required> $name ]
}
}
- Function [ <internal:libsmbclient> function smbclient_statvfs ] {
+ Function [ <internal:smbclient> function smbclient_statvfs ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
Parameter #1 [ <required> $path ]
}
}
- Function [ <internal:libsmbclient> function smbclient_fstatvfs ] {
+ Function [ <internal:smbclient> function smbclient_fstatvfs ] {
- Parameters [2] {
Parameter #0 [ <required> $state ]
diff --git a/php-smbclient.spec b/php-smbclient.spec
index cf89fd5..b8b467a 100644
--- a/php-smbclient.spec
+++ b/php-smbclient.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for php-libsmbclient
+# remirepo spec file for php-smbclient
#
# Copyright (c) 2015 Remi Collet
# License: CC-BY-SA
@@ -14,19 +14,20 @@
%endif
%endif
-%global gh_commit a65127d6b271e4627456aa5e8a2d8aff51cbf6fd
+%global gh_commit 8b9587df1a0859074eae6133c5210451d6527e38
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner eduardok
%global gh_project libsmbclient-php
%global gh_date 20150909
-%global prever -dev
-%{?scl: %scl_package php-libsmbclient}
+%global prever -rc1
+
+%{?scl: %scl_package php-smbclient}
%{!?scl: %global pkg_name %{name}}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global ext_name libsmbclient
+%global ext_name smbclient
%global with_zts 0%{?__ztsphp:1}
%if "%{php_version}" < "5.6"
%global ini_name %{ext_name}.ini
@@ -36,9 +37,9 @@
# Test suite requires a Samba server and configuration file
%global with_tests 0%{?_with_tests:1}
-Name: %{?sub_prefix}php-libsmbclient
+Name: %{?sub_prefix}php-smbclient
Version: 0.8.0
-Release: 0.1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.2.rc1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP wrapper for libsmbclient
Group: Development/Languages
@@ -61,6 +62,10 @@ BuildRequires: samba
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+# Rename
+Obsoletes: %{?sub_prefix}php-libsmbclient < 0.8.0-0.2
+Provides: %{?sub_prefix}php-libsmbclient = %{version}-%{release}
+Provides: %{?sub_prefix}php-libsmbclient%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -82,13 +87,15 @@ Obsoletes: php70w-%{ext_name} <= %{version}
%endif
%endif
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter private shared
%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
%{?filter_setup}
+%endif
%description
-libsmbclient-php is a PHP extension that uses Samba's libsmbclient
+%{ext_name} is a PHP extension that uses Samba's libsmbclient
library to provide Samba related functions to PHP programs.
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
@@ -100,9 +107,9 @@ mv %{gh_project}-%{gh_commit} NTS
cd NTS
# Check extension version
-ver=$(sed -n '/define LIBSMBCLIENT_VERSION/{s/.* "//;s/".*$//;p}' php_libsmbclient.h)
+ver=$(sed -n '/define PHP_SMBCLIENT_VERSION/{s/.* "//;s/".*$//;p}' php_smbclient.h)
if test "$ver" != "%{version}%{?prever}"; then
- : Error: Upstream LIBSMBCLIENT_VERSION version is ${ver}, expecting %{version}%{?prever}.
+ : Error: Upstream VERSION version is ${ver}, expecting %{version}%{?prever}.
exit 1
fi
cd ..
@@ -184,6 +191,11 @@ cp %{SOURCE2} phpunit.xml
%changelog
+* Wed Sep 16 2015 Remi Collet <rcollet@redhat.com> - 0.8.0-0.2.rc1
+- update to 0.8.0-rc1
+- rename from php-libsmbclient to php-smbclient
+- https://github.com/eduardok/libsmbclient-php/pull/26 rename
+
* Thu Sep 3 2015 Remi Collet <rcollet@redhat.com> - 0.8.0-0.1.20150909gita65127d
- update to 0.8.0-dev
- https://github.com/eduardok/libsmbclient-php/pull/20 streams support