summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-16 08:57:11 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-16 08:57:11 +0200
commita74b27bcb0b99bd9ac3d60643db77e0e1e9af95b (patch)
tree6d75b7e11536ee90324b19ff1f0777b7e66c8015
rename php-libsmbclient to php-smbclient
-rw-r--r--.gitignore1
-rw-r--r--Makefile4
-rw-r--r--REFLECTION277
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-smbclient.spec204
5 files changed, 513 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..97fa2e2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+libsmbclient-php-phpunit.xml
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..8ad0e21
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,277 @@
+Extension [ <persistent> extension #116 libsmbclient version 0.7.0 ] {
+
+ - Constants [30] {
+ Constant [ integer SMBCLIENT_XATTR_CREATE ] { 1 }
+ Constant [ integer SMBCLIENT_XATTR_REPLACE ] { 2 }
+ Constant [ integer SMBCLIENT_OPT_OPEN_SHAREMODE ] { 1 }
+ Constant [ integer SMBCLIENT_OPT_ENCRYPT_LEVEL ] { 2 }
+ Constant [ integer SMBCLIENT_OPT_CASE_SENSITIVE ] { 3 }
+ Constant [ integer SMBCLIENT_OPT_BROWSE_MAX_LMB_COUNT ] { 4 }
+ Constant [ integer SMBCLIENT_OPT_URLENCODE_READDIR_ENTRIES ] { 5 }
+ Constant [ integer SMBCLIENT_OPT_USE_KERBEROS ] { 6 }
+ Constant [ integer SMBCLIENT_OPT_FALLBACK_AFTER_KERBEROS ] { 7 }
+ Constant [ integer SMBCLIENT_OPT_AUTO_ANONYMOUS_LOGIN ] { 8 }
+ Constant [ integer SMBCLIENT_OPT_USE_CCACHE ] { 9 }
+ Constant [ integer SMBCLIENT_OPT_USE_NT_HASH ] { 10 }
+ Constant [ integer SMBCLIENT_OPT_NETBIOS_NAME ] { 11 }
+ Constant [ integer SMBCLIENT_OPT_WORKGROUP ] { 12 }
+ Constant [ integer SMBCLIENT_OPT_USER ] { 13 }
+ Constant [ integer SMBCLIENT_OPT_PORT ] { 14 }
+ Constant [ integer SMBCLIENT_OPT_TIMEOUT ] { 15 }
+ Constant [ integer SMBCLIENT_SHAREMODE_DENY_DOS ] { 0 }
+ Constant [ integer SMBCLIENT_SHAREMODE_DENY_ALL ] { 1 }
+ Constant [ integer SMBCLIENT_SHAREMODE_DENY_WRITE ] { 2 }
+ Constant [ integer SMBCLIENT_SHAREMODE_DENY_READ ] { 3 }
+ Constant [ integer SMBCLIENT_SHAREMODE_DENY_NONE ] { 4 }
+ Constant [ integer SMBCLIENT_SHAREMODE_DENY_FCB ] { 7 }
+ Constant [ integer SMBCLIENT_ENCRYPTLEVEL_NONE ] { 0 }
+ Constant [ integer SMBCLIENT_ENCRYPTLEVEL_REQUEST ] { 1 }
+ Constant [ integer SMBCLIENT_ENCRYPTLEVEL_REQUIRE ] { 2 }
+ Constant [ integer SMBCLIENT_VFS_RDONLY ] { 1 }
+ Constant [ integer SMBCLIENT_VFS_DFS ] { 268435456 }
+ Constant [ integer SMBCLIENT_VFS_CASE_INSENSITIVE ] { 536870912 }
+ Constant [ integer SMBCLIENT_VFS_NO_UNIXCIFS ] { 1073741824 }
+ }
+
+ - Functions {
+ Function [ <internal:libsmbclient> function smbclient_version ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_library_version ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_state_new ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_state_init ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <optional> $workgroup ]
+ Parameter #2 [ <optional> $user ]
+ Parameter #3 [ <optional> $password ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_state_errno ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $state ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_state_free ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $state ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_option_get ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $option ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_option_set ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $option ]
+ Parameter #2 [ <required> $value ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_opendir ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_readdir ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $dir ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_closedir ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $dir ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_stat ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_fstat ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $file ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_open ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ Parameter #2 [ <required> $flags ]
+ Parameter #3 [ <optional> $mode ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_creat ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ Parameter #2 [ <optional> $mode ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_read ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $file ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_close ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $file ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_mkdir ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ Parameter #2 [ <optional> $mode ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_rmdir ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_rename ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $oldstate ]
+ Parameter #1 [ <required> $oldpath ]
+ Parameter #2 [ <required> $oldstate ]
+ Parameter #3 [ <required> $oldpath ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_write ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $file ]
+ Parameter #2 [ <required> $buffer ]
+ Parameter #3 [ <optional> $count ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_unlink ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_lseek ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $file ]
+ Parameter #2 [ <required> $offset ]
+ Parameter #3 [ <required> $whence ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_ftruncate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $file ]
+ Parameter #2 [ <required> $offset ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_chmod ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ Parameter #2 [ <optional> $mode ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_utimes ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ Parameter #2 [ <required> $mtime ]
+ Parameter #3 [ <required> $atime ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_listxattr ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_getxattr ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ Parameter #2 [ <required> $name ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_setxattr ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ Parameter #2 [ <required> $name ]
+ Parameter #3 [ <required> $value ]
+ Parameter #4 [ <optional> $flags ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_removexattr ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ Parameter #2 [ <required> $name ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_statvfs ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $path ]
+ }
+ }
+ Function [ <internal:libsmbclient> function smbclient_fstatvfs ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $state ]
+ Parameter #1 [ <required> $file ]
+ }
+ }
+ }
+}
+
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..24fbf81
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-smbclient.spec b/php-smbclient.spec
new file mode 100644
index 0000000..cf89fd5
--- /dev/null
+++ b/php-smbclient.spec
@@ -0,0 +1,204 @@
+# remirepo spec file for php-libsmbclient
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%endif
+
+%global gh_commit a65127d6b271e4627456aa5e8a2d8aff51cbf6fd
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner eduardok
+%global gh_project libsmbclient-php
+%global gh_date 20150909
+%global prever -dev
+%{?scl: %scl_package php-libsmbclient}
+%{!?scl: %global pkg_name %{name}}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global ext_name libsmbclient
+%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{ext_name}.ini
+%else
+%global ini_name 40-%{ext_name}.ini
+%endif
+# Test suite requires a Samba server and configuration file
+%global with_tests 0%{?_with_tests:1}
+
+Name: %{?sub_prefix}php-libsmbclient
+Version: 0.8.0
+Release: 0.1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Summary: PHP wrapper for libsmbclient
+
+Group: Development/Languages
+License: BSD
+URL: https://github.com/eduardok/libsmbclient-php
+Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
+# git snapshot as upstream doesn't provide test suite
+Source1: makesrc.sh
+%if %{with_tests}
+Source2: %{gh_project}-phpunit.xml
+%endif
+
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: libsmbclient-devel > 3.6
+%if %{with_tests}
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: samba
+%endif
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-%{ext_name} <= %{version}
+Obsoletes: php53u-%{ext_name} <= %{version}
+Obsoletes: php54-%{ext_name} <= %{version}
+Obsoletes: php54w-%{ext_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-%{ext_name} <= %{version}
+Obsoletes: php55w-%{ext_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-%{ext_name} <= %{version}
+Obsoletes: php56w-%{ext_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-%{ext_name} <= %{version}
+Obsoletes: php70w-%{ext_name} <= %{version}
+%endif
+%endif
+
+# Filter private shared
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+
+
+%description
+libsmbclient-php is a PHP extension that uses Samba's libsmbclient
+library to provide Samba related functions to PHP programs.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
+
+
+%prep
+%setup -q -c
+mv %{gh_project}-%{gh_commit} NTS
+
+cd NTS
+# Check extension version
+ver=$(sed -n '/define LIBSMBCLIENT_VERSION/{s/.* "//;s/".*$//;p}' php_libsmbclient.h)
+if test "$ver" != "%{version}%{?prever}"; then
+ : Error: Upstream LIBSMBCLIENT_VERSION version is ${ver}, expecting %{version}%{?prever}.
+ exit 1
+fi
+cd ..
+
+cat << 'EOF' | tee %{ini_name}
+; Enable %{summary} extension module
+extension=%{ext_name}.so
+EOF
+
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install configuration
+install -Dpm 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -Dpm 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%check
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{ext_name}.so \
+ --modules | grep %{ext_name}
+
+%if %{with_zts}
+: Minimal load test for NTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{ext_name}.so \
+ --modules | grep %{ext_name}
+%endif
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+cd NTS
+cp %{SOURCE2} phpunit.xml
+
+%{__php} \
+ --define extension=%{buildroot}%{php_extdir}/%{ext_name}.so \
+ %{_bindir}/phpunit --verbose
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license NTS/LICENSE
+%doc NTS/README.md
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{ext_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{ext_name}.so
+%endif
+
+
+%changelog
+* Thu Sep 3 2015 Remi Collet <rcollet@redhat.com> - 0.8.0-0.1.20150909gita65127d
+- update to 0.8.0-dev
+- https://github.com/eduardok/libsmbclient-php/pull/20 streams support
+- https://github.com/eduardok/libsmbclient-php/pull/23 PHP 7
+
+* Thu Sep 3 2015 Remi Collet <rcollet@redhat.com> - 0.7.0-1
+- Update to 0.7.0
+- drop patches merged upstream
+- license is now BSD
+
+* Wed Sep 2 2015 Remi Collet <rcollet@redhat.com> - 0.6.1-1
+- Initial packaging of 0.6.1
+- open https://github.com/eduardok/libsmbclient-php/pull/17
+ test suite configuration
+- open https://github.com/eduardok/libsmbclient-php/pull/18
+ add reflection and improve phpinfo
+- open https://github.com/eduardok/libsmbclient-php/issues/19
+ missing license file \ No newline at end of file