summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-29 13:12:06 +0200
committerRemi Collet <remi@remirepo.net>2019-04-29 13:12:06 +0200
commit50a19e83b6f21c08d5e29bc502baaefb1ad0ee80 (patch)
tree73d51f199b1f11ffa7a5810a199e304c0f4525ec
parent6b29858370373767274b14d16ab2e7f10e05383f (diff)
From FedoraHEADmaster
* Sat Apr 27 2019 Johan Cwiklinski <johan AT x+tnd DOT be> - 3.12.1-1 - New upstream release * Sat Jul 14 2018 Johan Cwiklinski <johan AT x-tnd DOT be> - 3.10.0-3 - php-Slim (for v2) has been retired, add provides and obsoletes
-rw-r--r--.gitignore8
-rw-r--r--composer.json13
l---------makesrc.sh1
-rw-r--r--php-slim3.spec19
4 files changed, 32 insertions, 9 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 554a838..ca85d58 100644
--- a/composer.json
+++ b/composer.json
@@ -47,12 +47,15 @@
"Slim\\": "Slim"
}
},
+ "autoload-dev": {
+ "files": [
+ "tests/Assets/PhpFunctionOverrides.php"
+ ]
+ },
"scripts": {
"test": [
- "@phpunit",
- "@phpcs"
- ],
- "phpunit": "php vendor/bin/phpunit",
- "phpcs": "php vendor/bin/phpcs"
+ "phpunit",
+ "phpcs"
+ ]
}
}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..cc20008
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-slim3-makesrc.sh \ No newline at end of file
diff --git a/php-slim3.spec b/php-slim3.spec
index 8f0c4f0..e6b5cfc 100644
--- a/php-slim3.spec
+++ b/php-slim3.spec
@@ -7,12 +7,12 @@
#
# Please preserve changelog entries
-%global gh_commit d8aabeacc3688b25e2f2dd2db91df91ec6fdd748
+%global gh_commit eaee12ef8d0750db62b8c548016d82fb33addb6b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner slimphp
%global gh_project Slim
%global pk_project slim
-%global gh_version 3.10.0
+%global gh_version 3.12.1
%global php_home %{_datadir}/php
%global slim_home %{php_home}/Slim3
@@ -29,7 +29,6 @@ Source1: %{name}-makesrc.sh
URL: http://www.slimframework.com/
License: MIT
-Group: Development/Libraries
BuildArch: noarch
@@ -72,6 +71,12 @@ Requires: php-composer(nikic/fast-route) < 2.0
Provides: php-composer(%{pk_project}/%{pk_project}) = %{version}
Provides: php-composer(psr/http-message-implementation) = 1.0
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
+#php-Slim (v2) ha been retired
+Provides: php-Slim = %{version}-%{release}
+Obsoletes: php-Slim <= 2.6.2-8
+%endif
+
%description
Slim is a PHP micro framework that helps you quickly write simple yet
@@ -130,7 +135,7 @@ cp -a %{gh_project}/* %{buildroot}%{slim_home}/
%check
sed -e \
"s|dirname(__DIR__) . '/vendor/autoload.php'|'%{buildroot}%{slim_home}/autoload.php'|" \
- -e "s|\$autoloader->addPsr4.*$|require 'autoload.php';|" \
+ -e "s|\$autoloader->addPsr4.*$|require 'autoload.php';\nrequire __DIR__ . '/Assets/PhpFunctionOverrides.php';|" \
-i tests/bootstrap.php
# OK (Tests: 512, Assertions: 820, Skipped: 13)
@@ -149,6 +154,12 @@ sed -e \
%changelog
+* Sat Apr 27 2019 Johan Cwiklinski <johan AT x+tnd DOT be> - 3.12.1-1
+- New upstream release
+
+* Sat Jul 14 2018 Johan Cwiklinski <johan AT x-tnd DOT be> - 3.10.0-3
+- php-Slim (for v2) has been retired, add provides and obsoletes
+
* Sat Apr 21 2018 Johan Cwiklinski <johan AT x-tnd DOT be> - 3.10.0-1
- New upstream release