summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-23 14:55:58 +0200
committerRemi Collet <remi@remirepo.net>2018-04-23 14:55:58 +0200
commit6b29858370373767274b14d16ab2e7f10e05383f (patch)
treea897d43a368fe241740ab8548a0914a86f5a1d7e
parent6f27b3a46c4b034fe5ebb7e938c9c6b3064e33ec (diff)
v3.10.0 from Fedora
-rw-r--r--composer.json3
-rw-r--r--php-slim3.spec36
2 files changed, 12 insertions, 27 deletions
diff --git a/composer.json b/composer.json
index ed19202..554a838 100644
--- a/composer.json
+++ b/composer.json
@@ -32,7 +32,8 @@
"pimple/pimple": "^3.0",
"psr/http-message": "^1.0",
"nikic/fast-route": "^1.0",
- "container-interop/container-interop": "^1.1"
+ "container-interop/container-interop": "^1.2",
+ "psr/container": "^1.0"
},
"require-dev": {
"squizlabs/php_codesniffer": "^2.5",
diff --git a/php-slim3.spec b/php-slim3.spec
index eeb53b0..8f0c4f0 100644
--- a/php-slim3.spec
+++ b/php-slim3.spec
@@ -7,12 +7,12 @@
#
# Please preserve changelog entries
-%global gh_commit 4254e40d81559e35cdf856bcbaca5f3af468b7ef
+%global gh_commit d8aabeacc3688b25e2f2dd2db91df91ec6fdd748
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner slimphp
%global gh_project Slim
%global pk_project slim
-%global gh_version 3.7.0
+%global gh_version 3.10.0
%global php_home %{_datadir}/php
%global slim_home %{php_home}/Slim3
@@ -27,11 +27,10 @@ Source0: %{name}-%{gh_version}-%{gh_short}.tgz
# Script to pull the git snapshot
Source1: %{name}-makesrc.sh
-URL: https://slimframework.com
+URL: http://www.slimframework.com/
License: MIT
Group: Development/Libraries
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
#main app
@@ -48,7 +47,8 @@ BuildRequires: php-composer(phpunit/phpunit) >= 4.0
BuildRequires: php-mbstring
BuildRequires: php-composer(psr/http-message) >= 1.0
BuildRequires: php-composer(pimple/pimple) >= 3.0
-BuildRequires: php-composer(container-interop/container-interop) >= 1.1
+BuildRequires: php-composer(container-interop/container-interop) >= 1.2
+BuildRequires: php-composer(psr/container) >= 1.0
BuildRequires: php-composer(nikic/fast-route) >= 1.0
Requires: php(language) >= 5.5.0
@@ -64,6 +64,8 @@ Requires: php-composer(pimple/pimple) >= 3.0
Requires: php-composer(pimple/pimple) < 4.0
Requires: php-composer(container-interop/container-interop) >= 1.1
Requires: php-composer(container-interop/container-interop) < 2.0
+Requires: php-composer(psr/container) >= 1.0
+Requires: php-composer(psr/container) < 2.0
Requires: php-composer(nikic/fast-route) >= 1.0
Requires: php-composer(nikic/fast-route) < 2.0
@@ -120,8 +122,6 @@ EOF
%install
-rm -rf %{buildroot}
-
# install framework files
install -d %{buildroot}%{slim_home}
cp -a %{gh_project}/* %{buildroot}%{slim_home}/
@@ -134,32 +134,13 @@ sed -e \
-i tests/bootstrap.php
# OK (Tests: 512, Assertions: 820, Skipped: 13)
-# remirepo:11
-run=0
-ret=0
-if which php56; then
- php56 %{_bindir}/phpunit -d memory_limit=-1 tests || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit -d memory_limit=-1 tests || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
%{_bindir}/phpunit \
-d memory_limit=-1 \
tests
-# remirepo:2
-fi
-exit $ret
-
-%clean
-rm -rf %{buildroot}
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE.md
%doc README.md CONTRIBUTING.md composer.json
@@ -168,6 +149,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Apr 21 2018 Johan Cwiklinski <johan AT x-tnd DOT be> - 3.10.0-1
+- New upstream release
+
* Sun Dec 25 2016 Johan Cwiklinski <johan AT x-tnd DOT be> - 3.7.0-1
- New upstream release