summaryrefslogtreecommitdiffstats
path: root/php-simplepie.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-simplepie.spec')
-rw-r--r--php-simplepie.spec45
1 files changed, 29 insertions, 16 deletions
diff --git a/php-simplepie.spec b/php-simplepie.spec
index e60947d..6b62067 100644
--- a/php-simplepie.spec
+++ b/php-simplepie.spec
@@ -7,12 +7,12 @@
#
# Please preserve changelog entries
#
-%global gh_commit 0e8fe72132dad765d25db4cabc69a91139af1263
+%global gh_commit 1c68e14ca3ac84346b6e6fe3c5eedf725d0f92c6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner simplepie
%global gh_project simplepie
-%global gh_version 1.5.2
-%global with_tests 0%{!?_without_tests:1}
+%global gh_version 1.5.6
+%bcond_without tests
Name: php-%{gh_project}
Version: %{gh_version}
@@ -30,20 +30,15 @@ Source1: %{name}-makesrc.sh
# Adapt autoloader for installation tree
Patch0: %{name}-rpm.patch
+# Adpat to phpunit7 and php 8
+Patch1: %{name}-tests.patch
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# From composer.json, "require-dev"
# "phpunit/phpunit": "~5.4.3 || ~6.5"
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: phpunit6 >= 6.5
-%global phpunit %{_bindir}/phpunit6
-# remirepo:4
-%else
-BuildRequires: php-phpunit-PHPUnit
-%global phpunit %{_bindir}/phpunit
-%endif
+BuildRequires: phpunit7
+%global phpunit %{_bindir}/phpunit7
%endif
# from composer.json, "require"
@@ -89,6 +84,7 @@ Autoloader: %{_datadir}/php/%{name}/autoloader.php
%setup -qn %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
+%patch1 -p1 -b .php8
# fix rpmlint warnings
find . -type f -exec chmod -x {} \;
@@ -108,16 +104,16 @@ install -pm 644 autoloader.php \
%{buildroot}/%{_datadir}/php/%{name}/autoloader.php
-%if %{with_tests}
+%if %{with tests}
%check
sed -e 's:@PATH@:%{buildroot}/%{_datadir}/php/%{name}:' \
-i tests/bootstrap.php
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72 php73; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -125,6 +121,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE.txt
%doc composer.json
@@ -134,6 +131,22 @@ exit $ret
%changelog
+* Tue Mar 23 2021 Remi Collet <remi@remirepo.net> - 1.5.6-1
+- update to 1.5.6
+- switch to phpunit7 and fix FTBFS with PHP 8
+
+* Wed Jul 1 2020 Remi Collet <remi@remirepo.net> - 1.5.5-1
+- update to 1.5.5
+
+* Wed Dec 18 2019 Remi Collet <remi@remirepo.net> - 1.5.4-1
+- update to 1.5.4
+- drop patch merged upstream
+
+* Wed Oct 9 2019 Remi Collet <remi@remirepo.net> - 1.5.3-1
+- update to 1.5.3
+- add patch for PHP 7.4 from
+ https://github.com/simplepie/simplepie/pull/628
+
* Tue Oct 2 2018 Remi Collet <remi@remirepo.net> - 1.5.2-1
- update to 1.5.2
- raise dependency on PHP 5.6