summaryrefslogtreecommitdiffstats
path: root/php-simplepie.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-23 16:19:39 +0100
committerRemi Collet <remi@remirepo.net>2021-03-23 16:19:39 +0100
commit5886f2d426a86aca8ad68dc3dcbd2acc34e402c5 (patch)
tree1c4e59786958993d23c979f07415bc5634c9df54 /php-simplepie.spec
parent562641ccbb7fc5f3bd35d252ebf8a463dfb94c43 (diff)
update to 1.5.6HEADmaster
switch to phpunit7 and fix FTBFS with PHP 8
Diffstat (limited to 'php-simplepie.spec')
-rw-r--r--php-simplepie.spec28
1 files changed, 14 insertions, 14 deletions
diff --git a/php-simplepie.spec b/php-simplepie.spec
index 06c887a..6b62067 100644
--- a/php-simplepie.spec
+++ b/php-simplepie.spec
@@ -7,11 +7,11 @@
#
# Please preserve changelog entries
#
-%global gh_commit ae49e2201b6da9c808e5dac437aca356a11831b4
+%global gh_commit 1c68e14ca3ac84346b6e6fe3c5eedf725d0f92c6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner simplepie
%global gh_project simplepie
-%global gh_version 1.5.5
+%global gh_version 1.5.6
%bcond_without tests
Name: php-%{gh_project}
@@ -30,20 +30,15 @@ Source1: %{name}-makesrc.sh
# Adapt autoloader for installation tree
Patch0: %{name}-rpm.patch
+# Adpat to phpunit7 and php 8
+Patch1: %{name}-tests.patch
BuildArch: noarch
%if %{with tests}
# From composer.json, "require-dev"
# "phpunit/phpunit": "~5.4.3 || ~6.5"
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: phpunit6 >= 6.5
-%global phpunit %{_bindir}/phpunit6
-# remirepo:4
-%else
-BuildRequires: php-phpunit-PHPUnit
-%global phpunit %{_bindir}/phpunit
-%endif
+BuildRequires: phpunit7
+%global phpunit %{_bindir}/phpunit7
%endif
# from composer.json, "require"
@@ -89,6 +84,7 @@ Autoloader: %{_datadir}/php/%{name}/autoloader.php
%setup -qn %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
+%patch1 -p1 -b .php8
# fix rpmlint warnings
find . -type f -exec chmod -x {} \;
@@ -114,11 +110,10 @@ sed -e 's:@PATH@:%{buildroot}/%{_datadir}/php/%{name}:' \
-i tests/bootstrap.php
ret=0
-# TODO php 8 Errors: 1, Failures: 1.
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -126,6 +121,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE.txt
%doc composer.json
@@ -135,6 +131,10 @@ exit $ret
%changelog
+* Tue Mar 23 2021 Remi Collet <remi@remirepo.net> - 1.5.6-1
+- update to 1.5.6
+- switch to phpunit7 and fix FTBFS with PHP 8
+
* Wed Jul 1 2020 Remi Collet <remi@remirepo.net> - 1.5.5-1
- update to 1.5.5