summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-09-01 11:44:20 +0200
committerRemi Collet <fedora@famillecollet.com>2012-09-01 11:44:20 +0200
commit09277511010f5f840b1e2df7415d9357cde2e53e (patch)
tree1647ff4a3aa0d85a9e4be40867ffca6bae65d56d
parent41abbd16c0c0af5e17904506b7b0a71fd33cec66 (diff)
php-redis fix test server config for EL
-rw-r--r--php-redis.spec6
1 files changed, 4 insertions, 2 deletions
diff --git a/php-redis.spec b/php-redis.spec
index e8955f1..8556497 100644
--- a/php-redis.spec
+++ b/php-redis.spec
@@ -133,7 +133,9 @@ cd nts/tests
# Launch redis server
mkdir -p {run,log,lib}/redis
-sed -s "s:/var:$PWD:" /etc/redis.conf >redis.conf
+sed -e "s:/var:$PWD:" \
+ -e "/daemonize/s/yes/no/" \
+ /etc/redis.conf >redis.conf
%if 0%{?__isa_bits}
# port number to allow 32/64 build at same time
# and avoid conflict with a possible running server
@@ -153,7 +155,7 @@ php --no-php-ini \
TestRedis.php || ret=1
# Cleanup
-kill $srv
+kill $srv || :
exit $ret
%else