summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-09-01 11:08:59 +0200
committerRemi Collet <fedora@famillecollet.com>2012-09-01 11:08:59 +0200
commit41abbd16c0c0af5e17904506b7b0a71fd33cec66 (patch)
tree7a5cd89aed18e57c4d37a59f4a3e00babf250210
parent1464143f1dc695a5c949e32e4ab12f24996c47a4 (diff)
php-redis: select server port for tests
-rw-r--r--php-redis.spec7
1 files changed, 7 insertions, 0 deletions
diff --git a/php-redis.spec b/php-redis.spec
index e02a8f9..e8955f1 100644
--- a/php-redis.spec
+++ b/php-redis.spec
@@ -134,6 +134,13 @@ cd nts/tests
# Launch redis server
mkdir -p {run,log,lib}/redis
sed -s "s:/var:$PWD:" /etc/redis.conf >redis.conf
+%if 0%{?__isa_bits}
+# port number to allow 32/64 build at same time
+# and avoid conflict with a possible running server
+port=$(expr %{__isa_bits} + 6350)
+sed -e "s/6379/$port/" -i redis.conf
+sed -e "s/6379/$port/" -i TestRedis.php
+%endif
%{_sbindir}/redis-server ./redis.conf &
srv=$!