summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-08-02 08:54:56 +0200
committerRemi Collet <remi@remirepo.net>2019-08-02 08:54:56 +0200
commitf0be2b7c58cde65f582dbb10d3e26b535f68b781 (patch)
tree0c01f509cd1cf7ffa8ae923c0a9f472325dc4567
parent1509f902318659f8cf55861c35e85fdbf2e2997f (diff)
v2.7.0
-rw-r--r--composer.json106
-rw-r--r--php-phpmd-PHP-PMD.spec32
2 files changed, 79 insertions, 59 deletions
diff --git a/composer.json b/composer.json
index 2d2dae1..12b293c 100644
--- a/composer.json
+++ b/composer.json
@@ -1,55 +1,61 @@
{
- "name": "phpmd/phpmd",
- "description": "PHPMD is a spin-off project of PHP Depend and aims to be a PHP equivalent of the well known Java tool PMD.",
- "keywords": [
- "phpmd",
- "pdepend",
- "pmd",
- "mess detection",
- "mess detector"
- ],
- "type": "project",
- "license": "BSD-3-Clause",
- "homepage": "http://phpmd.org/",
- "authors": [
- {
- "name": "Manuel Pichler",
- "homepage": "https://github.com/manuelpichler",
- "email": "github@manuel-pichler.de",
- "role": "Project Founder"
- },
- {
- "name": "Marc Würth",
- "homepage": "https://github.com/ravage84",
- "email": "ravage@bluewin.ch",
- "role": "Project Maintainer"
- },
- {
- "name": "Other contributors",
- "homepage": "https://github.com/phpmd/phpmd/graphs/contributors",
- "role": "Contributors"
- }
- ],
- "support": {
- "irc": "irc://irc.freenode.org/phpmd"
+ "name": "phpmd/phpmd",
+ "description": "PHPMD is a spin-off project of PHP Depend and aims to be a PHP equivalent of the well known Java tool PMD.",
+ "keywords": [
+ "phpmd",
+ "pdepend",
+ "pmd",
+ "mess detection",
+ "mess detector"
+ ],
+ "type": "library",
+ "license": "BSD-3-Clause",
+ "homepage": "https://phpmd.org/",
+ "authors": [
+ {
+ "name": "Manuel Pichler",
+ "homepage": "https://github.com/manuelpichler",
+ "email": "github@manuel-pichler.de",
+ "role": "Project Founder"
},
- "minimum-stability" : "stable",
- "require": {
- "php": ">=5.3.9",
- "pdepend/pdepend": "^2.5",
- "ext-xml": "*"
+ {
+ "name": "Marc Würth",
+ "homepage": "https://github.com/ravage84",
+ "email": "ravage@bluewin.ch",
+ "role": "Project Maintainer"
},
- "require-dev": {
- "phpunit/phpunit": "^4.0",
- "squizlabs/php_codesniffer": "^2.0"
- },
- "autoload": {
- "psr-0": {
- "PHPMD\\": "src/main/php"
- }
- },
- "bin": ["src/bin/phpmd"],
- "scripts": {
- "test": "phpunit"
+ {
+ "name": "Other contributors",
+ "homepage": "https://github.com/phpmd/phpmd/graphs/contributors",
+ "role": "Contributors"
+ }
+ ],
+ "support": {
+ "irc": "irc://irc.freenode.org/phpmd"
+ },
+ "minimum-stability": "stable",
+ "require": {
+ "php": ">=5.3.9",
+ "pdepend/pdepend": "^2.5",
+ "ext-xml": "*"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.8.36 || ^5.7.27",
+ "squizlabs/php_codesniffer": "^2.0",
+ "mikey179/vfsstream": "^1.6.4",
+ "gregwar/rst": "^1.0"
+ },
+ "autoload": {
+ "psr-0": {
+ "PHPMD\\": "src/main/php"
}
+ },
+ "bin": [
+ "src/bin/phpmd"
+ ],
+ "scripts": {
+ "test": "phpunit",
+ "cs-check": "phpcs -p --standard=PSR2 --runtime-set ignore_errors_on_exit 1 --runtime-set ignore_warnings_on_exit 1 ./src/main/php ./src/test/php",
+ "cs-fix": "phpcbf -p --standard=PSR2 --runtime-set ignore_errors_on_exit 1 --runtime-set ignore_warnings_on_exit 1 ./src/main/php ./src/test/php"
+ }
}
diff --git a/php-phpmd-PHP-PMD.spec b/php-phpmd-PHP-PMD.spec
index 12edf39..e327918 100644
--- a/php-phpmd-PHP-PMD.spec
+++ b/php-phpmd-PHP-PMD.spec
@@ -7,7 +7,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 7425e155cf22cdd2b4dd3458a7da4cf6c0201562
+%global gh_commit a05a999c644f4bc9a204846017db7bb7809fbe4c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpmd
%global gh_project phpmd
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-phpmd-PHP-PMD
-Version: 2.6.1
+Version: 2.7.0
Release: 1%{?dist}
Summary: PHPMD - PHP Mess Detector
@@ -35,17 +35,23 @@ BuildArch: noarch
%if %{with_tests}
# For tests
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^4.0",
-# "squizlabs/php_codesniffer": "^2.0"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# "phpunit/phpunit": "^4.8.36 || ^5.7.27",
+# "squizlabs/php_codesniffer": "^2.0",
+# "mikey179/vfsstream": "^1.6.4",
+# "gregwar/rst": "^1.0"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8.36
BuildRequires: php(language) >= 5.3.9
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(pdepend/pdepend) >= 2.5 with php-composer(pdepend/pdepend) < 3)
+BuildRequires: (php-composer(pdepend/pdepend) >= 2.5 with php-composer(pdepend/pdepend) < 3)
+BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6.4 with php-composer(mikey179/vfsstream) < 2)
%else
-BuildRequires: php-composer(pdepend/pdepend) < 3
-BuildRequires: php-composer(pdepend/pdepend) >= 2.5
+BuildRequires: php-composer(pdepend/pdepend) < 3
+BuildRequires: php-composer(pdepend/pdepend) >= 2.5
+BuildRequires: php-composer(mikey179/vfsstream) < 2
+BuildRequires: php-composer(mikey179/vfsstream) >= 1.6.4
%endif
BuildRequires: php-date
+BuildRequires: php-json
BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-simplexml
@@ -66,8 +72,9 @@ Requires: php-composer(pdepend/pdepend) < 3
Requires: php-composer(pdepend/pdepend) >= 2.5
%endif
Requires: php-xml
-# From phpcompatinfo report for version 2.6.0
+# From phpcompatinfo report for version 2.7.0
Requires: php-date
+Requires: php-json
Requires: php-libxml
Requires: php-pcre
Requires: php-simplexml
@@ -122,6 +129,10 @@ cat << 'EOF' | tee src/test/php/bootstrap.php
<?php
require '%{buildroot}%{php_home}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('PHPMD\\', __DIR__ . '/PHPMD');
+\Fedora\Autoloader\Dependencies::required([
+ '%{_datadir}/php/org/bovigo/vfs/autoload.php',
+]);
+
EOF
ret=0
@@ -155,6 +166,9 @@ fi
%changelog
+* Fri Aug 2 2019 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- update to 2.7.0
+
* Mon Jul 15 2019 Remi Collet <remi@remirepo.net> - 2.6.1-1
- update to 2.6.1
- use range dependencies