summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-15 09:29:05 +0200
committerRemi Collet <remi@remirepo.net>2019-07-15 09:29:05 +0200
commit1509f902318659f8cf55861c35e85fdbf2e2997f (patch)
treeab8bb4be78acc356dfa672c036256d11db0c3458
parent8c938ae6055f63638cf37027c8a2583b1b078f73 (diff)
- update to 2.6.1
- use range dependencies
-rw-r--r--php-phpmd-PHP-PMD.spec30
1 files changed, 17 insertions, 13 deletions
diff --git a/php-phpmd-PHP-PMD.spec b/php-phpmd-PHP-PMD.spec
index 9ddd6a8..12edf39 100644
--- a/php-phpmd-PHP-PMD.spec
+++ b/php-phpmd-PHP-PMD.spec
@@ -7,7 +7,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 4e9924b2c157a3eb64395460fcf56b31badc8374
+%global gh_commit 7425e155cf22cdd2b4dd3458a7da4cf6c0201562
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpmd
%global gh_project phpmd
@@ -18,11 +18,10 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-phpmd-PHP-PMD
-Version: 2.6.0
+Version: 2.6.1
Release: 1%{?dist}
Summary: PHPMD - PHP Mess Detector
-Group: Development/Libraries
License: BSD
URL: http://phpmd.org/
# git snashop to get upstream test suite
@@ -32,7 +31,6 @@ Source1: makesrc.sh
Source2: %{name}-autoload.php
Patch0: %{name}-rpm.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -41,7 +39,12 @@ BuildArch: noarch
# "squizlabs/php_codesniffer": "^2.0"
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
BuildRequires: php(language) >= 5.3.9
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(pdepend/pdepend) >= 2.5 with php-composer(pdepend/pdepend) < 3)
+%else
+BuildRequires: php-composer(pdepend/pdepend) < 3
BuildRequires: php-composer(pdepend/pdepend) >= 2.5
+%endif
BuildRequires: php-date
BuildRequires: php-libxml
BuildRequires: php-pcre
@@ -56,8 +59,12 @@ BuildRequires: php-composer(fedora/autoloader)
# "pdepend/pdepend": "^2.5",
# "ext-xml": "*"
Requires: php(language) >= 5.3.9
-Requires: php-composer(pdepend/pdepend) >= 2.5
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(pdepend/pdepend) >= 2.5 with php-composer(pdepend/pdepend) < 3)
+%else
Requires: php-composer(pdepend/pdepend) < 3
+Requires: php-composer(pdepend/pdepend) >= 2.5
+%endif
Requires: php-xml
# From phpcompatinfo report for version 2.6.0
Requires: php-date
@@ -97,8 +104,6 @@ find src/test -type f -exec sed -e 's:@package_version@:%{version}:' -i
%install
-rm -rf %{buildroot}
-
: Library
mkdir -p $(dirname %{buildroot}%{php_home})
cp -pr src/main/php/PHPMD %{buildroot}%{php_home}
@@ -120,7 +125,7 @@ require '%{buildroot}%{php_home}/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit --columns max --verbose || ret=1
fi
@@ -138,12 +143,7 @@ if [ -x %{_bindir}/pear ]; then
fi
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -155,6 +155,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Jul 15 2019 Remi Collet <remi@remirepo.net> - 2.6.1-1
+- update to 2.6.1
+- use range dependencies
+
* Fri Jan 20 2017 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
- update to 2.6.0
- raise dependency on pdepend/pdepend version 2.5