summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-01 15:16:10 +0100
committerRemi Collet <remi@remirepo.net>2017-11-01 15:16:10 +0100
commit8c938ae6055f63638cf37027c8a2583b1b078f73 (patch)
treeec4b2ffe2ab1f571715b50aa2d349e59d801be95
parenta346ac5545e05f95aec38e395802b8c4f2add674 (diff)
improve %check
-rw-r--r--.gitignore7
-rw-r--r--php-phpmd-PHP-PMD.spec19
2 files changed, 12 insertions, 14 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-phpmd-PHP-PMD.spec b/php-phpmd-PHP-PMD.spec
index b3a5e84..9ddd6a8 100644
--- a/php-phpmd-PHP-PMD.spec
+++ b/php-phpmd-PHP-PMD.spec
@@ -119,21 +119,12 @@ require '%{buildroot}%{php_home}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('PHPMD\\', __DIR__ . '/PHPMD');
EOF
-# remirepo:11
ret=0
-run=0
-if which php71; then
- php71 %{_bindir}/phpunit --verbose --columns max || ret=1
- run=1
-fi
-if which php56; then
- php56 %{_bindir}/phpunit --verbose --columns max || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --columns max --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled