summaryrefslogtreecommitdiffstats
path: root/php-phpmd-PHP-PMD.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpmd-PHP-PMD.spec')
-rw-r--r--php-phpmd-PHP-PMD.spec19
1 files changed, 5 insertions, 14 deletions
diff --git a/php-phpmd-PHP-PMD.spec b/php-phpmd-PHP-PMD.spec
index b3a5e84..9ddd6a8 100644
--- a/php-phpmd-PHP-PMD.spec
+++ b/php-phpmd-PHP-PMD.spec
@@ -119,21 +119,12 @@ require '%{buildroot}%{php_home}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('PHPMD\\', __DIR__ . '/PHPMD');
EOF
-# remirepo:11
ret=0
-run=0
-if which php71; then
- php71 %{_bindir}/phpunit --verbose --columns max || ret=1
- run=1
-fi
-if which php56; then
- php56 %{_bindir}/phpunit --verbose --columns max || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --columns max --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled