summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-19 07:07:46 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-19 07:07:46 +0100
commit2f2fb42a9dcee3d956397d1b604359287e6a0246 (patch)
tree67a928a655e9dbcb80ede36bdd8cc386d430c99d
parent12f6c301ca5b4b6470ae7374276904297102d32d (diff)
php-phpass: backportHEADmaster
-rw-r--r--Makefile10
-rw-r--r--php-phpass.spec7
2 files changed, 16 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-phpass.spec b/php-phpass.spec
index 02c676c..ca846dc 100644
--- a/php-phpass.spec
+++ b/php-phpass.spec
@@ -5,11 +5,12 @@ Summary: Portable password hashing framework for use in PHP applications
License: Public Domain
URL: http://www.openwall.com/phpass/
+Group: Development/Libraries
Source0: http://www.openwall.com/phpass/phpass-0.3.tar.gz
Source1: phpass-README.devel
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-
BuildRequires: php-cli
Requires: php-common
@@ -45,12 +46,16 @@ php test.php | grep PASSED
%files
+%defattr(-,root,root,-)
%doc test.php c README.devel
%dir %{_datadir}/php/phpass
%{_datadir}/php/phpass/PasswordHash.php
%changelog
+* Wed Dec 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 0.3-2
+- backport 0.3.2 for remi repo.
+
* Sun Dec 16 2012 Gregor Tätzner <brummbq@fedoraproject.org> - 0.3-2
- enabled tests