summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-19 07:05:20 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-19 07:05:20 +0100
commit12f6c301ca5b4b6470ae7374276904297102d32d (patch)
tree4e4b47f9a2da240a82fa5a4f9c8cdec024a2b758
php-phpass: import from rawhide
-rw-r--r--php-phpass.spec59
-rw-r--r--phpass-README.devel7
2 files changed, 66 insertions, 0 deletions
diff --git a/php-phpass.spec b/php-phpass.spec
new file mode 100644
index 0000000..02c676c
--- /dev/null
+++ b/php-phpass.spec
@@ -0,0 +1,59 @@
+Name: php-phpass
+Version: 0.3
+Release: 2%{?dist}
+Summary: Portable password hashing framework for use in PHP applications
+
+License: Public Domain
+URL: http://www.openwall.com/phpass/
+Source0: http://www.openwall.com/phpass/phpass-0.3.tar.gz
+Source1: phpass-README.devel
+
+BuildArch: noarch
+
+BuildRequires: php-cli
+
+Requires: php-common
+
+%description
+phpass (pronounced "pH pass") is a portable public domain password hashing
+framework for use in PHP applications. It is meant to work with PHP 3 and
+above.
+
+The preferred (most secure) hashing method supported by phpass is the
+OpenBSD-style Blowfish-based bcrypt and known in PHP as CRYPT_BLOWFISH, with
+a fallback to BSDI-style extended DES-based hashes, known in PHP as
+CRYPT_EXT_DES, and a last resort fallback to MD5-based salted and variable
+iteration count password hashes implemented in phpass
+itself (also referred to as portable hashes).
+
+
+%prep
+%setup -q -n phpass-%{version}
+
+cp -a %{SOURCE1} README.devel
+
+
+%build
+
+%install
+mkdir -p %{buildroot}/%{_datadir}/php/phpass
+install -pm 644 PasswordHash.php %{buildroot}%{_datadir}/php/phpass
+
+
+%check
+php test.php | grep PASSED
+
+
+%files
+%doc test.php c README.devel
+%dir %{_datadir}/php/phpass
+%{_datadir}/php/phpass/PasswordHash.php
+
+
+%changelog
+* Sun Dec 16 2012 Gregor Tätzner <brummbq@fedoraproject.org> - 0.3-2
+- enabled tests
+
+* Tue Dec 11 2012 Gregor Tätzner <brummbq@fedoraproject.org> - 0.3-1
+- Initial package
+
diff --git a/phpass-README.devel b/phpass-README.devel
new file mode 100644
index 0000000..9bb2fbe
--- /dev/null
+++ b/phpass-README.devel
@@ -0,0 +1,7 @@
+Included in this package are also a tiny PHP application demonstrating the use of the
+PasswordHash class, and a C reimplementation of the portable hashes (used for
+testing correctness of the primary implementation only).
+
+You can use the 'make' utility to compile the test C-code.
+
+See also this tutorial: http://www.openwall.com/articles/PHP-Users-Passwords