summaryrefslogtreecommitdiffstats
path: root/php-phalcon3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-08-21 07:18:37 +0200
committerRemi Collet <remi@remirepo.net>2018-08-21 07:18:37 +0200
commit6a7fe9ca111f177b4dd2ec517b187cb101d8194b (patch)
tree772e7dc3e8757ef074f9dad743304ca17b6fa8fa /php-phalcon3.spec
parented34c39364268b102d5044e438300de565e3403d (diff)
update to 3.4.1 using zephir 0.10.10
Diffstat (limited to 'php-phalcon3.spec')
-rw-r--r--php-phalcon3.spec23
1 files changed, 16 insertions, 7 deletions
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index 328bbaa..61cfbb0 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -24,7 +24,8 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{?_with_tests:1}
%global ext_name phalcon
-%global zephir_ver 0.11
+%global zephir_min 0.10.10
+%global zephir_max 0.11
%if "%{php_version}" < "5.6"
# after pdo.ini, json.ini, igbinary.ini
%global ini_name z-%{ext_name}.ini
@@ -35,7 +36,7 @@
Name: %{?sub_prefix}php-phalcon3
Version: 3.4.1
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
Group: Development/Libraries
@@ -55,8 +56,13 @@ BuildRequires: %{?scl_prefix}php-devel > 5.5
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pdo
# For sources generation
-%if 0%{?zephir_ver:1}
-BuildRequires: %{?scl_prefix}zephir >= %{zephir_ver}
+%if 0%{?zephir_min:1}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (%{?scl_prefix}zephir >= %{zephir_min} with %{?scl_prefix}zephir < %{zephir_max})
+%else
+BuildRequires: %{?scl_prefix}zephir < %{zephir_max}
+BuildRequires: %{?scl_prefix}zephir >= %{zephir_min}
+%endif
BuildRequires: %{?scl_prefix}php-gd
BuildRequires: %{?scl_prefix}php-pecl(libsodium)
BuildRequires: %{?scl_prefix}php-mbstring
@@ -157,13 +163,13 @@ peclconf() {
: Generate the SAFE sources - optimization seems no more needed
%if "%{php_version}" > "7.0"
-%if 0%{?zephir_ver:1}
-%{_bindir}/zephir generate
+%if 0%{?zephir_min:1}
+%{_bindir}/zephir generate --backend=ZendEngine3
%endif
%{__php} build/gen-build.php
mv build/php7/safe build/NTS
%else
-%if 0%{?zephir_ver:1}
+%if 0%{?zephir_min:1}
%{_bindir}/zephir generate --backend=ZendEngine2
%endif
%{__php} build/gen-build.php
@@ -256,6 +262,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Aug 21 2018 Remi Collet <remi@remirepo.net> - 3.4.1-2
+- update to 3.4.1 using zephir 0.10.10
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 3.4.1-1
- update to 3.4.1 using zephir 0.11.0
- open https://github.com/phalcon/cphalcon/issues/13465