summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION59
-rw-r--r--php-phalcon3.spec23
3 files changed, 71 insertions, 15 deletions
diff --git a/PHPINFO b/PHPINFO
index 84d018f..b6620f1 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,8 +5,8 @@ phalcon
Web framework delivered as a C-extension for PHP
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 3.4.0
-Build Date => May 28 2018 11:05:33
+Version => 3.4.1
+Build Date => Aug 21 2018 07:13:36
Powered by Zephir => Version 0.10.10
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 89cebdf..4a74a1b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #191 phalcon version 3.4.0 ] {
+Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
- INI {
Entry [ phalcon.db.escape_identifiers <ALL> ]
@@ -12267,7 +12267,7 @@ Extension [ <persistent> extension #191 phalcon version 3.4.0 ] {
- Static methods [0] {
}
- - Properties [19] {
+ - Properties [21] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_uriSource ]
@@ -12287,9 +12287,31 @@ Extension [ <persistent> extension #191 phalcon version 3.4.0 ] {
Property [ <default> protected $_defaultParams ]
Property [ <default> protected $_removeExtraSlashes ]
Property [ <default> protected $_notFoundPaths ]
+ Property [ <default> protected $_keyRouteNames ]
+ Property [ <default> protected $_keyRouteIds ]
}
- - Methods [42] {
+ - Methods [46] {
+ Method [ <internal:phalcon> public method getKeyRouteNames ] {
+ }
+
+ Method [ <internal:phalcon> public method setKeyRouteNames ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $keyRouteNames ]
+ }
+ }
+
+ Method [ <internal:phalcon> public method getKeyRouteIds ] {
+ }
+
+ Method [ <internal:phalcon> public method setKeyRouteIds ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $keyRouteIds ]
+ }
+ }
+
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [1] {
@@ -38245,7 +38267,7 @@ Extension [ <persistent> extension #191 phalcon version 3.4.0 ] {
- Static methods [0] {
}
- - Properties [23] {
+ - Properties [25] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_uriSource ]
@@ -38265,13 +38287,15 @@ Extension [ <persistent> extension #191 phalcon version 3.4.0 ] {
Property [ <default> protected $_defaultParams ]
Property [ <default> protected $_removeExtraSlashes ]
Property [ <default> protected $_notFoundPaths ]
+ Property [ <default> protected $_keyRouteNames ]
+ Property [ <default> protected $_keyRouteIds ]
Property [ <default> protected $_handlers ]
Property [ <default> protected $_controllerSuffix ]
Property [ <default> protected $_actionSuffix ]
Property [ <default> protected $_routePrefix ]
}
- - Methods [49] {
+ - Methods [53] {
Method [ <internal:phalcon> public method addResource ] {
- Parameters [2] {
@@ -38332,6 +38356,26 @@ Extension [ <persistent> extension #191 phalcon version 3.4.0 ] {
Method [ <internal:phalcon> public method getResources ] {
}
+ Method [ <internal:phalcon, inherits Phalcon\Mvc\Router> public method getKeyRouteNames ] {
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Mvc\Router> public method setKeyRouteNames ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $keyRouteNames ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Mvc\Router> public method getKeyRouteIds ] {
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Mvc\Router> public method setKeyRouteIds ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $keyRouteIds ]
+ }
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Mvc\Router, ctor> public method __construct ] {
- Parameters [1] {
@@ -38826,7 +38870,10 @@ Extension [ <persistent> extension #191 phalcon version 3.4.0 ] {
Property [ <default> protected $_group ]
}
- - Methods [24] {
+ - Methods [25] {
+ Method [ <internal:phalcon> public method getId ] {
+ }
+
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [3] {
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index 328bbaa..61cfbb0 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -24,7 +24,8 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{?_with_tests:1}
%global ext_name phalcon
-%global zephir_ver 0.11
+%global zephir_min 0.10.10
+%global zephir_max 0.11
%if "%{php_version}" < "5.6"
# after pdo.ini, json.ini, igbinary.ini
%global ini_name z-%{ext_name}.ini
@@ -35,7 +36,7 @@
Name: %{?sub_prefix}php-phalcon3
Version: 3.4.1
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
Group: Development/Libraries
@@ -55,8 +56,13 @@ BuildRequires: %{?scl_prefix}php-devel > 5.5
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pdo
# For sources generation
-%if 0%{?zephir_ver:1}
-BuildRequires: %{?scl_prefix}zephir >= %{zephir_ver}
+%if 0%{?zephir_min:1}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (%{?scl_prefix}zephir >= %{zephir_min} with %{?scl_prefix}zephir < %{zephir_max})
+%else
+BuildRequires: %{?scl_prefix}zephir < %{zephir_max}
+BuildRequires: %{?scl_prefix}zephir >= %{zephir_min}
+%endif
BuildRequires: %{?scl_prefix}php-gd
BuildRequires: %{?scl_prefix}php-pecl(libsodium)
BuildRequires: %{?scl_prefix}php-mbstring
@@ -157,13 +163,13 @@ peclconf() {
: Generate the SAFE sources - optimization seems no more needed
%if "%{php_version}" > "7.0"
-%if 0%{?zephir_ver:1}
-%{_bindir}/zephir generate
+%if 0%{?zephir_min:1}
+%{_bindir}/zephir generate --backend=ZendEngine3
%endif
%{__php} build/gen-build.php
mv build/php7/safe build/NTS
%else
-%if 0%{?zephir_ver:1}
+%if 0%{?zephir_min:1}
%{_bindir}/zephir generate --backend=ZendEngine2
%endif
%{__php} build/gen-build.php
@@ -256,6 +262,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Aug 21 2018 Remi Collet <remi@remirepo.net> - 3.4.1-2
+- update to 3.4.1 using zephir 0.10.10
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 3.4.1-1
- update to 3.4.1 using zephir 0.11.0
- open https://github.com/phalcon/cphalcon/issues/13465