summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-13 07:48:35 +0200
committerRemi Collet <remi@remirepo.net>2017-10-13 07:48:35 +0200
commit47fa94996e24396ab3ed38137b2233791b99b498 (patch)
treeed288ff9554ff10b07dde0ad2708d334c9507765
parent477714e8a0fd883ad34dd6b42629bdae67606d24 (diff)
Update to 3.2.3 using zephir 0.10.3
-rw-r--r--REFLECTION33
-rw-r--r--composer.json59
-rw-r--r--php-phalcon3.spec24
3 files changed, 93 insertions, 23 deletions
diff --git a/REFLECTION b/REFLECTION
index 3225e45..869c653 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
+Extension [ <persistent> extension #179 phalcon version 3.2.3 ] {
- INI {
Entry [ phalcon.db.escape_identifiers <ALL> ]
@@ -10927,7 +10927,7 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
- Static methods [0] {
}
- - Properties [22] {
+ - Properties [23] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_activeHandler ]
@@ -10950,9 +10950,10 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
Property [ <default> protected $_previousActionName ]
Property [ <default> protected $_modelBinding ]
Property [ <default> protected $_modelBinder ]
+ Property [ <default> protected $_isControllerInitialize ]
}
- - Methods [35] {
+ - Methods [34] {
Method [ <internal:phalcon, prototype Phalcon\Di\InjectionAwareInterface> public method setDI ] {
- Parameters [1] {
@@ -11102,9 +11103,6 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
Method [ <internal:phalcon, prototype Phalcon\DispatcherInterface> public method dispatch ] {
}
- Method [ <internal:phalcon> protected method _dispatch ] {
- }
-
Method [ <internal:phalcon, prototype Phalcon\DispatcherInterface> public method forward ] {
- Parameters [1] {
@@ -16730,7 +16728,7 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
- Static methods [0] {
}
- - Properties [23] {
+ - Properties [24] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_activeHandler ]
@@ -16750,13 +16748,14 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
Property [ <default> protected $_previousActionName ]
Property [ <default> protected $_modelBinding ]
Property [ <default> protected $_modelBinder ]
+ Property [ <default> protected $_isControllerInitialize ]
Property [ <default> protected $_handlerSuffix ]
Property [ <default> protected $_defaultHandler ]
Property [ <default> protected $_defaultAction ]
Property [ <default> protected $_options ]
}
- - Methods [47] {
+ - Methods [46] {
Method [ <internal:phalcon, prototype Phalcon\Cli\DispatcherInterface> public method setTaskSuffix ] {
- Parameters [1] {
@@ -16986,9 +16985,6 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
Method [ <internal:phalcon, inherits Phalcon\Dispatcher, prototype Phalcon\DispatcherInterface> public method dispatch ] {
}
- Method [ <internal:phalcon, inherits Phalcon\Dispatcher> protected method _dispatch ] {
- }
-
Method [ <internal:phalcon, inherits Phalcon\Dispatcher, prototype Phalcon\DispatcherInterface> public method forward ] {
- Parameters [1] {
@@ -27391,7 +27387,10 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
Property [ <default> protected $_cookies ]
}
- - Methods [10] {
+ - Methods [11] {
+ Method [ <internal:phalcon, ctor> public method __construct ] {
+ }
+
Method [ <internal:phalcon, prototype Phalcon\Di\InjectionAwareInterface> public method setDI ] {
- Parameters [1] {
@@ -30551,7 +30550,7 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
- Static methods [0] {
}
- - Properties [22] {
+ - Properties [23] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_activeHandler ]
@@ -30571,12 +30570,13 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
Property [ <default> protected $_previousActionName ]
Property [ <default> protected $_modelBinding ]
Property [ <default> protected $_modelBinder ]
+ Property [ <default> protected $_isControllerInitialize ]
Property [ <default> protected $_handlerSuffix ]
Property [ <default> protected $_defaultHandler ]
Property [ <default> protected $_defaultAction ]
}
- - Methods [47] {
+ - Methods [46] {
Method [ <internal:phalcon, prototype Phalcon\Mvc\DispatcherInterface> public method setControllerSuffix ] {
- Parameters [1] {
@@ -30790,9 +30790,6 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
Method [ <internal:phalcon, inherits Phalcon\Dispatcher, prototype Phalcon\DispatcherInterface> public method dispatch ] {
}
- Method [ <internal:phalcon, inherits Phalcon\Dispatcher> protected method _dispatch ] {
- }
-
Method [ <internal:phalcon, inherits Phalcon\Dispatcher> public method wasForwarded ] {
}
@@ -38775,7 +38772,7 @@ Extension [ <persistent> extension #177 phalcon version 3.2.2 ] {
Method [ <internal:phalcon, prototype Phalcon\Mvc\ViewInterface> public method getActionName ] {
}
- Method [ <internal:phalcon, prototype Phalcon\Mvc\ViewInterface> public method getParams ] {
+ Method [ <internal, deprecated:phalcon, prototype Phalcon\Mvc\ViewInterface> public method getParams ] {
}
Method [ <internal:phalcon, prototype Phalcon\Mvc\ViewInterface> public method start ] {
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..d59ea21
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,59 @@
+{
+ "name": "phalcon/cphalcon",
+ "description": "Phalcon is an open source web framework delivered as a C extension for the PHP language providing high performance and lower resource consumption.",
+ "keywords": [
+ "extension",
+ "phalcon",
+ "framework",
+ "high load",
+ "mvc"
+ ],
+ "require": {
+ "php": ">=5.5"
+ },
+ "require-dev": {
+ "doctrine/instantiator": "1.0.5",
+ "phpdocumentor/reflection-docblock": "^2.0",
+ "phpunit/phpunit": "^4.8",
+ "mustache/mustache": "^2.11",
+ "twig/twig": "~1.34",
+ "predis/predis": "^1.1",
+ "codeception/codeception": "^2.3",
+ "codeception/verify": "^0.3",
+ "codeception/specify": "^0.4",
+ "squizlabs/php_codesniffer": "^2.9",
+ "phalcon/zephir": "^0.10"
+ },
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Phalcon Team",
+ "email": "team@phalconphp.com",
+ "homepage": "https://phalconphp.com/en/team"
+ },
+ {
+ "name": "Contributors",
+ "homepage": "https://github.com/phalcon/cphalcon/graphs/contributors"
+ }
+ ],
+ "autoload-dev": {
+ "psr-4": {
+ "Zephir\\Optimizers\\": "optimizers/",
+ "Phalcon\\Test\\Unit\\": "tests/unit/",
+ "Phalcon\\Test\\Unit5x\\": "tests/unit5x/",
+ "Phalcon\\Test\\Integration\\": "tests/integration/",
+ "Phalcon\\Test\\Module\\": "tests/_support/Module/",
+ "Phalcon\\Test\\Listener\\": "tests/_data/listener/"
+ }
+ },
+ "support": {
+ "issues": "https://github.com/phalcon/cphalcon/issues",
+ "source": "https://github.com/phalcon/cphalcon",
+ "forum": "https://forum.phalconphp.com/",
+ "docs": "https://docs.phalconphp.com/",
+ "wiki": "https://github.com/phalcon/cphalcon/wiki",
+ "irc": "irc://irc.freenode.org/phalconphp",
+ "rss" : "https://blog.phalconphp.com/rss",
+ "email": "support@phalconphp.com"
+ }
+}
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index 9d52efc..aad4028 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -13,13 +13,14 @@
%global pkg_name %{name}
%endif
-%global gh_commit 44ce3c6d5d00cfe0626ff09c0ce4b825e39389d0
+%global gh_commit a8635777097ac4b3ad6c51ec6bc1fe5fb86ca90e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{?_with_tests:1}
%global ext_name phalcon
+%global zephir_ver 0.10.3
%if "%{php_version}" < "5.6"
# after pdo.ini, json.ini, igbinary.ini
%global ini_name z-%{ext_name}.ini
@@ -29,7 +30,7 @@
%endif
Name: %{?sub_prefix}php-phalcon3
-Version: 3.2.2
+Version: 3.2.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
@@ -49,12 +50,17 @@ BuildRequires: %{?scl_prefix}php-devel > 5.5
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pdo
# For sources generation
-BuildRequires: %{?scl_prefix}zephir >= 0.9.11
+%if 0%{?zephir_ver:1}
+BuildRequires: %{?scl_prefix}zephir >= %{zephir_ver}
BuildRequires: %{?scl_prefix}php-gd
BuildRequires: %{?scl_prefix}php-pecl(libsodium)
BuildRequires: %{?scl_prefix}php-mbstring
-BuildRequires: %{?scl_prefix}php-msgpack
+BuildRequires: %{?scl_prefix}php-memcached
BuildRequires: %{?scl_prefix}php-imagick
+BuildRequires: %{?scl_prefix}php-yaml
+# pull php-pecl-apcu (PHP 5) or php-pecl-apcu-bc (PHP 7)
+BuildRequires: %{?scl_prefix}php-apc
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -146,11 +152,15 @@ peclconf() {
: Generate the SAFE sources - optimization seems no more needed
%if "%{php_version}" > "7.0"
-%{_bindir}/zephir generate --backend=ZendEngine3
+%if 0%{?zephir_ver:1}
+%{_bindir}/zephir generate
+%endif
%{__php} build/gen-build.php
mv build/php7/safe build/NTS
%else
+%if 0%{?zephir_ver:1}
%{_bindir}/zephir generate --backend=ZendEngine2
+%endif
%{__php} build/gen-build.php
mv build/php5/safe build/NTS
%endif
@@ -241,6 +251,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Oct 13 2017 Remi Collet <remi@remirepo.net> - 3.2.3-1
+- Update to 3.2.3 using zephir 0.10.3
+- open https://github.com/phalcon/cphalcon/issues/13117 conflicts
+
* Mon Aug 14 2017 Remi Collet <remi@remirepo.net> - 3.2.2-1
- Update to 3.2.2 using zephir 0.9.11