summaryrefslogtreecommitdiffstats
path: root/php-phalcon3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phalcon3.spec')
-rw-r--r--php-phalcon3.spec24
1 files changed, 19 insertions, 5 deletions
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index 9d52efc..aad4028 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -13,13 +13,14 @@
%global pkg_name %{name}
%endif
-%global gh_commit 44ce3c6d5d00cfe0626ff09c0ce4b825e39389d0
+%global gh_commit a8635777097ac4b3ad6c51ec6bc1fe5fb86ca90e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{?_with_tests:1}
%global ext_name phalcon
+%global zephir_ver 0.10.3
%if "%{php_version}" < "5.6"
# after pdo.ini, json.ini, igbinary.ini
%global ini_name z-%{ext_name}.ini
@@ -29,7 +30,7 @@
%endif
Name: %{?sub_prefix}php-phalcon3
-Version: 3.2.2
+Version: 3.2.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
@@ -49,12 +50,17 @@ BuildRequires: %{?scl_prefix}php-devel > 5.5
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pdo
# For sources generation
-BuildRequires: %{?scl_prefix}zephir >= 0.9.11
+%if 0%{?zephir_ver:1}
+BuildRequires: %{?scl_prefix}zephir >= %{zephir_ver}
BuildRequires: %{?scl_prefix}php-gd
BuildRequires: %{?scl_prefix}php-pecl(libsodium)
BuildRequires: %{?scl_prefix}php-mbstring
-BuildRequires: %{?scl_prefix}php-msgpack
+BuildRequires: %{?scl_prefix}php-memcached
BuildRequires: %{?scl_prefix}php-imagick
+BuildRequires: %{?scl_prefix}php-yaml
+# pull php-pecl-apcu (PHP 5) or php-pecl-apcu-bc (PHP 7)
+BuildRequires: %{?scl_prefix}php-apc
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -146,11 +152,15 @@ peclconf() {
: Generate the SAFE sources - optimization seems no more needed
%if "%{php_version}" > "7.0"
-%{_bindir}/zephir generate --backend=ZendEngine3
+%if 0%{?zephir_ver:1}
+%{_bindir}/zephir generate
+%endif
%{__php} build/gen-build.php
mv build/php7/safe build/NTS
%else
+%if 0%{?zephir_ver:1}
%{_bindir}/zephir generate --backend=ZendEngine2
+%endif
%{__php} build/gen-build.php
mv build/php5/safe build/NTS
%endif
@@ -241,6 +251,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Oct 13 2017 Remi Collet <remi@remirepo.net> - 3.2.3-1
+- Update to 3.2.3 using zephir 0.10.3
+- open https://github.com/phalcon/cphalcon/issues/13117 conflicts
+
* Mon Aug 14 2017 Remi Collet <remi@remirepo.net> - 3.2.2-1
- Update to 3.2.2 using zephir 0.9.11