summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-21 09:15:38 +0100
committerRemi Collet <remi@remirepo.net>2017-11-21 09:15:38 +0100
commit01390b6269f364de9d72f331c883f5b5e0db183a (patch)
tree418d60783195c2a4285cb7c2f975a76ba9fbc2b0
parent6c3b6ecb6651804e6d1daedd83f423eb15444ed2 (diff)
Update to 2.5.1
open https://github.com/pdepend/pdepend/issues/337 missing changelog
-rw-r--r--303.patch23
-rw-r--r--composer.json2
-rw-r--r--php-pdepend-PHP-Depend.spec23
3 files changed, 13 insertions, 35 deletions
diff --git a/303.patch b/303.patch
deleted file mode 100644
index a3e0687..0000000
--- a/303.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From c1b369a621c826c10dbad4c60e67fbd07e12cccd Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 16 May 2017 11:57:30 +0200
-Subject: [PATCH] fix count(): Parameter must be an array or an object that
- implements Countable (php 7.2)
-
----
- src/main/php/PDepend/Metrics/Analyzer/InheritanceAnalyzer.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/main/php/PDepend/Metrics/Analyzer/InheritanceAnalyzer.php b/src/main/php/PDepend/Metrics/Analyzer/InheritanceAnalyzer.php
-index 03c0d6f..7b2aa8b 100644
---- a/src/main/php/PDepend/Metrics/Analyzer/InheritanceAnalyzer.php
-+++ b/src/main/php/PDepend/Metrics/Analyzer/InheritanceAnalyzer.php
-@@ -86,7 +86,7 @@ class InheritanceAnalyzer extends AbstractAnalyzer implements
- *
- * @var array(integer)
- */
-- private $rootClasses = null;
-+ private $rootClasses = array();
-
- /**
- * The maximum depth of inheritance tree value within the analyzed source code.
diff --git a/composer.json b/composer.json
index d5738cf..1c2bc69 100644
--- a/composer.json
+++ b/composer.json
@@ -9,7 +9,7 @@
"symfony/config": "^2.3.0|^3"
},
"require-dev": {
- "phpunit/phpunit": "^4.4.0,<4.8",
+ "phpunit/phpunit": "^4.8|^5.7",
"squizlabs/php_codesniffer": "^2.0.0"
},
"bin": ["src/bin/pdepend"],
diff --git a/php-pdepend-PHP-Depend.spec b/php-pdepend-PHP-Depend.spec
index cbb2bb5..0410ece 100644
--- a/php-pdepend-PHP-Depend.spec
+++ b/php-pdepend-PHP-Depend.spec
@@ -7,7 +7,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0c50874333149c0dad5a2877801aed148f2767ff
+%global gh_commit a479c5204d761d15c506e31ecea8964aa922cfa2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner pdepend
%global gh_project pdepend
@@ -28,8 +28,8 @@
%endif
Name: php-pdepend-PHP-Depend
-Version: 2.5.0
-Release: 5%{?dist}
+Version: 2.5.1
+Release: 1%{?dist}
Summary: PHP_Depend design quality metrics for PHP package
Group: Development/Libraries
@@ -42,16 +42,12 @@ Source1: makesrc.sh
# Autoloader
Patch0: %{name}-rpm.patch
-# https://github.com/pdepend/pdepend/pull/303
-Patch1: 303.patch
-
BuildArch: noarch
%if %{with_tests}
# From composer/json, "require-dev": {
-# "phpunit/phpunit": "^4.4.0,<4.8",
+# "phpunit/phpunit": "^4.8|^5.7",
# "squizlabs/php_codesniffer": "^2.0.0"
-# Test suite pass with PHPUnit 4.8.12 and PHPUnit 5.0.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0.0
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8
BuildRequires: php(language) >= 5.3.7
BuildRequires: php-composer(symfony/dependency-injection) < %{sym_max}
BuildRequires: php-composer(symfony/dependency-injection) >= %{sym_min}
@@ -121,7 +117,6 @@ reusability and maintainability.
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0
-%patch1 -p1
cat << 'EOF' | tee src/main/php/PDepend/autoload.php
<?php
/* Autoloader for %{name} and its dependencies */
@@ -137,6 +132,8 @@ EOF
find src/main/php -name \*php -exec sed -e 's:@package_version@:%{version}:' -i {} \;
find src/test/php -name \*xml -exec sed -e 's:@package_version@:%{version}:' -i {} \;
+# https://github.com/pdepend/pdepend/issues/337
+sed -e '/project.version/s/2.5.0/%{version}/' -i build.properties
%build
@@ -167,7 +164,7 @@ EOF
ret=0
for cmd in php php56 php70 php71 php72; do
if which $cmd; then
- $cmd %{_bindir}/phpunit -d memory_limit=1G --verbose || ret=1
+ $cmd %{_bindir}/phpunit -d memory_limit=1G --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -194,6 +191,10 @@ fi
%changelog
+* Tue Nov 21 2017 Remi Collet <remi@remirepo.net> - 2.5.1-1
+- Update to 2.5.1
+- open https://github.com/pdepend/pdepend/issues/337 missing changelog
+
* Wed Nov 1 2017 Remi Collet <remi@fedoraproject.org> - 2.5.0-5
- fix FTBFS from Koschei, add patch for PHP 7.2 from
https://github.com/pdepend/pdepend/pull/303