summaryrefslogtreecommitdiffstats
path: root/php-pdepend-PHP-Depend.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pdepend-PHP-Depend.spec')
-rw-r--r--php-pdepend-PHP-Depend.spec23
1 files changed, 12 insertions, 11 deletions
diff --git a/php-pdepend-PHP-Depend.spec b/php-pdepend-PHP-Depend.spec
index cbb2bb5..0410ece 100644
--- a/php-pdepend-PHP-Depend.spec
+++ b/php-pdepend-PHP-Depend.spec
@@ -7,7 +7,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0c50874333149c0dad5a2877801aed148f2767ff
+%global gh_commit a479c5204d761d15c506e31ecea8964aa922cfa2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner pdepend
%global gh_project pdepend
@@ -28,8 +28,8 @@
%endif
Name: php-pdepend-PHP-Depend
-Version: 2.5.0
-Release: 5%{?dist}
+Version: 2.5.1
+Release: 1%{?dist}
Summary: PHP_Depend design quality metrics for PHP package
Group: Development/Libraries
@@ -42,16 +42,12 @@ Source1: makesrc.sh
# Autoloader
Patch0: %{name}-rpm.patch
-# https://github.com/pdepend/pdepend/pull/303
-Patch1: 303.patch
-
BuildArch: noarch
%if %{with_tests}
# From composer/json, "require-dev": {
-# "phpunit/phpunit": "^4.4.0,<4.8",
+# "phpunit/phpunit": "^4.8|^5.7",
# "squizlabs/php_codesniffer": "^2.0.0"
-# Test suite pass with PHPUnit 4.8.12 and PHPUnit 5.0.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0.0
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8
BuildRequires: php(language) >= 5.3.7
BuildRequires: php-composer(symfony/dependency-injection) < %{sym_max}
BuildRequires: php-composer(symfony/dependency-injection) >= %{sym_min}
@@ -121,7 +117,6 @@ reusability and maintainability.
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0
-%patch1 -p1
cat << 'EOF' | tee src/main/php/PDepend/autoload.php
<?php
/* Autoloader for %{name} and its dependencies */
@@ -137,6 +132,8 @@ EOF
find src/main/php -name \*php -exec sed -e 's:@package_version@:%{version}:' -i {} \;
find src/test/php -name \*xml -exec sed -e 's:@package_version@:%{version}:' -i {} \;
+# https://github.com/pdepend/pdepend/issues/337
+sed -e '/project.version/s/2.5.0/%{version}/' -i build.properties
%build
@@ -167,7 +164,7 @@ EOF
ret=0
for cmd in php php56 php70 php71 php72; do
if which $cmd; then
- $cmd %{_bindir}/phpunit -d memory_limit=1G --verbose || ret=1
+ $cmd %{_bindir}/phpunit -d memory_limit=1G --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -194,6 +191,10 @@ fi
%changelog
+* Tue Nov 21 2017 Remi Collet <remi@remirepo.net> - 2.5.1-1
+- Update to 2.5.1
+- open https://github.com/pdepend/pdepend/issues/337 missing changelog
+
* Wed Nov 1 2017 Remi Collet <remi@fedoraproject.org> - 2.5.0-5
- fix FTBFS from Koschei, add patch for PHP 7.2 from
https://github.com/pdepend/pdepend/pull/303