summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-12 11:09:37 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-12 11:09:37 +0100
commit101ad62b3a65b9a0a409330706c75afd0eb53435 (patch)
treee6ee3244d0b555992ab7c06043a3e0c8c596a6ca
parent04c61812c822955df51fb92c4b17b9d68de6e5d1 (diff)
php-mock-phpunit: 1.1.1, new package
-rw-r--r--php-mock-phpunit/Makefile4
-rw-r--r--php-mock-phpunit/php-mock-phpunit-upstream.patch60
-rw-r--r--php-mock-phpunit/php-mock-phpunit.spec108
3 files changed, 172 insertions, 0 deletions
diff --git a/php-mock-phpunit/Makefile b/php-mock-phpunit/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/php-mock-phpunit/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-mock-phpunit/php-mock-phpunit-upstream.patch b/php-mock-phpunit/php-mock-phpunit-upstream.patch
new file mode 100644
index 0000000..bdb776a
--- /dev/null
+++ b/php-mock-phpunit/php-mock-phpunit-upstream.patch
@@ -0,0 +1,60 @@
+From 1dad555b26c919ac42803f4d84b72af4aeb529d0 Mon Sep 17 00:00:00 2001
+From: Markus Malkusch <markus@malkusch.de>
+Date: Wed, 11 Nov 2015 23:43:41 +0100
+Subject: [PATCH] [refactor] moved testDefineFunctionMock() into php-mock
+
+---
+ tests/PHPMockTest.php | 33 +++++----------------------------
+ 1 file changed, 5 insertions(+), 28 deletions(-)
+
+diff --git a/tests/PHPMockTest.php b/tests/PHPMockTest.php
+index dd0171c..fe59f78 100644
+--- a/tests/PHPMockTest.php
++++ b/tests/PHPMockTest.php
+@@ -17,6 +17,11 @@ class PHPMockTest extends AbstractMockTest
+
+ use PHPMock;
+
++ protected function defineFunction($namespace, $functionName)
++ {
++ self::defineFunctionMock($namespace, $functionName);
++ }
++
+ protected function mockFunction($namespace, $functionName, callable $function)
+ {
+ $mock = $this->getFunctionMock($namespace, $functionName);
+@@ -28,34 +33,6 @@ protected function disableMocks()
+ }
+
+ /**
+- * Tests defineFunctionMock().
+- *
+- * @test
+- */
+- public function testDefineFunctionMock()
+- {
+- self::defineFunctionMock(__NAMESPACE__, "escapeshellcmd");
+- self::escapeshellcmd("foo");
+-
+- $mock = $this->getFunctionMock(__NAMESPACE__, "escapeshellcmd");
+- $mock->expects($this->once())->willReturn("bar");
+-
+- $this->assertEquals("bar", self::escapeshellcmd("foo"));
+- }
+-
+- /**
+- * Returns the built-in call to escapeshellcmd().
+- *
+- * @param string $command Shell command.
+- *
+- * @return string The built-in call.
+- */
+- private static function escapeshellcmd($command)
+- {
+- return escapeshellcmd($command);
+- }
+-
+- /**
+ * Tests building a mock with arguments.
+ *
+ * @test
diff --git a/php-mock-phpunit/php-mock-phpunit.spec b/php-mock-phpunit/php-mock-phpunit.spec
new file mode 100644
index 0000000..fa86c99
--- /dev/null
+++ b/php-mock-phpunit/php-mock-phpunit.spec
@@ -0,0 +1,108 @@
+# remirepo/fedora spec file for php-mock-phpunit
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit d2edb32ec05584bb6bd8f1b7e94284022fb12d75
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner php-mock
+%global gh_project php-mock-phpunit
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-mock-phpunit
+Version: 1.1.1
+Release: 1%{?dist}
+Summary: Mock built-in PHP functions with PHPUnit.
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+Patch0: %{name}-upstream.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.5
+%if %{with_tests}
+BuildRequires: php-composer(php-mock/php-mock-integration) >= 1
+BuildRequires: php-composer(phpunit/phpunit) > 4
+%endif
+
+# from composer.json, "require": {
+# "php": ">=5.5",
+# "phpunit/phpunit": "^4.0.0 || ^5.0.0",
+# "php-mock/php-mock-integration": "^1"
+Requires: php(language) >= 5.5
+Requires: php-composer(phpunit/phpunit) >= 4
+Requires: php-composer(phpunit/phpunit) < 6
+Requires: php-composer(php-mock/php-mock-integration) >= 1
+Requires: php-composer(php-mock/php-mock-integration) < 2
+# From phpcompatinfo report from version 1.1.1
+# only Core
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Mock built-in PHP functions (e.g. time()) with PHPUnit.
+This package relies on PHP's namespace fallback policy.
+No further extension is needed.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
+
+# Same namespace than php-mock, not specific autoloader needed
+
+
+%build
+# Nothing
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{_datadir}/php/
+mkdir -p %{buildroot}%{_datadir}/php/phpmock
+cp -pr classes %{buildroot}%{_datadir}/php/phpmock/phpunit
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{_datadir}/tests/phpmock/autoload.php';
+$fedoraClassLoader->addPrefix('phpmock\\', '%{buildroot}%{_datadir}/php');
+EOF
+
+%{_bindir}/phpunit
+
+if which php70; then
+ php70 %{_bindir}/phpunit
+fi
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%{_datadir}/php/phpmock/phpunit
+
+
+%changelog
+* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- initial package \ No newline at end of file