summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-01 09:51:10 +0200
committerRemi Collet <remi@remirepo.net>2019-10-01 09:51:10 +0200
commitf5a34136c705727994917402ac0b4a360eeb4803 (patch)
treeb240fff776fd31ec4dfd39e93c24cc0157317f3c
parent012e075c865d936ded0fc5d24be92e945a5dd7f4 (diff)
- add patch for old libmaxmindb in EL-6 from
https://github.com/maxmind/MaxMind-DB-Reader-php/pull/90
-rw-r--r--90.patch46
-rw-r--r--REFLECTION3
-rw-r--r--php-maxminddb.spec12
3 files changed, 57 insertions, 4 deletions
diff --git a/90.patch b/90.patch
new file mode 100644
index 0000000..66b8bcc
--- /dev/null
+++ b/90.patch
@@ -0,0 +1,46 @@
+From cc5731a3b1c0257a7e227443dca69b64f2dbc4d0 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 1 Oct 2019 09:25:39 +0200
+Subject: [PATCH 1/2] expose MMDB_LIB_VERSION to userland
+
+---
+ ext/maxminddb.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/ext/maxminddb.c b/ext/maxminddb.c
+index 91dd706..239decc 100644
+--- a/ext/maxminddb.c
++++ b/ext/maxminddb.c
+@@ -665,6 +665,7 @@ PHP_MINIT_FUNCTION(maxminddb) {
+ maxminddb_obj_handlers.offset = XtOffsetOf(maxminddb_obj, std);
+ maxminddb_obj_handlers.free_obj = maxminddb_free_storage;
+ #endif
++ zend_declare_class_constant_string(maxminddb_ce, "MMDB_LIB_VERSION", sizeof("MMDB_LIB_VERSION")-1, MMDB_lib_version() TSRMLS_CC);
+
+ return SUCCESS;
+ }
+
+From 91e160eaf465d1646f18ecf182271d59ab219d31 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 1 Oct 2019 09:30:37 +0200
+Subject: [PATCH 2/2] skip test when running with extension build against old
+ library
+
+---
+ tests/MaxMind/Db/Test/ReaderTest.php | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tests/MaxMind/Db/Test/ReaderTest.php b/tests/MaxMind/Db/Test/ReaderTest.php
+index 773bedd..3cbd0ff 100644
+--- a/tests/MaxMind/Db/Test/ReaderTest.php
++++ b/tests/MaxMind/Db/Test/ReaderTest.php
+@@ -243,6 +243,9 @@ public function testGetWithPrefixLen()
+ */
+ public function testV6AddressV4Database()
+ {
++ if (defined("MaxMind\\Db\\Reader::MMDB_LIB_VERSION") && version_compare(Reader::MMDB_LIB_VERSION, '1.2.0', '<')) {
++ $this->markTestSkipped('MMDB_LIB_VERSION < 1.2.0');
++ }
+ $reader = new Reader('tests/data/test-data/MaxMind-DB-test-ipv4-24.mmdb');
+ $reader->get('2001::');
+ }
diff --git a/REFLECTION b/REFLECTION
index a25f27f..162abb3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -3,7 +3,8 @@ Extension [ <persistent> extension #200 maxminddb version 1.5.0 ] {
- Classes [1] {
Class [ <internal:maxminddb> class MaxMind\Db\Reader ] {
- - Constants [0] {
+ - Constants [1] {
+ Constant [ public string MMDB_LIB_VERSION ] { 1.2.0 }
}
- Static properties [0] {
diff --git a/php-maxminddb.spec b/php-maxminddb.spec
index cee378a..3799db6 100644
--- a/php-maxminddb.spec
+++ b/php-maxminddb.spec
@@ -32,14 +32,16 @@
Summary: MaxMind DB Reader extension
Name: %{?sub_prefix}php-maxminddb
Version: 1.5.0
-%global rpmrel 1
-Release: %{rpmrel}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo "1".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%global rpmrel 3
+Release: %{rpmrel}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/maxmind/MaxMind-DB-Reader-php/pull/90.patch
+
BuildRequires: %{?scl_prefix}php-devel >= 5.6
BuildRequires: pkgconfig(libmaxminddb) >= 1.0.0
@@ -155,6 +157,8 @@ Autoloader: %{_datadir}/php/MaxMind/Db/Reader/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1 -b .pr90
+
%if %{with_lib}
%{_bindir}/phpab \
--template fedora \
@@ -303,9 +307,11 @@ exit $ret
%changelog
-* Tue Oct 1 2019 Remi Collet <remi@remirepo.net> - 1.5.0-1
+* Tue Oct 1 2019 Remi Collet <remi@remirepo.net> - 1.5.0-3
- update to 1.5.0
- raise dependency on PHP 5.6
+- add patch for old libmaxmindb in EL-6 from
+ https://github.com/maxmind/MaxMind-DB-Reader-php/pull/90
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 1.4.1-2
- rebuild for 7.4.0RC1